Bug 144304 - Seg fault on attempt to print
Summary: Seg fault on attempt to print
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mozilla   
(Show other bugs)
Version: 3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-05 19:46 UTC by John Morris
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:09:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Morris 2005-01-05 19:46:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20041010

Description of problem:
The problem only appears when attempting to print some CGI generated
pages.  Basically, when moz prints it does so by reloading the page in
a subprocess and if the server won't return the page again moz
segfaults instead of throwing an error.  Attempting to do a "Save Page
As..." on the same content also fails but does so correctly by
displaying an error message.

If needed, I can supply the contents (as saved by IE, since Moz won't
save it) of the page causing the problem.

Version-Release number of selected component (if applicable):
mozilla-1.4.3-3.0.4

How reproducible:
Always

Steps to Reproduce:
1. Load a page that won't refresh.

2. Try to save and observe the error, otherwise try another page.

3. Attempt printing.. BOOM!

Additional info:

Comment 1 RHEL Product and Program Management 2007-10-19 19:09:53 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.