Bug 144327 - Applications freeze in dualhead Xinerama mode when scrolled
Applications freeze in dualhead Xinerama mode when scrolled
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-05 18:17 EST by Douglas Phillipson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:40:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Douglas Phillipson 2005-01-05 18:17:13 EST
Description of problem:

Applications freeze randomly when scroll events occur while in
xinerama mode.  In particular it occurs with OpenOffice (any version)
or any app with a scrollbar.


How reproducible:

I have two boxes setup in dual head mode.  Box 1 is a multiport Matrox
video card.  Box 2 has a nVidia Gforce 4 and a ATI card.  In both
cases when I set them up with "Xinerama on", in FC2 or FC3,
applications will randomly freeze when scrolled or when loading a
document into OpenOffice, OO will hang.  Sometimes when Mozilla surfs
to a site like http://www.digitaldutch.com/unitconverter/ the whole
desktop freezes.

This does NOT occur with Xinerama turned off.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mike A. Harris 2005-01-31 20:19:26 EST
Please attach the X server config, X server logs, and /var/log/messages
from each system or configuration in which this problem occurs.

This strongly sounds like a bug in the applications themselves or in
the toolkits they are using, but without more details it's hard to
say.

Please attach an strace/ltrace of the frozen applications, and
if they SEGV, a stack backtrace from the generated corefiles.

Attach all files as individual uncompressed file attachments,
however you can gzip or bzip2 the strace/ltraces as they're likely
to be quite large.

Thanks in advance.
Comment 2 Mike A. Harris 2005-01-31 20:20:06 EST
Setting status to "NEEDINFO" and awaiting all information requested
in comment #1 above.
Comment 3 Mike A. Harris 2005-01-31 20:20:54 EST
Also, please try this using the "vesa" driver on all systems
that show the problem.  This will be slower, but is intended
to help diagnose the issue.

Thanks.
Comment 4 Mike A. Harris 2005-04-15 10:40:26 EDT
This bug has not been updated to provide us with the information
we've requested above.  If you have not already updated to the
latest Fedora Core xorg-x11 and kernel updates, please do so now and
if you still encounter the problem described above, please report the
issue to X.Org bugzilla at http://bugs.freedestop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NOTABUG" due to lack of information.

Note You need to log in before you can comment on or make changes to this bug.