Bug 144393 - strace stops at exec?
strace stops at exec?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 13:58 EST by Tom Lane
Modified: 2013-07-02 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-23 18:16:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Lane 2005-01-06 13:58:55 EST
Description of problem:
I tried to strace a perfectly ordinary program, and got nowhere:
[tgl@rh1 ~]$ strace /home/tgl/testversion/bin/psql -l -h localhost
2>zzz
[tgl@rh1 ~]$ cat zzz
execve("/home/tgl/testversion/bin/psql",
["/home/tgl/testversion/bin/psql", "-l", "-h", "localhost"], [/* 35
vars */]) = 0
[tgl@rh1 ~]$

It seems to just quit after emitting the execve report.

Version-Release number of selected component (if applicable):
strace-4.5.8-1
machine is fully up to date with FC3

How reproducible:
100%

Steps to Reproduce:
1. See above
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Sitsofe Wheeler 2005-01-06 17:43:38 EST
Might be a dup of bug #144070 or bug #144021 ...
Comment 2 redhat-bugs2eran 2005-01-19 06:46:24 EST
This is a dup of bug 144453, where it's reported the problem is fixed
in kernel 2.6.10-1.737_FC3.
Comment 3 Tom Lane 2005-01-23 18:16:08 EST
OK, I can confirm it works again with kernel  2.6.10-1.741_FC3.

Note You need to log in before you can comment on or make changes to this bug.