Bug 144399 - gnome-system-monitor has empty process name fields
Summary: gnome-system-monitor has empty process name fields
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-system-monitor   
(Show other bugs)
Version: 4.0
Hardware: powerpc Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Søren Sandmann Pedersen
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: Desktop
: 149280 (view as bug list)
Depends On:
Blocks: 187538
TreeView+ depends on / blocked
 
Reported: 2005-01-06 19:17 UTC by James Laska
Modified: 2014-06-18 09:07 UTC (History)
5 users (show)

Fixed In Version: RHBA-2006-0326
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-10 22:18:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (130.08 KB, image/png)
2005-01-06 19:17 UTC, James Laska
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2006:0326 normal SHIPPED_LIVE gnome-system-monitor bug fix update 2006-05-10 04:00:00 UTC

Description James Laska 2005-01-06 19:17:55 UTC
# TREE rel-eng/RHEL4-re0106.1::AS
# ARCH ppc (power5 IBM sf2)
# PACKAGE gnome-system-monitor-2.7.0-2

See attached screenshot.

This appears to happen only for kernel processes such as:

root         2     1  0 13:31 ?        00:00:00 [migration/0]
root         3     1  0 13:31 ?        00:00:00 [ksoftirqd/0]
root         4     1  0 13:31 ?        00:00:00 [migration/1]
root         5     1  0 13:31 ?        00:00:00 [ksoftirqd/1]
root         6     1  0 13:31 ?        00:00:00 [migration/2]
root         7     1  0 13:31 ?        00:00:00 [ksoftirqd/2]
root         8     1  0 13:31 ?        00:00:00 [migration/3]
root         9     1  0 13:31 ?        00:00:00 [ksoftirqd/3]
root        10     1  0 13:31 ?        00:00:00 [events/0]
root        11     1  0 13:31 ?        00:00:00 [events/1]
root        12     1  0 13:31 ?        00:00:00 [events/2]
root        13     1  0 13:31 ?        00:00:00 [events/3]
root        14    10  0 13:31 ?        00:00:00 [khelper]
root        46    10  0 13:31 ?        00:00:00 [kblockd/0]
root        47    10  0 13:31 ?        00:00:00 [kblockd/1]
root        48    10  0 13:31 ?        00:00:00 [kblockd/2]
root        49    10  0 13:31 ?        00:00:00 [kblockd/3]
root        66    10  0 13:31 ?        00:00:00 [pdflush]
root        50     1  0 13:31 ?        00:00:00 [khubd]
root        65     1  0 13:31 ?        00:00:00 [rtasd]
root        67    10  0 13:31 ?        00:00:00 [pdflush]
root        69    10  0 13:31 ?        00:00:00 [aio/0]
root        68     1  0 13:31 ?        00:00:00 [kswapd0]
root        70    10  0 13:31 ?        00:00:00 [aio/1]
root        71    10  0 13:31 ?        00:00:00 [aio/2]
root        72    10  0 13:31 ?        00:00:00 [aio/3]
root       150    10  0 13:31 ?        00:00:00 [khvcd]
root       152     1  0 13:31 ?        00:00:00 [kseriod]
root       214     1  0 13:31 ?        00:00:00 [scsi_eh_0]
root       239     1  0 13:31 ?        00:00:00 [kjournald]
root      1176     1  0 13:31 ?        00:00:00 [kjournald]

Comment 1 James Laska 2005-01-06 19:17:55 UTC
Created attachment 109436 [details]
screenshot

Comment 2 Bastien Nocera 2005-09-29 10:09:35 UTC
*** Bug 149280 has been marked as a duplicate of this bug. ***

Comment 3 Bastien Nocera 2005-09-29 10:14:25 UTC
Still occurs on RHEL4. Fixes are in newer gnome-system-monitor.

2004-10-22  Benoît Dejean  <tazforever@dlfp.org>

        * src/proctable.c: (get_process_name): Fixed empty process name. This is
       because of a small change in libgtop. If cmdline is empty, libgtop now
        returns "" instead of NULL (this was not documented at all).
        Now : if procargs is NULL or "", the process name is given by procstate,
else
        procargs is parsed.

Patch is at:
http://cvs.gnome.org/viewcvs/procman/src/proctable.c?r1=1.110&r2=1.111

Comment 12 Steffen Mann 2006-01-30 16:22:50 UTC
Could we please ensure that the patch from the rejected hotfix will make it into
U4 then.

Comment 15 Søren Sandmann Pedersen 2006-04-11 20:49:52 UTC
Devel ack. Note that this bug is already fixed in the 2.7.0-5 build.

Comment 16 Søren Sandmann Pedersen 2006-04-11 21:00:25 UTC
Which means it could be fasttracked ...

Comment 22 Red Hat Bugzilla 2006-05-10 22:18:31 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0326.html



Note You need to log in before you can comment on or make changes to this bug.