Bug 144430 - Installed OS through ispec, but it does not appear to be running any tests
Installed OS through ispec, but it does not appear to be running any tests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: ispec (Show other bugs)
1.8
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Will Woods
Richard Li
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 17:42 EST by Gregg Shick
Modified: 2007-04-18 13:17 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 14:28:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregg Shick 2005-01-06 17:42:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
Using the following components: ispec-0.95-1.8rc1.noarch.rpm / rhr2-
rhel4-0.9-16.rc1a.noarch.rpm / 1220 RHEL 4 release.

1.  Created ispec server following instructions in the pdf. 
2.  Ran ispec, submitted my server configuration, kickstart files 
were created.
3.  Booted to the boot.iso cd on disc1 of the 1220 release.**
4.  ran command linux ks=http://10.0.0.63/ispec/models/server/ks2.cfg
5.  OS completed installation and then rebooted to a console.

At this point, my assumption was that the OS would boot, 
automatically run the desired tests and save results.  I cannot logon 
to the OS because the password is encrypted in the ks file and 
looking through the documentation I cannot find information regarding 
a default password.  


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:


Expected Results:  At this point, my assumption was that the OS would 
boot, automatically run the desired tests and save results.  I cannot 
logon to the OS because the password is encrypted in the ks file and 
looking through the documentation I cannot find information regarding 
a default password.


Additional info:
Comment 1 Richard Li 2005-01-06 17:48:54 EST
The root password is "hwcert". This was pointed out by another tester
and has been fixed in the documentation.

Can you tail -f /var/log/redhat-ready and see if the tests are running?

Due to hardware compatibility issues, for RC we had to switch the
tests to not log to vt12 by default but instead log to a file. The
rhrconsole option (which was not documented at the time of the RC)
allows you to override this.

I apologize for the inadequate documentation; all of the above issues
have been documented now.
Comment 2 Gregg Shick 2005-01-07 09:35:19 EST
Richard

Yeah, it looks like it is running.  Can I ask you a couple of 
extra ?'s?  Specifically on step 6 of the current instructions.  

1.The doc mentions the key we need to use is in 
redhatready2_id_dsa.pub.  I could not find that file, found an 
ispec_id file so I used that instead.  
2. With RHEL3 the .ssh folder was off /root, but the only place I 
could find .ssh on RHEL4 was /var/crash, so I edited the authorized 
keys file here. I am assuming that is correct
3. Do we copy the entire contents of the .pub file into 
authorized_keys2, or just the actual key itself.

Thanks
Gregg
Comment 3 Richard Li 2005-01-07 10:25:51 EST
> Yeah, it looks like it is running.  Can I ask you a couple of 
> extra ?'s?  Specifically on step 6 of the current instructions.  

Thanks for the feedback. I'll work on clarifying the below in the documentation
as well.

> 1.The doc mentions the key we need to use is in 
> redhatready2_id_dsa.pub.  I could not find that file, found an 
> ispec_id file so I used that instead.  

This is the same thing.

> 2. With RHEL3 the .ssh folder was off /root, but the only place I 
> could find .ssh on RHEL4 was /var/crash, so I edited the authorized 
> keys file here. I am assuming that is correct

You may need to create the .ssh/ directory. It should be in /root/.

> 3. Do we copy the entire contents of the .pub file into 
> authorized_keys2, or just the actual key itself.

The entire file, which really is the actual key. You can just cp the file if the
authorized_keys doesn't exist, or append the contents of the entire file to the
authorized_keys if it does exist.
Comment 4 Will Woods 2005-01-07 10:56:53 EST
The commands should go something like this:

mkdir -p /root/.ssh
chmod 700 /root/.ssh
cat /etc/sysconfig/redhatready2_id_dsa.pub >> /root/.ssh/authorized_keys

(the current ispec rc will use ispec_id_dsa.pub, as noted above)
Comment 5 Richard Li 2005-01-19 14:28:45 EST
I believe all these issues have been resolved.

Note You need to log in before you can comment on or make changes to this bug.