Bug 144436 - upgrading from RHEL3 -> RHEL4 turns off httpd
upgrading from RHEL3 -> RHEL4 turns off httpd
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-06 19:19 EST by Ben Levenson
Modified: 2009-08-14 08:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-14 08:03:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Levenson 2005-01-06 19:19:13 EST
Version-Release number of selected component (if applicable):
httpd-2.0.52-9.ent

Steps to Reproduce:
1. install RHEL3, configure httpd for runlevel 3,4,5
2. upgrade to RHEL4
3. httpd is not running after upgrade. chkconfig 
  
Actual results:
chkconfig --list httpd
httpd           0:off   1:off   2:off   3:off   4:off   5:off   6:off


Expected results:
chkconfig --list httpd
httpd           0:off   1:off   2:off   3:on   4:on   5:on   6:off


Additional info:
probably a duplicate of 131919, but I thought I would get something in
bugzilla for RHEL4.

Also, I was left with an httpd.conf.rpmsave and httpd.conf.rpmnew after
upgrade, but no httpd.conf.
Comment 2 Ben Levenson 2005-01-07 14:08:30 EST
> Then something very funky has happened.  Was the RHEL3 httpd.conf modified
> from the default?

Yes.  I expected an httpd.conf.rpmnew, but didn't expect my file to then be
moved to httpd.conf.rpmsave.
Here is some info from the upgrade.log:
...
Upgrading gnome-mime-data-2.4.1-5.i386.
Upgrading apr-0.9.4-24.1.i386.
warning: /etc/httpd/conf/httpd.conf saved as /etc/httpd/conf/httpd.conf.rpmsave
Upgrading atk-1.8.0-2.i386.
Upgrading libart_lgpl-2.3.16-3.i386.
<snip>
Upgrading apr-util-0.9.4-17.i386.
Upgrading httpd-2.0.52-9.ent.i386.
warning: /etc/httpd/conf/httpd.conf created as /etc/httpd/conf/httpd.conf.rpmnew
Upgrading httpd-suexec-2.0.52-9.ent.i386.
...

> I tried and failed to reproduce bug 131919, I hoped it was user error.

I'll run a few more tests.
Comment 3 Joe Orton 2005-01-11 11:10:50 EST
That looks wrong, I don't see how that could happen due to a mere packaging bug.
 Jeremy/Jeff, are there any known anaconda/rpm issues which could cause
something like the above?
Comment 4 daryl herzmann 2005-02-15 23:32:42 EST
Probably related.  I had a similiar issue with up2date after a RHEL3 to RHEL4
migration.  From my upgrade.log file

Upgrading up2date-4.4.5-1.i386.
warning: /etc/sysconfig/rhn/up2date created as /etc/sysconfig/rhn/up2date.rpmnew
warning: /etc/sysconfig/rhn/sources saved as /etc/sysconfig/rhn/sources.rpmsave

Once RHEL4 booted, I had no /etc/sysconfig/rhn/sources file! 

Hope I am not too OT for this bug.
Comment 5 Joe Orton 2005-02-16 05:27:21 EST
What I can hypothesize is happening here with httpd is some weird
behaviour from the upgrade from "httpd" to "httpd + apr + apr-util".

jbj could you have a look at this, am I off-base?

it looks like on the upgrade to the RHEL4 apr package (which replaces
some files previously in the RHEL3 httpd package), httpd is first
being *removed*; the %postun is run removing the chkconfig links, and
a modified httpd.conf is renamed to httpd.conf.rpmsave:

Upgrading gnome-mime-data-2.4.1-5.i386.
Upgrading apr-0.9.4-24.1.i386.
warning: /etc/httpd/conf/httpd.conf saved as
/etc/httpd/conf/httpd.conf.rpmsave
Upgrading atk-1.8.0-2.i386.
...

then later on httpd is installed as fresh:

Upgrading httpd-2.0.52-9.ent.i386.
warning: /etc/httpd/conf/httpd.conf created as
/etc/httpd/conf/httpd.conf.rpmnew
warning: /etc/sysconfig/httpd created as /etc/sysconfig/httpd.rpmnew
Upgrading httpd-suexec-2.0.52-9.ent.i386.

except RPM still had some memory that httpd.conf did exist, so it
created httpd.conf.rpmsave instead.

I can reproduce this at will...
Comment 6 Joe Orton 2005-02-18 03:48:17 EST
I'm going to presume this is some RPM bug, though possibly it is
anaconda related.  If instead there's some packaging mistake which I
can correct I'm just as happy to hear what it is...
Comment 7 daryl herzmann 2005-08-18 12:03:09 EDT
What is the status of this bug?  I am still seeing it on RHEL4U1 updates.  This
routinely happens to httpd and up2date, where httpd.conf.rpmnew will be created
with no httpd.conf . And /etc/sysconfig/rhn/up2date.rpmnew is created with no
/etc/sysconfig/rhn/up2date (or the sources file will have a similiar fate).

Comment 9 Jeff Johnson 2006-01-19 21:39:08 EST
Bug or not, the behavior in rpm has been exactly the same for years. Guessing
that it's an rpm bug and asking how to fix your packaging has the burden of proof
going the wrong way.
Comment 10 Joe Orton 2009-08-14 08:03:04 EDT
I was never able to reproduce this.   If anybody is able to reproduce the bug and is still affected by the issue, please reopen.

Note You need to log in before you can comment on or make changes to this bug.