Bug 144442 - [PATCH] compile error when CONFIG_ACPI_DEBUG is set
Summary: [PATCH] compile error when CONFIG_ACPI_DEBUG is set
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: x86_64
OS: Linux
medium
low
Target Milestone: ---
Assignee: Brian Maly
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-07 02:36 UTC by David Lehman
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 19:40:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to call ACPI_DEBUG_TRACE in machine_reset (457 bytes, patch)
2005-01-07 02:36 UTC, David Lehman
no flags Details | Diff

Description David Lehman 2005-01-07 02:36:05 UTC
Description of problem:
When rebuilding the kernel on x86_64 with CONFIG_ACPI_DEBUG enabled you get a
compile error because of a missing call to ACPI_DEBUG_TRACE in acpi_machine_reset.

Version-Release number of selected component (if applicable):
kernel-2.4.21-27.EL

How reproducible:
Always

Steps to Reproduce:
1. Enable CONFIG_ACPI_DEBUG, then try to rebuild the kernel on RHEL3-U4 x86_64
2.
3.
  
Actual results:
Fails with the following error:
bus.c:1856: `_dbg\' undeclared (first use in this function)
bus.c:1856: (Each undeclared identifier is reported only once
bus.c:1856: for each function it appears in.)

Expected results:
Build completes successfully

Additional info:

Comment 1 David Lehman 2005-01-07 02:36:06 UTC
Created attachment 109453 [details]
Patch to call ACPI_DEBUG_TRACE in machine_reset

Comment 4 Red Hat Bugzilla 2007-03-18 22:29:06 UTC
User jparadis@redhat.com's account has been closed


Note You need to log in before you can comment on or make changes to this bug.