Bug 144449 - httpd in Fedora Core 3 requires libdb-4.0 which does not appear to be shipped with FC3
httpd in Fedora Core 3 requires libdb-4.0 which does not appear to be shipped...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 01:10 EST by Hugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-12 03:53:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hugh 2005-01-07 01:10:47 EST
Description of problem:

httpd-2.0.52-3 shipped with Fedora Core 3 dated Nov 2004 requires
library libdb-4.0.so. FC 3 doesn't install this library, and I could
not find a compat- RPM for that version of libdb on either the CD
images or an update site as of 7 Jan 2005.

Work-around which hasn't broken anything (yet) is to install the
compat-db-4.1 RPM and manually symlink libdb-4.0 -> libdb-4.1


How reproducible:

Upgrade a RedHat 9 server to Fedora Core 3.

A clean install of Fedora Core 3 server might have the same problem.


Additional info:

As compat-db-4.0 was part of Fedora Core 1 (and 2?) I suspect that
people upgrading from those systems won't encounter this problem. I
went directly from RH9 to FC3 on our server.

httpd also requires libldap.so.2, but that can be installed from
compat-openldap-2.1.30
Comment 1 Joe Orton 2005-01-07 04:12:48 EST
I think something on your system is confused.

$ rpm -qp --requires httpd-2.0.52-3.i386.rpm | grep libdb
libdb-4.2.so
$ rpm -qp --requires httpd-2.0.52-3.i386.rpm  | grep libldap
libldap-2.2.so.7

try an install from scratch.
Comment 2 Hugh 2005-01-11 23:10:18 EST
I agree that something is confused. I have removed and reinstalled
httpd on the affected Fedora Core 3 system twice, and the unresolved
library problem re-occurs each time. Another FC3 machine on which I
did an overwrite & clean install (from the same CD) does not.

Installing from scratch does fix the problem, but that defeats the
usefulness of being able to upgrade your existing machine!

Here is the architecture, RPM list, and output from ldd on a freshly
installed 'workstation' P4 system with all existing partitions
overwritten:

# uname -a
Linux thridi 2.6.9-1.724_FC3 #1 Sun Jan 2 15:43:49 EST 2005 i686 i686
i386 GNU/Linux
# rpm -q -a | grep httpd 
httpd-2.0.52-3.1
httpd-suexec-2.0.52-3.1
# ldd /usr/sbin/httpd
        libpcre.so.0 => /lib/libpcre.so.0 (0x00891000)
        libpcreposix.so.0 => /usr/lib/libpcreposix.so.0 (0x003d8000)
        libaprutil-0.so.0 => /usr/lib/libaprutil-0.so.0 (0x00a05000)
        libldap-2.2.so.7 => /usr/lib/libldap-2.2.so.7 (0x005d0000)
        liblber-2.2.so.7 => /usr/lib/liblber-2.2.so.7 (0x0071d000)
        libdb-4.2.so => /lib/tls/i686/libdb-4.2.so (0x00111000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x00a61000)
        libapr-0.so.0 => /usr/lib/libapr-0.so.0 (0x001df000)
        librt.so.1 => /lib/tls/librt.so.1 (0x007ac000)
        libm.so.6 => /lib/tls/libm.so.6 (0x00b5d000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00e12000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x0072e000)
        libdl.so.2 => /lib/libdl.so.2 (0x003bc000)
        libc.so.6 => /lib/tls/libc.so.6 (0x00201000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x0032b000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x0033f000)
        libssl.so.4 => /lib/libssl.so.4 (0x00f8c000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x003db000)
        /lib/ld-linux.so.2 (0x00b1c000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x0096a000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00353000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x00629000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00be7000)
        libz.so.1 => /usr/lib/libz.so.1 (0x008a6000)


Here's the architecture, RPM list, and output from ldd on the upgraded
'server' system. It is a P3 machine formerly running Red Hat 9. I have
marked the five shared libraries that are different, one of which
doesn't exist and prevents httpd from running.

# uname -a
Linux ephebe 2.6.9-1.724_FC3 #1 Sun Jan 2 15:43:49 EST 2005 i686 i686
i386 GNU/Linux
# rpm -q -a | grep httpd
httpd-2.0.52-3.1
httpd-suexec-2.0.52-3.1
# ldd /usr/sbin/httpd
        libpcre.so.0 => /lib/libpcre.so.0 (0x0012a000)
        libpcreposix.so.0 => /usr/lib/libpcreposix.so.0 (0x00598000)
        libaprutil-0.so.0 => /usr/lib/libaprutil-0.so.0 (0x00a7d000)
        libldap-2.2.so.7 => /usr/lib/libldap-2.2.so.7 (0x0092a000)
        liblber-2.2.so.7 => /usr/lib/liblber-2.2.so.7 (0x00ef2000)
        libdb-4.2.so => /lib/tls/i686/libdb-4.2.so (0x00497000)
        libexpat.so.0 => /usr/lib/libexpat.so.0 (0x0013a000)
        libapr-0.so.0 => /usr/lib/libapr-0.so.0 (0x00159000)
        librt.so.1 => /lib/tls/librt.so.1 (0x00867000)
        libm.so.6 => /lib/tls/libm.so.6 (0x0017a000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x00c96000)
        libpthread.so.0 => /lib/tls/libpthread.so.0 (0x0081a000)
        libdl.so.2 => /lib/libdl.so.2 (0x005dc000)
        libc.so.6 => /lib/tls/libc.so.6 (0x0019d000)
****    libldap.so.2 => /usr/lib/libldap.so.2 (0x00ce8000)
****    liblber.so.2 => /usr/lib/liblber.so.2 (0x00111000)
****    libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x0062e000)
****    libdb-4.0.so => not found
****    libnsl.so.1 => /lib/libnsl.so.1 (0x00ec5000)
        libresolv.so.2 => /lib/libresolv.so.2 (0x00e81000)
        libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0x002c7000)
        libssl.so.4 => /lib/libssl.so.4 (0x00406000)
        libcrypto.so.4 => /lib/libcrypto.so.4 (0x002db000)
        /lib/ld-linux.so.2 (0x0044f000)
        libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00b2f000)
        libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00634000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x00992000)
        libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00906000)
        libz.so.1 => /usr/lib/libz.so.1 (0x003c3000)

Comment 3 Joe Orton 2005-01-12 03:53:24 EST
The cause could also be using an old apr-util package, ensure you have
the FC3 apr-util package.

# rpm -q apr apr-util
apr-0.9.4-23
apr-util-0.9.4-17

If you've ever installed a third-party apr-util package then perhaps
that is the problem.  Regardless, please follow up on
fedora-list@redhat.com rather than in bugzilla since this is a support
issue not a bug.
Comment 4 Need Real Name 2005-05-12 06:01:51 EDT
The same problem will occure, when using subversion
subversion-1.1.4-1.1.i386.rpm for fedora core 3

Note You need to log in before you can comment on or make changes to this bug.