Bug 144462 - Dovecot user uid not expanded in preinstall scriplet
Dovecot user uid not expanded in preinstall scriplet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: John Dennis
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 07:42 EST by Matthias Saou
Modified: 2014-01-21 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-07 13:38:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2005-01-07 07:42:23 EST
Description of problem:

Looking at the %prein scriplet of the current i386 binary dovecot
package, it seems the spec file's %{dovecot-uid} hasn't been explanded
properly. My guess would be that it's because dashes aren't allowed in
rpm macro names, underscores should be used instead :

preinstall scriptlet (using /bin/sh):
/usr/sbin/useradd -c "dovecot" -u %{dovecot-uid} -s /sbin/nologin -r
-d /usr/libexec/dovecot dovecot 2>/dev/null || :


Version-Release number of selected component (if applicable):

dovecot-0.99.11-7.devel.i386.rpm
Comment 1 John Dennis 2005-01-07 13:38:35 EST
Thank you for catching this! I wonder how I missed that, but I'm glad
you have better eyes than I do :-) Fixed in next.

Note You need to log in before you can comment on or make changes to this bug.