Bug 144506 - fence_apc does not work when using admin account on masterview vm switch
fence_apc does not work when using admin account on masterview vm switch
Status: CLOSED WONTFIX
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
3
All Linux
medium Severity low
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 15:42 EST by mike c
Modified: 2009-04-16 16:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 16:47:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mike c 2005-01-07 15:42:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
fence_apc returns an error when logging onto a masterview vm switch
with the admin account.

Version-Release number of selected component (if applicable):
6.0.0-1.2 (srpm)

How reproducible:
Always

Steps to Reproduce:
1. select the apc_fencing method
2. use the admin account
    

Actual Results:  Jan  7 14:43:17 pktanl1 lock_gulmd_core[2363]:
pktanl2.perimeterco.com missed a heartbeat (time:1105126997810583 mb:1)
Jan  7 14:43:32 pktanl1 lock_gulmd_core[2363]: pktanl2.perimeterco.com
missed a heartbeat (time:1105127012830584 mb:2)
Jan  7 14:43:47 pktanl1 lock_gulmd_core[2363]: pktanl2.perimeterco.com
missed a heartbeat (time:1105127027870583 mb:3)
Jan  7 14:43:47 pktanl1 lock_gulmd_core[2363]: Client
(pktanl2.perimeterco.com) expired
Jan  7 14:43:47 pktanl1 lock_gulmd_core[2363]: Forked [2402]
fence_node pktanl2.perimeterco.com with a 0 pause.
Jan  7 14:43:47 pktanl1 lock_gulmd_core[2402]: Gonna exec fence_node
pktanl2.perimeterco.com
Jan  7 14:43:47 pktanl1 fence_node[2402]: Performing fence method,
power, on pktanl2.perimeterco.com.
Jan  7 14:43:49 pktanl1 fence_node[2402]: The agent (fence_apc) reports:
Jan  7 14:43:49 pktanl1 fence_node[2402]: failed: unrecognised menu
response

Expected Results:  success: test outlet 2 reboot

Additional info:

the workaround is to *not* use the admin account for fencing.
Comment 1 mike c 2005-01-07 15:43:35 EST
this workaround should probably be mentioned in the documentation.
Comment 2 Adam "mantis" Manthei 2005-01-07 16:49:15 EST
What do you mean by "masterview vm switch"?  What is the model number?
 firmware version?  If it is an APC79xx series switch, support for
this switch wasn't added until GFS-6.0.0-15.  

Could you try running the agent with the command line arguments and
the -v option for both the admin and non-admin accounts?  This will
produce a transcript in /tmp/apclog.  Then post the the logs and the
commands you used to create them as an attachment to this bug?

Thanks!
Comment 3 mike c 2005-01-07 17:02:03 EST
[root@pktanl1 cluster]# fence_apc -T -a 10.25.19.44 -l admin -p ****
-n 1:2 -v
failed: unrecognised menu response

[root@pktanl1 cluster]# cat /tmp/apclog

User Name : admin
Password  : ******


American Power Conversion               Web/SNMP Management Card AOS 
   v2.5.5
(c) Copyright 2000 All Rights Reserved  MasterSwitch VM APP          
   v1.1.1
-------------------------------------------------------------------------------
Name      : Unknown                     Date    : 01/07/2005
Contact   : Unknown                     Time    : 16:59:04
Location  : Unknown                     Up Time : 52 Days 9 Hours 8
Minutes
Status    : P+ N+ A+                    User    : Administrator

MasterSwitch VM 1 Load: 6 of 15 amps [41%] (MasterSwitch VM )
MasterSwitch VM 2 Load: 5 of 15 amps [36%] (MasterSwitch VM )

------- Control Console
-------------------------------------------------------

     1- Device Manager
     2- Network
     3- System
     4- Logout

     ?- Help, <ESC>- Main Menu, <ENTER>- Refresh, <CTRL-L>- Event Log
> 1

------- Device Manager
--------------------------------------------------------

     1- MasterSwitch VM 1
     2- MasterSwitch VM 2
     3- Synchset Configuration

     <ESC>- Back, <ENTER>- Refresh, <CTRL-L>- Event Log
Comment 4 mike c 2005-01-07 17:20:34 EST
oops, here's the one that works with the non-admin account...

[root@pktanl1 cluster]# fence_apc -T -a 10.25.19.44 -l cluster -p ****
-n 1:2 -v-v
success: test outlet 2 reboot

[root@pktanl1 cluster]# cat /tmp/apclog
User Name : cluster
Password  : *******


American Power Conversion               Web/SNMP Management Card AOS 
   v2.5.5
(c) Copyright 2000 All Rights Reserved  MasterSwitch VM APP          
   v1.1.1
-------------------------------------------------------------------------------
Name      : Unknown                     Date    : 01/07/2005
Contact   : Unknown                     Time    : 17:17:25
Location  : Unknown                     Up Time : 52 Days 9 Hours 27
Minutes
Status    : P+ N+ A+                    User    : Outlet User

MasterSwitch VM 1 Load: 6 of 15 amps [41%] (MasterSwitch VM )
MasterSwitch VM 2 Load: 5 of 15 amps [36%] (MasterSwitch VM )

------- Control Console
-------------------------------------------------------

     1- Device Manager
     2- Network
     3- System
     4- Logout

     ?- Help, <ESC>- Main Menu, <ENTER>- Refresh
> 1

------- Device Manager
--------------------------------------------------------

     1- 1:1     Analysis1                ON
     2- 1:2     Analysis2                ON
     3- ALL Accessible Outlets

     <ESC>- Back, <ENTER>- Refresh
> 2

------- 1:2
-------------------------------------------------------------------

        Outlet Name : Analysis2
        Outlet State: ON

     1- Immediate On
     2- Immediate Off
     3- Immediate Reboot
     4- Delayed On
     5- Delayed Off
     6- Delayed Reboot
     7- Cancel

     ?- Help, <ESC>- Back, <ENTER>- Refresh
> 3
       
-----------------------------------------------------------------------
        Immediate Reboot

        This command will immediately turn off
        outlet 2 named Analysis2, delay for 05 Seconds,
        and then turn it on.

        Enter 'YES' to continue or <ENTER> to cancel : NO

        Press <ENTER> to continue...
Comment 5 Adam "mantis" Manthei 2005-01-07 17:24:11 EST
I'm struggling to find what the model number of this device would be
on APC's website.  The fence_apc agent has been tested on the
MasterSwitch AP9211 and AP9212 w/ AP9606 mgmt card and APC79xx series
network power switches.  What model number is listed on you switch?
Comment 6 Adam "mantis" Manthei 2005-01-07 17:30:04 EST
I wonder if this has the same problem as mentioned in bug #134489?  
Comment 7 mike c 2005-01-07 17:37:11 EST
oops, here's the one that works with the non-admin account...

[root@pktanl1 cluster]# fence_apc -T -a 10.25.19.44 -l cluster -p ****
-n 1:2 -v-v
success: test outlet 2 reboot

[root@pktanl1 cluster]# cat /tmp/apclog
User Name : cluster
Password  : *******


American Power Conversion               Web/SNMP Management Card AOS 
   v2.5.5
(c) Copyright 2000 All Rights Reserved  MasterSwitch VM APP          
   v1.1.1
-------------------------------------------------------------------------------
Name      : Unknown                     Date    : 01/07/2005
Contact   : Unknown                     Time    : 17:17:25
Location  : Unknown                     Up Time : 52 Days 9 Hours 27
Minutes
Status    : P+ N+ A+                    User    : Outlet User

MasterSwitch VM 1 Load: 6 of 15 amps [41%] (MasterSwitch VM )
MasterSwitch VM 2 Load: 5 of 15 amps [36%] (MasterSwitch VM )

------- Control Console
-------------------------------------------------------

     1- Device Manager
     2- Network
     3- System
     4- Logout

     ?- Help, <ESC>- Main Menu, <ENTER>- Refresh
> 1

------- Device Manager
--------------------------------------------------------

     1- 1:1     Analysis1                ON
     2- 1:2     Analysis2                ON
     3- ALL Accessible Outlets

     <ESC>- Back, <ENTER>- Refresh
> 2

------- 1:2
-------------------------------------------------------------------

        Outlet Name : Analysis2
        Outlet State: ON

     1- Immediate On
     2- Immediate Off
     3- Immediate Reboot
     4- Delayed On
     5- Delayed Off
     6- Delayed Reboot
     7- Cancel

     ?- Help, <ESC>- Back, <ENTER>- Refresh
> 3
       
-----------------------------------------------------------------------
        Immediate Reboot

        This command will immediately turn off
        outlet 2 named Analysis2, delay for 05 Seconds,
        and then turn it on.

        Enter 'YES' to continue or <ENTER> to cancel : NO

        Press <ENTER> to continue...
Comment 8 mike c 2005-01-07 17:40:33 EST
i was able to pull the following from the web interface:

Model Number: 		AP9227
Manufacture Date: 	11/24/2003
Hardware Revision: 	B10
Firmware Revision: 	2.4
Comment 9 mike c 2005-01-11 13:49:20 EST
ok, heres the deal.  if the apc login is configured with access to
multiple power strips, you get an intermediate menu asking what power
strip you want to work with.  the current fence_apc script does not
expect this menu.  my new workaround was to create a seperate user for
each strip.  this seemed to work well enough at first, but then i
noticed that unless you give each user access to every socket on the
strip, the script will occasionally fail with "failed: unrecognised
menu response."
Comment 10 Jim Parsons 2007-09-12 16:47:10 EDT
Closing, as there have been ALOT of updates since this ticket was filed.

Note You need to log in before you can comment on or make changes to this bug.