Bug 144514 - fence_sanbox2: failure path locks user out of admin mode
fence_sanbox2: failure path locks user out of admin mode
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: fence (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-07 16:19 EST by Derek Anderson
Modified: 2009-08-31 14:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-31 14:01:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Anderson 2005-01-07 16:19:11 EST
Description of problem:

If the command fails then the session is currently just closed.  The
sanbox is touchy about this because you were in admin mode.  Even
though the session is dropped the switch still thinks it is in admin
mode and won't allow any one else in there until you manually log in
and execute 'admin cancel'.

When locked out you get this error message.
failed: parallel telnet session

Proposed solution is simply to drop out of admin mode if the command
fails.
@@ -161,6 +161,9 @@
 if (!((($opt_o =~ /disable/i) && ($text =~ /AdminState\ *Offline/i)) ||
     (($opt_o =~ /enable/i) && ($text =~ /AdminState\ *Online/i))))
 {
+  # Get out of admin mode before failing
+  $t->print("admin end");
+  $t->waitfor('/\>/');
   fail "failed: could not change state to $opt_o\n";
 }


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Adam "mantis" Manthei 2005-01-17 19:32:21 EST
Patch applied:

Checking in fence_sanbox2.pl;
/cvs/cluster/cluster/fence/agents/sanbox2/fence_sanbox2.pl,v  <-- 
fence_sanbox2.pl
new revision: 1.2; previous revision: 1.1
done

Checking in fence_sanbox2.pl;
/cvs/cluster/cluster/fence/agents/sanbox2/fence_sanbox2.pl,v  <-- 
fence_sanbox2.pl
new revision: 1.1.2.1; previous revision: 1.1
done
Comment 2 Kiersten (Kerri) Anderson 2005-10-11 18:03:57 EDT
Can we close this one?  Looks like we probably shipped it.

Note You need to log in before you can comment on or make changes to this bug.