Bug 144575 - After booting, kernel panic happens in kernel-2.6.10-1.1074_FC4
After booting, kernel panic happens in kernel-2.6.10-1.1074_FC4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 144590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-08 12:14 EST by sangu
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-28 04:37:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/messages before kernel panic (25.83 KB, text/plain)
2005-01-08 12:28 EST, sangu
no flags Details
Updated patch for slab object scanning (5.02 KB, patch)
2005-01-23 11:08 EST, Manfred Spraul
no flags Details | Diff

  None (edit)
Description sangu 2005-01-08 12:14:37 EST
Description of problem:
after booting, the first keyboard stop, the second mous stop, and kernel panic.

Jan  9 01:03:05 sangu kernel: Unable to handle kernel paging request at virtual
address ca142f44
Jan  9 01:03:05 sangu kernel:  printing eip:
Jan  9 01:03:05 sangu kernel: c01465e0
Jan  9 01:03:05 sangu kernel: *pde = 00028067
Jan  9 01:03:05 sangu kernel: Oops: 0000 [#1]
Jan  9 01:03:05 sangu kernel: DEBUG_PAGEALLOC
Jan  9 01:03:05 sangu kernel: Modules linked in: vfat fat parport_pc lp parport
autofs4 ipt_REJECT ipt_state iptable_filter ipt_MASQUERADE iptable_nat
ip_conntrack ip_tables dm_mod video button battery ac md5 ipv6 ohci_hcd ehci_hcd
i2c_nforce2 i2c_core emu10k1_gp gameport snd_emu10k1_synth snd_emux_synth
snd_seq_virmidi snd_seq_midi_event snd_seq_midi_emul snd_seq snd_emu10k1
snd_rawmidi snd_seq_device snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm
snd_timer snd_page_alloc
snd_util_mem snd_hwdep snd soundcore 8139too mii forcedeth floppy ext3 jbd
Jan  9 01:03:05 sangu kernel: CPU:    0
Jan  9 01:03:05 sangu kernel: EIP:    0060:[<c01465e0>]    Not tainted VLI
Jan  9 01:03:05 sangu kernel: EFLAGS: 00010002   (2.6.10-1.1074_FC4)
Jan  9 01:03:05 sangu kernel: EIP is at check_slabuse+0x33/0xc1
Jan  9 01:03:05 sangu kernel: eax: ca142f44   ebx: c14d3200   ecx: 00000000  
edx: ca142000
Jan  9 01:03:05 sangu kernel: esi: ca142000   edi: 00000000   ebp: c7c1e64c  
esp: dfe50f38
Jan  9 01:03:05 sangu kernel: ds: 007b   es: 007b   ss: 0068
Jan  9 01:03:05 sangu kernel: Process events/0 (pid: 3, threadinfo=dfe50000
task=dffdfa80)
Jan  9 01:03:05 sangu kernel: Stack: 00000000 00000000 c7c1e64c c14d3200
00000005 dfe64ef8 c01466b4 c14d3200
Jan  9 01:03:05 sangu kernel:        c14d3288 c0146bb0 c0402c00 c0402c00
00000293 00000000 c012ca14 c0146ae1
Jan  9 01:03:05 sangu kernel:        ffffffff ffffffff 00000001 00000000
c01176ad 00010000 00000000 dffdfa80
Jan  9 01:03:05 sangu kernel: Call Trace:
Jan  9 01:03:05 sangu kernel:  [<c01466b4>] check_redzone+0x46/0xdf
Jan  9 01:03:05 sangu kernel:  [<c0146bb0>] cache_reap+0xcf/0x29c
Jan  9 01:03:05 sangu kernel:  [<c012ca14>] worker_thread+0x1eb/0x2f0
Jan  9 01:03:05 sangu kernel:  [<c0146ae1>] cache_reap+0x0/0x29c
Jan  9 01:03:05 sangu kernel:  [<c01176ad>] default_wake_function+0x0/0xc
Jan  9 01:03:05 sangu kernel:  [<c0301c11>] schedule+0x457/0x4da
Jan  9 01:03:05 sangu kernel:  [<c01176ad>] default_wake_function+0x0/0xc
Jan  9 01:03:05 sangu kernel:  [<c012c829>] worker_thread+0x0/0x2f0
Jan  9 01:03:05 sangu kernel:  [<c0131425>] kthread+0x69/0x91
Jan  9 01:03:05 sangu kernel:  [<c01313bc>] kthread+0x0/0x91
Jan  9 01:03:05 sangu kernel:  [<c0101215>] kernel_thread_helper+0x5/0xb
Jan  9 01:03:05 sangu kernel: Code: 51 51 f6 40 39 04 0f 84 a6 00 00 00 31 ff 3b
7b 3c 0f 83 9b 00 00 00 8b 73 34 89 d8 0f af f7 03 75 0c 89 f2 e8 84 db ff ff 89
f2 <8b> 00 89 44 24 04 89 d8 e8 91 db ff ff 31 d2 8b 00 81 7c 24 04


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.1074_FC4


How reproducible:
Always

Steps to Reproduce:
1. booting
2. 
3.
  
Actual results:


Expected results:


Additional info:

CPU : AMD Athlon(tm) XP 2600+
Main Board : Abit NF7-II
Comment 1 sangu 2005-01-08 12:28:53 EST
Created attachment 109514 [details]
/var/log/messages before kernel panic
Comment 2 Dave Jones 2005-01-08 19:40:18 EST
*** Bug 144590 has been marked as a duplicate of this bug. ***
Comment 3 Dave Jones 2005-01-08 19:50:47 EST
will be fixed in the next build.  This was caused by an incompatability between
two debugging patches being enabled at the same time.
Comment 4 taj 2005-01-09 21:02:28 EST
Just confirming that the fix works. I ran into the same issue with 1074.

Build 1075 does indeed appear to solve the problem.
Comment 5 Manfred Spraul 2005-01-23 11:08:37 EST
Created attachment 110106 [details]
Updated patch for slab object scanning

The problem was the combination of CONFIG_DEBUG_PAGEALLOC with some new code
that tries to scan all slab objects in the system. Some were unmapped, and that
crashed.
Attached is an update to the patch that does the scanning. It skips potentially
unmapped objects.
Patch vs. 2.6.11-rc6.

Note You need to log in before you can comment on or make changes to this bug.