This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 144597 - (dual-head) cannot see ati display or configure 815 correctly
cannot see ati display or configure 815 correctly
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 03:13 EST by Jim Cornette
Modified: 2014-06-18 05:07 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 15:36:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.conf post dual-head configuration (3.97 KB, text/plain)
2005-01-09 03:18 EST, Jim Cornette
no flags Details
This is my current Xorg.0.log file (33.96 KB, text/plain)
2005-01-09 03:22 EST, Jim Cornette
no flags Details
Attempting to start a fresh config file for xorg-x11 (187 bytes, text/plain)
2005-01-09 03:36 EST, Jim Cornette
no flags Details
Log for Severn system used yesterday, no dual-head ability (30.03 KB, text/plain)
2005-01-13 19:19 EST, Jim Cornette
no flags Details
This is the log for the newly created dual display via s-c-display (14.39 KB, text/plain)
2005-01-13 19:21 EST, Jim Cornette
no flags Details
This is the backup before configuration of the server (3.18 KB, text/plain)
2005-01-13 19:23 EST, Jim Cornette
no flags Details
This is what s-c-display did to the config file (3.94 KB, text/plain)
2005-01-13 19:24 EST, Jim Cornette
no flags Details
I edited this file to get X up (3.96 KB, text/plain)
2005-01-13 19:28 EST, Jim Cornette
no flags Details
current log after editing file (34.68 KB, text/plain)
2005-01-13 19:31 EST, Jim Cornette
no flags Details
rawhide freshly generated xorg.conf file (3.30 KB, text/plain)
2005-01-16 16:09 EST, Jim Cornette
no flags Details
This is the current log for full details with tool generated config file. (36.38 KB, text/plain)
2005-01-16 16:14 EST, Jim Cornette
no flags Details
switching ati 815 on fc2 (3.29 KB, text/plain)
2005-01-17 17:59 EST, Jim Cornette
no flags Details
the log that goes w/ the story (46.18 KB, text/plain)
2005-01-17 18:01 EST, Jim Cornette
no flags Details
This is with nvidia as primary, no abilityto configure 815 (31.10 KB, text/plain)
2005-01-30 20:45 EST, Jim Cornette
no flags Details
This is with the intel 815 as primary (31.29 KB, text/plain)
2005-01-30 20:51 EST, Jim Cornette
no flags Details
Development, still problems, different symptom, xorg.conf (3.10 KB, text/plain)
2005-10-16 22:21 EDT, Jim Cornette
no flags Details
Here is the xorg-x11 log file (39.91 KB, text/plain)
2005-10-16 22:23 EDT, Jim Cornette
no flags Details
Xorg log after configuring with system-config display (55.56 KB, text/plain)
2005-10-17 17:53 EDT, Jim Cornette
no flags Details
xorg log after using s-c-display to configure (3.36 KB, text/plain)
2005-10-17 17:56 EDT, Jim Cornette
no flags Details
trying with mgs replaced with vesa (39.78 KB, text/plain)
2005-10-17 17:58 EDT, Jim Cornette
no flags Details
just changed to vesa for display 2 (MGA) (3.36 KB, text/plain)
2005-10-17 18:00 EDT, Jim Cornette
no flags Details
change to rightof (55.04 KB, text/plain)
2005-10-17 18:04 EDT, Jim Cornette
no flags Details
this is the last config file for the display (55.04 KB, text/plain)
2005-10-17 18:05 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2005-01-09 03:13:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041220 Fedora/1.7.5-2

Description of problem:
For a long time now, I cannot get the proper resolution for my Intel
815 card (primary) and my ati card to configure dual-head properly. I
cannot pan off of the display for the i810 to see the display on the
secondary monitor.

I am able to get this to work on Windows ME, so it is possible to
accomplish this feat.

I had a radeon 7200 in this box earlier and got a little closer to
getting dual display to even start. This was with an earlier X version
and earlier packages. The radeon 7200 locked up, so I switched to an
ati card as listed in lspci -vvv output below.

 /sbin/lspci -vvv
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and
Memory Controller Hub (rev 02)
        Subsystem: Super Micro Computer Inc: Unknown device 1130
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Capabilities: <available only to root>

00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 02) (prog-if 00 [VGA])
        Subsystem: Intel Corp.: Unknown device 0200
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at feb80000 (32-bit, non-prefetchable)
[size=512K]
        Capabilities: <available only to root>

00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02) (prog-if
00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=32
        I/O behind bridge: 0000d000-0000dfff
        Memory behind bridge: fc900000-fe9fffff
        Prefetchable memory behind bridge: f4700000-f47fffff
        Secondary status: 66Mhz- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-

00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02) (prog-if 80
[Master])
        Subsystem: Intel Corp. 82801AA IDE
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Region 4: I/O ports at ffa0 [size=16]

00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02) (prog-if 00
[UHCI])
        Subsystem: Intel Corp. 82801AA USB
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin D routed to IRQ 11
        Region 4: I/O ports at ef80 [size=32]

00:1f.3 SMBus: Intel Corp. 82801AA SMBus (rev 02)
        Subsystem: Intel Corp. 82801AA SMBus
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin B routed to IRQ 10
        Region 4: I/O ports at efa0 [size=16]

00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio
(rev 02)
        Subsystem: Super Micro Computer Inc: Unknown device 5933
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 10
        Region 0: I/O ports at e800 [size=256]
        Region 1: I/O ports at ef00 [size=64]

01:00.0 VGA compatible controller: ATI Technologies Inc 264VT [Mach64
VT] (rev 40) (prog-if 00 [VGA])
        Control: I/O- Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 255
        Region 0: Memory at ff000000 (32-bit, non-prefetchable)
[disabled] [size=16M]
        Region 1: I/O ports at <ignored> [disabled]
        Expansion ROM at ffff0000 [disabled] [size=64K]

01:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 10
        Region 0: I/O ports at df80 [size=32]
        Expansion ROM at fe9e8000 [disabled] [size=32K]



Version-Release number of selected component (if applicable):
system-config-display-1.0.25-1 xorg-x11-6.8.1.901-1
kernel-2.6.10-1.1063_FC4

How reproducible:
Always

Steps to Reproduce:
1. start system, start xorg-x11,etc
2. run s-c-display and attempt to configure dual-head
3. close X, then start again after configuration.
    

Actual Results:  I can only get 640x480 resolution from the Intel 815.
I cannot pan to the ati display.

Expected Results:  Higher resolution and the ability to get both
displays in a usable state.

Additional info:

I recall another user claiming that he had to revert to an earlier
version of xorg-x11 to get both displays working. I believe he pulled
it in from FC2.
I have another botched up rawhide installation on the system that I
can install FC2 on to see if dual head works using older versions of
packages and an earlier FC version.
Comment 1 Jim Cornette 2005-01-09 03:18:56 EST
Created attachment 109526 [details]
xorg.conf post dual-head configuration

This is what configuring dual-boot did to the xorg.conf file. The file was
edited manually to get the 815 card to work before configuration. I see
multiple monitor entries in the config file.
Comment 2 Jim Cornette 2005-01-09 03:22:29 EST
Created attachment 109527 [details]
This is my current Xorg.0.log file

Referring to many monitor entries, I had to manually add resolutions for the
815 card to be set to a decent resolution.
I still was not able to get the secondary monitor to work.
Comment 3 Jim Cornette 2005-01-09 03:36:20 EST
Created attachment 109528 [details]
Attempting to start a fresh config file for xorg-x11

I got the attached error when attempting to run system-config-display
--reconfig

I guess something is amiss to be able to create a file from scratch via
s-c-display.

Jim
Comment 4 Jim Cornette 2005-01-12 22:13:33 EST
I found an earlier bug report where I could almost get dual display
working, but had a server lockup due to two "primary" devices.

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=105631&action=view

I'd like to figure out where this prolem is located and how to resolve
this problem. I'm unsure if this is a configuration problem or a
server problem.
Comment 5 Jim Cornette 2005-01-12 22:15:23 EST
Excerpt from old bug report

(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:31:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN
is set)
(!!) More than one possible primary device found
(--) PCI: (0:2:0) Intel Corp. 82815 CGC [Chipset Graphics Controller]
rev 2, Mem @ 0x40000000/26, 0x44000000/19
(--) PCI: (1:0:0) ATI Technologies Inc 264VT [Mach64 VT] rev 64, Mem @
0xfd000000/24, I/O @ 0xd800/8, BIOS @ 0xfe9f0000/16
Comment 6 Jim Cornette 2005-01-12 22:25:34 EST
I see that the device is not recognized by the program during this trial.

(II) ATI:  Candidate "Device" section "Videocard1".
(WW) ATI:  PCI/AGP Mach64 in slot 1:0:0 could not be detected!

 With the earlier bug report, I might have had the primary as ATI and
the secondary as Intel 815. I do not recall with certainty.
Comment 7 Jim Cornette 2005-01-12 22:32:35 EST
The earlier report was with the ATI card as the primary and Intel 815
as secondary.

(II) Primary Device is: 
(II) ATI:  Candidate "Device" section "Videocard0".
(II) ATI:  Shared PCI/AGP Mach64 in slot 1:0:0 detected.
(II) ATI:  Shared PCI/AGP Mach64 in slot 1:0:0 assigned to active
"Device" section "Videocard0".
Comment 8 Jim Cornette 2005-01-12 22:44:47 EST
Rounding up the radeon 7200 bug that at least recognized the two cards
is below for comparison.

https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=104238&action=view
Comment 9 Jim Cornette 2005-01-13 19:14:44 EST
Adding to this report is the fact that I installed Severn and found
dual-display functionality was in the future and has not been created yet.
After upgrading to FC2 from RHL 9.0.93, I found that FC2 does have
dual-display configuration tool.
I have several files to attach to the report and sort of a story to go
beforehand related to trials and tribulations encountered.
After upgrading, server started as setup in Severn. After configuring
system for dual boot Operation, I ended up with XFree86Config. The
server refused to start after saving the file, then exiting. The
reason seems to be obvious in the previously mentioned file.
After having the problem with XFree86 not starting, I edited the
xorg.conf file that was a copy of the XFree86Config file. The editing
was severe and I have the same problem that FC3 and the version in
Rawhide both exhibit.I cannot get to the second display for the ATI
card. 815 is primary and the ATI is secondary.
attachments for xorg.config and logs for both to follow.
Comment 10 Jim Cornette 2005-01-13 19:19:58 EST
Created attachment 109748 [details]
Log for Severn system used yesterday, no dual-head ability 

This is for reference to the system with an Intel 815 card
Comment 11 Jim Cornette 2005-01-13 19:21:37 EST
Created attachment 109749 [details]
This is the log for the newly created dual display via s-c-display

xorg-x11-6.7.0-2, system-config-display-1.0.14-1 intalled
Comment 12 Jim Cornette 2005-01-13 19:23:23 EST
Created attachment 109750 [details]
This is the backup before configuration of the server

The date is later than XFree86Config
Comment 13 Jim Cornette 2005-01-13 19:24:56 EST
Created attachment 109751 [details]
This is what s-c-display did to the config file

I believe ATI was "detected" as both cards.
Comment 14 Jim Cornette 2005-01-13 19:28:25 EST
Created attachment 109752 [details]
I edited this file to get X up

This is an amatuar  attempt to get by the problem. I am up and running with the
original problem.
Comment 15 Jim Cornette 2005-01-13 19:31:47 EST
Created attachment 109753 [details]
current log after editing file

I cannot get the ATI card and the screen won't pan. I believe the ATI fails to
initialize. I am using kernel-2.6.5-1.358 for the kernel.
Comment 16 Jim Cornette 2005-01-16 16:09:12 EST
Created attachment 109851 [details]
rawhide freshly generated xorg.conf file

I ran system-config-display after eliminating the conf file for xorg-x11. I did
not get an error and was able to havethis file generated with the tool.
I cannot get the secondary display to work because of the below error.
(--) PCI: (1:0:0) ATI Technologies Inc 264VT [Mach64 VT] rev 64
(WW) ATI:  PCI/AGP Mach64 in slot 1:0:0 could not be detected!
 
The kernel being run is 2.6.10-1.1089_FC4 and the version of X is
xorg-x11-6.8.1.902-1. The version of S-C-display is
system-config-display-1.0.25-1. 

I assume that s-c-display is working somewhat, except my top resolution with
the tool is only 800x600 for the primary card "Intel 815" and likewise for the
ATI card mentioned with the error above.
(no editing performed to file)
Comment 17 Jim Cornette 2005-01-16 16:14:58 EST
Created attachment 109852 [details]
This is the current log for full details with tool generated config file.

My wife can live with 800x600. I however see the screen as too restrictive for
any useability. The maximum resolution for the LCD on the secondary is 800x600,
would this limit the max resolution for the 815 card?

Next test. ATI as primary, 815 as secondary. The last attempt resulted in an x
lockup but was recoverable from. X exited with error.
Comment 18 Jim Cornette 2005-01-16 17:31:27 EST
changing video card from 815 primary to ATI primary - internal
secondary resulted in the i810 not even being an option within the
dual configuration setup. There was not even an option to select
another video card for the secondary. (just in case the configuration
tool was not able to detect,configure the secondary video)

As a reference, Windows ME displays a text message with directions to
enable the display on screen. The message basically is straightforward.

lspci detects the 815 video card with the flipped arrangement. I also
seem to recall that previous versions of system-config-display allowed
some configuration of video cards for the dual head setup.
Without being able to manually select your secondary video card type
or the tool being able to detect and configure the secondary properly,
the tool is very ineffective.
Comment 19 Jim Cornette 2005-01-17 17:59:42 EST
Created attachment 109897 [details]
switching ati 815 on fc2

This file was generated by system-config-display-1.0.14-1 with the ati as
primary and 815 as secondary.
Highlights of this configuration are that the two cards overlap memory
addresses. The login screen in runlevel 5 is on the ati and the mouse moves
within a messed up 815 display. Moving the mouse results in a block that moves
with the cursor. Eventually the display locks up. On the ati, the
initialization message keeps on cycling.
I have to hard reset to get the computer to halt. ctl-alt-del, alt-sysreq-b or
ctl-alt-backspace do nothing.
I will attach the log file for the x lockup also. No story though!
Comment 20 Jim Cornette 2005-01-17 18:01:12 EST
Created attachment 109898 [details]
the log that goes w/ the story

memory dual allocation. ATI has internal memory, 815 is well known what it
tries to do.
Comment 21 Jim Cornette 2005-01-24 19:35:02 EST
Looking at the settings that are used with a system that can
successfuly run dual displays, I got the below values for each card.

ATI ati_m64:
Interrupt Request 11
Memory Range FD000000 - FDFFFFFF
Input Output Range D000 - D0FF
Memory Range FC900000 - FC90FFFF

Intel 815:
Memory Range 000A0000 - 000AFFFF
Memory Range 000B0000 - 000BFFFF
Input Output Range 03B0 - 03BB
Input Output Range 03C0 - 03DF
Interrupt Request 11
Memory Range F8000000 - FBFFFFFF
Memory Range FEB80000 - FEBFFFFF
Memory Range 000C0000 - 000CBFFF

With the above values, I can set the 815 (primary display) to
1280x1024 and set the ATI (secondary display) to 800x600.
Since these results are on a primitive OS, how can the same (or
better) functionality be obtained using system-config-display? Or
manual entries into xorg.conf to prevent memory range overlap between
the two cards?
Comment 22 Jim Cornette 2005-01-24 22:53:00 EST
Sifting through the Xorg.log that I submitted earlier, I found these
values for the ati and the 815 cards relating to memory. It appears to
me thatsome of the values are the same and others are quite different.
I hope you can decipher the relations to the values and the
comparative ranges that the working OS relays.

ati >     [0] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
815 >     [0] -1    0    0xffe00000 - 0xffffffff (0x200000) MX[B](B)
ati >     [1] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
815 >     [1] -1    0    0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
ati >     [2] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
815 >     [2] -1    0    0x000f0000 - 0x000fffff (0x10000) MX[B]
ati >     [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
815 >     [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
ati >     [4] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
815 >     [4] -1    0    0x00000000 - 0x0009ffff (0xa0000) MX[B]
ati >     [5] -1    0    0xfeb80000 - 0xfebfffff (0x80000) MX[B](B)
815 >     [5] -1    0    0xfeb80000 - 0xfebfffff (0x80000) MX[B](B)
ati >     [6] -1    0    0xf8000000 - 0xfbffffff (0x4000000) MX[B](B)
815 >     [6] -1    0    0xf8000000 - 0xfbffffff (0x4000000) MX[B](B)
ati >     [7] 0    0    0x000a0000 - 0x000affff (0x10000) MS[B]
815 >     [7] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
ati >     [8] 0    0    0x000b0000 - 0x000b7fff (0x8000) MS[B]
815 >     [8] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
ati >     [9] 0    0    0x000b8000 - 0x000bffff (0x8000) MS[B]
815 >     [9] -1    0    0x0000df80 - 0x0000df9f (0x20) IX[B]
ati >     [10] -1    0    0x0000ffff - 0x0000ffff (0x1) IX[B]
815 >     [10] -1    0    0x0000ef00 - 0x0000ef3f (0x40) IX[B]
ati >     [11] -1    0    0x00000000 - 0x000000ff (0x100) IX[B]
815 >     [11] -1    0    0x0000e800 - 0x0000e8ff (0x100) IX[B]
ati >     [12] -1    0    0x0000df80 - 0x0000df9f (0x20) IX[B]
815 >     [12] -1    0    0x0000efa0 - 0x0000efaf (0x10) IX[B]
ati >     [13] -1    0    0x0000ef00 - 0x0000ef3f (0x40) IX[B]
815 >     [13] -1    0    0x0000ef80 - 0x0000ef9f (0x20) IX[B]
ati >     [14] -1    0    0x0000e800 - 0x0000e8ff (0x100) IX[B]
815 >     [14] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
815 >     [15] -1    0    0x0000efa0 - 0x0000efaf (0x10) IX[B]
815 >     [16] -1    0    0x0000ef80 - 0x0000ef9f (0x20) IX[B]
815 >     [17] -1    0    0x0000ffa0 - 0x0000ffaf (0x10) IX[B]
815 >     [18] 0    0    0x000003b0 - 0x000003bb (0xc) IS[B]
815 >     [19] 0    0    0x000003c0 - 0x000003df (0x20) IS[B]
Comment 23 Jim Cornette 2005-01-24 23:19:34 EST
adding the descrambling (or scrambling!) information from the working OS 

815 >> Input Output Range 03B0 - 03BB
815 >> Input Output Range 03C0 - 03DF
ati >> Input Output Range D000 - D0FF

815 >> Interrupt Request 11
ati >> Interrupt Request 11

815 >> Memory Range 000A0000 - 000AFFFF
815 >> Memory Range 000B0000 - 000BFFFF
815 >> Memory Range 000C0000 - 000CBFFF
skipped MemoryRange 000CC000 - F7FFFFFF (what value, I don't know!)
815 >> Memory Range F8000000 - FBFFFFFF
ati >> Memory Range FC900000 - FC90FFFF
skipped MemoryRange FC910000 - FCFFFFFF (speculating, math rusty)
ati >> Memory Range FD000000 - FDFFFFFF
skipped MemoryRange FE000000 - FEB7FFFF (rusty?)
815 >> Memory Range FEB80000 - FEBFFFFF
Comment 24 Jim Cornette 2005-01-30 20:28:27 EST
I replaced the ati card with a nvidia agp card. I found that the AGP
card and the nvidia card do not seem to work together. I either see
the nvidia card or see the intel 815 using system-config-display.
Doing an /sbin/lspci showed the intel 815 in the listing.

Anyway, since the radeon 7200, ati (both pci) overlapped in memory
regions, I thought that I'd see what this 815/nvidia combination would
do. I did not check the processes in windows ME yet to see if AGP and
an internal card would work in tandem. I assume that an AGP card and
an internal should work together.
Comment 25 Jim Cornette 2005-01-30 20:31:41 EST
additional note. The resolution for the Internal 815 card went back up
to how it was before adding either pci card. Also the nvidia card is
using the supplied driver (nv) and not the binary, closed-source driver.
Comment 26 Jim Cornette 2005-01-30 20:45:36 EST
Created attachment 110422 [details]
This is with nvidia as primary, no abilityto configure 815
Comment 27 Jim Cornette 2005-01-30 20:51:12 EST
Created attachment 110423 [details]
This is with the intel 815 as primary

The pci value for the nvidia driver was 2:0:0.
Comment 28 Jim Cornette 2005-02-04 10:05:42 EST
looking through the log file supplied in comment #20, I noticed that a
particular section refers to the i810 driver, but references the ATI
graphics card. The 000C000-000CBFFF is for the 815 card utilization.
The overlap range is in comment #22 for the [3] overlapping range.
As additional information, the 370SSM motherboard does not configure
two cards when using an AGP card on either windows or Linux when
choosing either card as the primary video. The PCI cards seem to be
where it is possible to enable dual-display.

(II) I810(1): Primary V_BIOS segment is: 0xc000
(II) I810(1): VESA BIOS detected
(II) I810(1): VESA VBE Version 2.0
(II) I810(1): VESA VBE Total Mem: 16384 kB
(II) I810(1): VESA VBE OEM: ATI MACH64
(II) I810(1): VESA VBE OEM Software Rev: 1.0
(II) I810(1): VESA VBE OEM Vendor: ATI Technologies Inc.
(II) I810(1): VESA VBE OEM Product: MACH64VT
(II) I810(1): VESA VBE OEM Product Rev: 01.00

excerpt from comment #22
ati >     [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
815 >     [3] -1    0    0x000c0000 - 0x000effff (0x30000) MX[B]
Comment 29 Jim Cornette 2005-02-04 10:12:54 EST
Also from log in comment #22 is this excerpt. The ATI has builtin
memory and should not require shared memory allocation. The shared
memory seems to be the problem that causes the overlapping resources.

(II) ATI:  Shared PCI/AGP Mach64 in slot 1:0:0 detected.
(II) ATI:  Shared PCI/AGP Mach64 in slot 1:0:0 assigned to active
"Device" section "Videocard0".
Comment 30 Jim Cornette 2005-10-16 22:21:05 EDT
Created attachment 120037 [details]
Development, still problems, different symptom, xorg.conf

Strange changes happened with the cards with present rawhide. The Intel is set
to primary and starts the boot process up to a point. Then the Matrox (yes,
changed to anotherPCI card, same problem with released version, no display at
all) - The boot process continues on the Matrox. When the GUI starts, the GUI
is displayed on  the Intel card.
As a note, a question was asked on the xorg-x11 list and this log is for
follow-up.
Comment 31 Jim Cornette 2005-10-16 22:23:51 EDT
Created attachment 120038 [details]
Here is the xorg-x11 log file

part 2 for development with Intel internal Matrox Millenium G200 secondary
video
Comment 32 Jim Cornette 2005-10-17 17:53:47 EDT
Created attachment 120091 [details]
Xorg log after configuring with system-config display

No editing and a fresh configuration file
Comment 33 Jim Cornette 2005-10-17 17:56:23 EDT
Created attachment 120093 [details]
xorg log after using  s-c-display to configure

This shows a normal Intel screen but a garbled mga screen.
Comment 34 Jim Cornette 2005-10-17 17:58:50 EDT
Created attachment 120094 [details]
trying with mgs replaced with vesa

With vesa, the screen only displays anything when you switch to vt 1-6. Moving
the mouse does not exit the screen toward any corner.
Comment 35 Jim Cornette 2005-10-17 18:00:34 EDT
Created attachment 120095 [details]
just changed to vesa for display 2 (MGA)
Comment 36 Jim Cornette 2005-10-17 18:04:34 EDT
Created attachment 120096 [details]
change to rightof

I added pci values for the Intel primary card. Since vesa did not work any
different than single head configuration, I tried with mga again. The screen
moves right of the main screen.
Comment 37 Jim Cornette 2005-10-17 18:05:52 EDT
Created attachment 120097 [details]
this is the last config  file for the display

last file for now
Comment 38 Jim Cornette 2005-11-28 15:36:05 EST
Though this problem still exists, I am closing this bug since dual head
operation is not a resource payed attention to and no developer actions in 10
months.

Note You need to log in before you can comment on or make changes to this bug.