This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 144599 - unable to get FC3 to output audio via S/PDIF/IEC958
unable to get FC3 to output audio via S/PDIF/IEC958
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 05:31 EST by jeroen
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-09 06:03:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jeroen 2005-01-09 05:31:04 EST
I've got a MSI K8N Neo2 mainboard with an NVidia 250 chipset,
including an audio driver:

00:06.0 Multimedia audio controller: nVidia Corporation nForce3 250Gb
AC'97 Audio Controller (rev a1)

The machine is connected to a Logitech speakerset via a fiberoptic
cable in the IEC958 port. On Windows, i've configured it to output
sound via that port and it works great (DD5.1, DTS etc. when watching
DVDs).

On Linux, i have been unable to get *any* sound output via the IEC958
port. Sound output works fine via any other output (generic headphone
audio jack).

This most likely a configuration issue, but it'd be nice if we
eventually get a GUI for this. Perhaps via GStreamer?
Comment 1 jeroen 2005-01-09 06:03:53 EST
After a little reading @
http://www.alsa-project.org/alsa-doc/doc-php/asoundrc.php?company=Generic&card=Generic&chip=Generic&module=Generic
it turns out i just had to change the "defaults.pcm.device" in
/etc/alsa/alsa.conf from "0" to "2". It now outputs via IEC958.

Note You need to log in before you can comment on or make changes to this bug.