This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 14460 - 2.2.16-3 has broken aic7xxx module
2.2.16-3 has broken aic7xxx module
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-22 10:42 EDT by redhat-bugzilla
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 19:19:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description redhat-bugzilla 2000-07-22 10:42:19 EDT
The aic7xxx module distributed with kernel 2.2.16-3 (non SMP) appears to be
broken in exactly the same way that the aic7xxx module in kernel 2.2.12 was
broken. 2.2.12 was the kernel distributed with RH6.1.

However, kernel 2.2.14-5.0 had an aic7xxx driver that worked fine.
Unfortunately, I can't speak for 2.2.14-12.

The particular symptom in my case is that the system stops cold -- 
no kernel panic -- after writing a few blocks to a scsi tape attached
to an Adaptec aha2940u2w controller, which uses the aic7xxx driver.

This *may* be the same problem that is reported in bug 13552.
Comment 1 redhat-bugzilla 2000-07-22 14:54:06 EDT
Another thought: in all of the cited cases (my systems with 2.2.16-3 and
2.2.12, and the case in bug 13552) the problem is with a tape 
drive connected to the aic7xxx controller. Other systems that use the
same controller and the same module to access discs have no such
problems.

Perhaps there's an interaction between the aic7xxx module and the st module.
If I remember correctly, there was a tape-related patch to the aic7xxx
code done between 2.2.12 and 2.2.14.

Comment 2 G. Bersano 2000-07-24 09:47:35 EDT
It seems that I have the same problem: working well after RH 6.2 installation but problems after kernel upgrade to 
2.2.16-3. 
The offending device is NOT a tape (the HP35480A is working fine) but now I am unable to mount the SCSI CD-ROM. 
The controller is not a genuine Adaptec (Olivetti internally developed) but it is of the same (AIC-7850) family. Maybe I
have some more luck since my system does not hang, I only have lost my cd-rom.
I can provide more datails if needed
Comment 3 Need Real Name 2000-08-17 14:18:17 EDT
I fixed mine by overwriting the aic7xxx files (and directory) in the source
    distro with the ones from RH 6.1.  A pain to get ahold of them, but once I
did,
    I then re-compiled the kernel and the aic problems went away.
Comment 4 G. Bersano 2000-08-21 11:27:27 EDT
Eventually I had the time to install the latest aic7xxx driver (version 5.1.31) using 
the patch from  http://people.redhat.com/dledford .
Kernel 2.2.16-3 contains driver 5.1.30, that is the problem - in my case.
Now all is fine and my cd-rom (and my tape too) are working as supposed.
Please note I had to recompile the kernel because Doug's 
"5.1.31 precompiled modules for Red Hat Linux 6.2" are for 2.2.14 kernels.
Comment 5 Hamlet Mun 2000-10-30 21:48:24 EST
I have these devices

Intel VC820 Motherboard with BIOS VC82010A.86A.0036.P16SCSI Adapter
Adaptec 2940U/UW (BIOS 2.57.2) (SCSI ID 7)
      at Bus:02h Device:09h / IRQ: 9 / IO Port: D800h
   Western Digital Vantage 9.1Gb U2W SCSI (SCSI ID 0)
   Saegate 4.5Gb UW SCSI (SCSI ID 1)

   UltraPlextor CD-ROM (SCSI ID 2)
   Yamaha 4260 CD ReWriter (SCSI ID 5)
   Iomega ZIP SCSI (SCSI ID 6)
Video Diamond Viper 770 OEM 16MB
Sound onboard
Network 3Com 3C509B

  When I connect only UltraWide hard disks, the system works fine. But if I 
add UltraPlextor, Yamaha, Iomega (All connected with 58 pin cable), I 
can't even install the RedHat 7.0 Linux. The install process stops after 
copying 3 packages or something like that. The system stops for 5 seconds 
every 2 minutes or less making blink cdrom's lights. It looks similar to 
scanning SCSI chains, just like at boot.
   So I had to install & use linux without those devices using 58 pin cable.
The Windows 98 SE works good with & without those 58 pin devices mentioned 
above.
Comment 6 Hamlet Mun 2000-10-30 21:49:11 EST
I have these devices

Intel VC820 Motherboard with BIOS VC82010A.86A.0036.P16SCSI Adapter
Adaptec 2940U/UW (BIOS 2.57.2) (SCSI ID 7)
      at Bus:02h Device:09h / IRQ: 9 / IO Port: D800h
   Western Digital Vantage 9.1Gb U2W SCSI (SCSI ID 0)
   Saegate 4.5Gb UW SCSI (SCSI ID 1)

   UltraPlextor CD-ROM (SCSI ID 2)
   Yamaha 4260 CD ReWriter (SCSI ID 5)
   Iomega ZIP SCSI (SCSI ID 6)
Video Diamond Viper 770 OEM 16MB
Sound onboard
Network 3Com 3C509B

  When I connect only UltraWide hard disks, the system works fine. But if I 
add UltraPlextor, Yamaha, Iomega (All connected with 58 pin cable), I 
can't even install the RedHat 7.0 Linux. The install process stops after 
copying 3 packages or something like that. The system stops for 5 seconds 
every 2 minutes or less making blink cdrom's lights. It looks similar to 
scanning SCSI chains, just like at boot.
   So I had to install & use linux without those devices using 58 pin cable.
The Windows 98 SE works good with & without those 58 pin devices mentioned 
above.

  I'm using RedHat 7.0 with AIC7xxxx 5.1.31 / 3.2.4!!!!!

Note You need to log in before you can comment on or make changes to this bug.