Bug 144601 - AltGr/I-search problems in XEmacs
AltGr/I-search problems in XEmacs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xemacs (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 06:10 EST by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 21.4.16-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 11:17:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Workaround for X bug; fixes AltGr (341 bytes, patch)
2005-01-11 12:55 EST, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2005-01-09 06:10:34 EST
I'm not sure which component is the culprit, but here goes:

The use of XEmacs and Emacs on FC3 is badly hindered by problems
related to the AltGr key.

Try starting a I-search in either (Ctrl-S), and try to search
something containing a character which requires the use of AltGr, for
example $ in my keyboard (Finnish) is AltGr+4.  In both editors, the
I-search quits immediately when AltGr is pressed, so such a search is
not possible.

Additionally, in XEmacs, only the AltGr press alone triggers the error
message "iso-level3-shift is not defined".

I googled for info, and found a suggested workaround for XEmacs:

  (define-key global-map [(iso-level3-shift)] #'ignore)

That gets rid of the above error message, but I-search still won't work.

I can input characters requiring the use of AltGr in both editors,
it's just the annoying error message in XEmacs + the I-search problem
in both that need solving.

I haven't had these problems earlier (eg. on FC2) with either editor.
 Upgrading XEmacs to the rawhide version does not help.  Ideas?
Comment 1 Jens Petersen 2005-01-11 01:54:48 EST
See bug 137868 for the Emacs case.

As I commented there though (perhaps I'm missing something?)
it seems to work ok for me.  I don't normally use AltGr, but
with say

$ setxkbmap de
$ xemacs

I don't see any problems with AltGr.
Comment 2 Ville Skyttä 2005-01-11 02:50:02 EST
On my box:

setxkbmap fi
/usr/bin/xemacs -vanilla
M-x set-variable debug-on-signal t
<press AltGr>

...results in:
Signaling: (undefined-keystroke-sequence [#<keypress-event
iso-level3-shift>])

The same happens after "setxkbmap de".

Since this happens with both Emacs and XEmacs I suspect xorg.
Comment 3 Ville Skyttä 2005-01-11 02:51:40 EST
(With Emacs there's no error from pressing AltGr as in above, but
I-search is aborted nevertheless.)
Comment 4 Ville Skyttä 2005-01-11 12:55:03 EST
Created attachment 109626 [details]
Workaround for X bug; fixes AltGr

Based on bug 137868 comment 11, I came up with the attached patch for XEmacs
("xintrinsic.h" pulls in <X11/Xutil.h> via <X11/Intrinsic.h>).	Seems to work
for me, will send also upstream.
Comment 5 Ville Skyttä 2005-01-17 17:49:02 EST
FYI, the patch from comment 4 was applied upstream to XEmacs 21.5, and is being
recommended for 21.4; it'll probably be in 21.4.17.  I think it would be good
and safe to apply it to the FC XEmacs package now.

Oh, and by the way, the GTK build of XEmacs has the same problem, but my patch
won't help with that.  Not a biggie AFAICS because XEmacs GTK 21.4 is not really
ready for much at all yet.

Comment 6 Ville Skyttä 2005-01-21 15:21:34 EST
My patch for this has been applied upstream for both next XEmacs 21.[45] versions.

And in case you're interested, ditto a patch that fixes the same problem for the
GTK build: http://list-archive.xemacs.org/xemacs-patches/200501/msg00088.html

Could you rebuild a new XEmacs with at least the X patch applied for rawhide?  I
see the fixed GNU Emacs is already there...
Comment 7 Jens Petersen 2005-01-24 20:07:15 EST
Sorry for the delay: your patch is in 21.4.16-2.
Comment 8 Ville Skyttä 2005-01-27 11:17:39 EST
Works for me (tested on FC3).  Thanks.

Note You need to log in before you can comment on or make changes to this bug.