Bug 144603 - local variable used uninitialised
Summary: local variable used uninitialised
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc4   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-09 13:32 UTC by David Binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 23:22:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Binderman 2005-01-09 13:32:15 UTC
Description of problem:

I just tried to compile package gcc4-4.0.0-0.17 from 
Redhat Fedora development tree.

The compiler said


../../../libjava/java/lang/e_rem_pio2.c:170: warning: 'z' is used
uninitialized
in this function

The source code is

        SET_LOW_WORD(z,low);

I'm not sure what the fix is for this.



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jakub Jelinek 2005-01-10 23:22:01 UTC
That's not a bug.  Both high and low word of z are set, albeit not on the same
line.



Note You need to log in before you can comment on or make changes to this bug.