Bug 144608 - PCMCIA - no cards detected (Yenta TI: socket 0000:02:07.1 no PCI interrupts. Fish. Please report.)
PCMCIA - no cards detected (Yenta TI: socket 0000:02:07.1 no PCI interrupts. ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 11:46 EST by Bruno De Wolf
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:44:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruno De Wolf 2005-01-09 11:46:50 EST
Description of problem:
No PCMCIA cards are detected - power led of my Linksys wireless
remains black.


Version-Release number of selected component (if applicable):
kernel 2.6.9-1.724_FC3

How reproducible:
Always

Steps to Reproduce:
1. Insert or remove a pcmcia card (I only have a Linksys wireless-G
card at hand, but I assume it happens with any card).
2. service pcmcia stop; service pcmcia start
3.
      
Actual results:
1. Card remains undetected
2. Power led of card remains black
3. 'cardctl status' does not list any cards

Expected results:
I assume at least one of the power led should light and/or cardctl
status should find a card.

Additional info:
- Bug 135508 was not a solution for me
- When running service pcmcia stop / service pcmcia start, the
following output is listed in dmesg:
ACPI: PCI interrupt 0000:02:07.1[A] -> GSI 5 (level, low) -> IRQ 5
Yenta: CardBus bridge found at 0000:02:07.1 [1033:819a]
Yenta: Using CSCINT to route CSC interrupts to PCI
Yenta: Routing CardBus interrupts to PCI
Yenta TI: socket 0000:02:07.1, mfunc 0x010c1022, devctl 0x64
Yenta TI: socket 0000:02:07.1 probing PCI interrupt failed, trying to fix
Yenta TI: socket 0000:02:07.1 no PCI interrupts. Fish. Please report.
Yenta: ISA IRQ mask 0x0000, PCI irq 0
Socket status: 00000000
cs: IO port probe 0x0c00-0x0cff: clean.
cs: IO port probe 0x0100-0x04ff: excluding 0x4d0-0x4d7
cs: IO port probe 0xfa00-0xfeff: excluding 0xfe00-0xfe07
cs: IO port probe 0x0a00-0x0aff: clean.


[root@avon ~]# lspci -vv
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host
Bridge (rev 04)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Region 0: Memory at ec000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [e4] Vendor Specific Information
        Capabilities: [a0] AGP version 2.0
                Status: RQ=32 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW+ AGP3- Rate=x1,x2,x4
                Command: RQ=1 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit-
FW- Rate=x1
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP
Bridge (rev 04) (prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 96
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: e8100000-e81fffff
        Prefetchable memory behind bridge: f0000000-f7ffffff
        Secondary status: 66Mhz+ FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA+ VGA+ MAbort- >Reset- FastB2B-

00:1e.0 PCI bridge: Intel Corp. 82801 Mobile PCI Bridge (rev 42)
(prog-if 00 [Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
        I/O behind bridge: 00004000-00004fff
        Memory behind bridge: e8200000-e82fffff
        Secondary status: 66Mhz- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR- NoISA+ VGA- MAbort- >Reset- FastB2B-

00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02) (prog-if
8a [Master SecP PriP])
        Subsystem: NEC Corporation: Unknown device 816c
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 7
        Region 0: I/O ports at <unassigned>
        Region 1: I/O ports at <unassigned>
        Region 2: I/O ports at <unassigned>
        Region 3: I/O ports at <unassigned>
        Region 4: I/O ports at 1800 [size=16]
        Region 5: Memory at e8000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 02)
        Subsystem: NEC Corporation: Unknown device 816c
        Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin B routed to IRQ 10
        Region 4: I/O ports at 1100 [size=32]

00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM AC'97
Audio Controller (rev 02)
        Subsystem: NEC Corporation: Unknown device 8119
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 10
        Region 0: I/O ports at 1c00 [size=256]
        Region 1: I/O ports at 18c0 [size=64]

00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem Controller (rev 02)
(prog-if 00 [Generic])
        Subsystem: NEC Corporation: Unknown device 8140
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 10
        Region 0: I/O ports at 2400 [size=256]
        Region 1: I/O ports at 2000 [size=128]

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon
Mobility M7 LW [Radeon Mobility 7500] (prog-if 00 [VGA])
        Subsystem: NEC Corporation: Unknown device 8190
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping+ SERR+ FastB2B+
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 66 (2000ns min), Cache Line Size 08
        Interrupt: pin A routed to IRQ 7
        Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
        Region 1: I/O ports at 3000 [size=256]
        Region 2: Memory at e8100000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
                Status: RQ=48 Iso- ArqSz=0 Cal=0 SBA+ ITACoh- GART64-
HTrans- 64bit- FW- AGP3- Rate=x1,x2,x4
                Command: RQ=32 ArqSz=0 Cal=0 SBA+ AGP+ GART64- 64bit-
FW- Rate=x1
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:05.0 USB Controller: NEC Corporation USB (rev 41) (prog-if 10 [OHCI])
        Subsystem: NEC Corporation: Unknown device 8185
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (250ns min, 10500ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at e8200000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:05.1 USB Controller: NEC Corporation USB (rev 41) (prog-if 10 [OHCI])
        Subsystem: NEC Corporation: Unknown device 8186
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64 (250ns min, 10500ns max), Cache Line Size 08
        Interrupt: pin B routed to IRQ 10
        Region 0: Memory at e8201000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:05.2 USB Controller: NEC Corporation USB 2.0 (rev 02) (prog-if 20
[EHCI])
        Subsystem: NEC Corporation: Unknown device 8187
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 132 (4000ns min, 8500ns max), Cache Line Size 20
        Interrupt: pin C routed to IRQ 7
        Region 0: Memory at e8202000 (32-bit, non-prefetchable) [size=256]
        Capabilities: [40] Power Management version 2
                Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:06.0 FireWire (IEEE 1394): NEC Corporation IEEE 1394 Host
Controller (rev 01) (prog-if 10 [OHCI])
        Subsystem: NEC Corporation: Unknown device 80fa
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 64, Cache Line Size 08
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at e8203000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2+ AuxCurrent=0mA
PME(D0-,D1-,D2+,D3hot+,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

02:07.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus
Controller (rev 01)
        Subsystem: NEC Corporation: Unknown device 819a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 168, Cache Line Size 20
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at 1ff00000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=03, subordinate=06, sec-latency=176
        Memory window 0: 20000000-203ff000 (prefetchable)
        Memory window 1: 20400000-207ff000
        I/O window 0: 00004400-000044ff
        I/O window 1: 00004800-000048ff
        BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt-
PostWrite+
        16-bit legacy interface ports at 0001

02:07.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus
Controller (rev 01)
        Subsystem: NEC Corporation: Unknown device 819a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B- ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 168, Cache Line Size 20
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at 1ff01000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=02, secondary=07, subordinate=0a, sec-latency=176
        Memory window 0: 20800000-20bff000 (prefetchable)
        Memory window 1: 20c00000-20fff000
        I/O window 0: 00004c00-00004cff
        I/O window 1: 00005000-000050ff
        BridgeCtl: Parity- SERR- ISA- VGA- MAbort- >Reset+ 16bInt-
PostWrite+
        16-bit legacy interface ports at 0001

02:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) PRO/100 VE
(LOM) Ethernet Controller (rev 42)
        Subsystem: NEC Corporation: Unknown device 8169
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 66 (2000ns min, 14000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at e8204000 (32-bit, non-prefetchable) [size=4K]
        Region 1: I/O ports at 4000 [size=64]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-



Thank you for helping on this,

Bruno
Comment 1 Dave Jones 2005-01-10 23:04:03 EST
any improvement with todays 2.6.10 update ?
Comment 2 Bruno De Wolf 2005-01-11 13:25:23 EST
Here's the status with 2.6.10_737:
- No Yenta or Yenta TI messages in the system log with 'service pcmcia
stop/start'
- Power led of card remains off.
- cardctl status does not show a card
- cardctl resume/ident and others: the process hangs. Even a kill -9
of the PID does not seem to function - a kill of the parent process
helps though.

Kind regards,

Bruno
Comment 3 Michael Murr 2005-01-16 00:45:10 EST
I've got the same problem on an IBM G40 Thinkpad.  When I initially
installed FC3 my Orinoco card was working just fine, and then this
morning it stopped suddenly.

The error messages I've received were identical to Bruno's.  After
reading this thread I updated to the latest 2.6.10 kernel, and now
have the same issues as Bruno did on the 11th (no yenta/ti messages,
power led of card remains off, cardctl status doesn't show a card,
etc.)  I have however gotten errors from cardmgr -vfo:

[root@sherlock ~]# cardmgr -vfo
cardmgr[6025]: watching 1 socket
cardmgr[6025]: could not adjust resource: IO ports 0xc00-0xcff: Device
or resource busy
cardmgr[6025]: could not adjust resource: IO ports 0x100-0x4ff: Device
or resource busy
cardmgr[6025]: could not adjust resource: memory 0xc0000-0xfffff:
Input/output error
cardmgr[6025]: could not adjust resource: memory
0x60000000-0x60ffffff: Input/output error
cardmgr[6025]: could not adjust resource: memory
0xa0000000-0xa0ffffff: Input/output error
cardmgr[6025]: could not adjust resource: IO ports 0xa00-0xaff: Device
or resource busy
[root@sherlock ~]#

I'm running kernel 2.6.10-1.741_FC3 and pcmcia-cs 3.2.7-2.1
Comment 4 Dave Jones 2005-07-15 16:29:13 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Bruno De Wolf 2005-07-18 04:12:36 EDT
Great,

Update to kernel-2.6.12-1.1372_FC3 solves the problem indeed. For my part, this
bug can be closed.

Thanks for your continued work,

Bruno
Comment 6 3ric Johanson 2005-08-09 22:20:46 EDT
I'm a gentoo user with this same problem.  What kernel patch/mod fixed this in
kernel-2.6.12-1.1372_FC3?  The changelog for this FC package didn't hint at it... 

Thanks!
-eric

(In reply to comment #4)
> An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
> may contain a fix for your problem.   Please update to this new kernel, and
> report whether or not it fixes your problem.
> 
> If you have updated to Fedora Core 4 since this bug was opened, and the problem
> still occurs with the latest updates for that release, please change the version
> field of this bug to 'fc4'.
> 
> Thank you.

Comment 7 Dave Jones 2005-08-10 02:22:50 EDT
it was fixed by something that occured after a rebase to 2.6.12 from 2.6.11.
which of the ~4000 csets fixed it is anyones guess..

Note You need to log in before you can comment on or make changes to this bug.