Bug 144619 - After FC3 install, hangs after "enabling swap space" during boot
After FC3 install, hangs after "enabling swap space" during boot
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 15:55 EST by Gantry York
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 18:14:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gantry York 2005-01-09 15:55:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I upgraded 2 laptops and 1 desktop from RH9.2 to FC3.  With the
laptops, I let the installer autopartition my drives for me.  With my
desktop I choose to partition my drives myself.  

I have an hda and an hdb each 250GB. I put /, /boot, /usr, /usr/local,
/opt, and swap on hda.  I put /home on hdb.  The remaining 150GB on
hda and hdb I combined into an lvm volume and mount to /export/disk01.

This is a Penguin Computing machine (about 2 years old).

I do a custom install installing everything.

I had no critical problems with my laptop installs.  However, the
desktop install completes, then when I go to do the initial reboot, it
hangs at the "Enabling swap space" part everytime.

Because of the graphical boot, I must do an ctrl-alt-f1 and switch to
the analog connection on my flat panel lcd monitor to see this.

I redid the install doing a minimal install with installer
autopartitioning for me -- I had no problem.

I redid the install again doing a desktop install with the installer
autopartitioning for me -- I had no problem.

I did the install again doing the workstation install with the
installer autopartitioning for me -- I had no problem.

I redid the install one more time doing an everything install and
manually partitioning it myself.  Again I got the hang at "Enabling
swap space".

I've seen a couple posts on the internet concerning this issue, but no
definitive solution.

http://www.fedoraforum.org/forum/showthread.php?t=22763
http://www.linuxforums.org/forum/post-110504.html



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  See description above
2.
3.
    

Actual Results:  Hangs at "Enabling swap space" during the boot process.

Expected Results:  Boots correctly.

Whatever the fix turns out to be, it should be encorporated into the
ISO  images.

Additional info:
Comment 1 Gantry York 2005-01-09 17:11:20 EST
I updated to the kernel-smp-2.6.9-1.724_FC3 and kernel-2.6.9-1.724_FC3
and this did not fix the problem.
Comment 2 Gantry York 2005-01-10 00:37:32 EST
OK, I have the install correct now.

I believe the problem was in the starting of X not the "Enabling swap
space".

I have a Dell 2001FP monitor and I use both the digital and analog
connections.  What I think was happening was the installer would get
confused when starting X after the install (before it was configured).
 It couldn't guess what type of monitor I had since I had both the
analog and digital connections connected at the same time.  It was
actually hanging at X.  But when I did the alt-ctrl-f1 "Enabling swap
space" was the last console message I saw.

This bug can probably be closed.  Although others seem to have had
simular issues.
Comment 3 Bill Nottingham 2005-01-10 16:07:31 EST
Assigning to X for now.
Comment 4 Mike A. Harris 2005-01-31 19:58:42 EST
This is unrelated to swap space.  That is just the last message
that is successfully printed to the screen.  What is failing, is
what happens _after_ swap space is enabled, but before anything
new gets displayed on the screen.

Most likely this is "rhgb" failing in some way.  Please
disable "rhgb" in your grub.conf by removing it.  Or you can
just uninstall rhgb.

Please update the report to indicate if disabling or removing
rhgb works around the issue.  Also, please attach your X server
log, config file, and /var/log/messages from after a failure
situation, as uncompressed individual attachments, using bugzilla
file attach feature, for investigation of the underlying problem.

Thanks in advance.
Comment 5 Mike A. Harris 2005-01-31 20:01:13 EST
Status set to "NEEDINFO"
Comment 6 Gantry York 2005-02-01 20:02:32 EST
I did try removing rhgb with one of my trial-and-error installs.  That
did not fix the problem.

The problem is fixed.  Please read Additional Comment #1.

This had everything to do with the starting of X (after enabling swap
space).  It had to do with my graphics card having both analog and DVI
monitor outputs and I had both of those connected at once.  I think
the X server got confused because of this.

Now I connect only the DVI cable to my video card and monitor and
there is no problem.

This is an interesting situation to note, but I don't think this bug
needs to stay open.

Feel free to close this bug.
Comment 7 Mike A. Harris 2005-02-02 18:14:36 EST
> The problem is fixed.  Please read Additional Comment #1.

Comment #1 says you upgraded your kernel and it did not fix the
problem.  Perhaps you meant "is fixed" instead of "is not fixed"?

> This had everything to do with the starting of X (after enabling
> swap space).  It had to do with my graphics card having both analog
> and DVI monitor outputs and I had both of those connected at once. 
> I think the X server got confused because of this.

Most of the video drivers in X.Org handle dualhead, including
mixed VGA/DVI output no problem.  If not, then it is either a bug,
or it is a lacking feature in the particular driver.  However,
if you boot into runlevel 3, and startx with a working dualhead
configuration, and it does not work when booting runlevel 5
with rhgb enabled, then there is definitely a problem.

Sometimes rhgb causes boot time problems in certain configurations
unfortunately, which go away when rhgb is disabled, and I believe
this is what you are experiencing.

> Feel free to close this bug.

Ok, I'll close the bug "WORKSFORME" for now as you've requested,
if you feel the workaround is acceptable.  Please feel free
however to reopen the report in the future if you'd like to
continue troubleshooting the rhgb issue.

In the future, we're considering starting gdm earlier on in the
boot sequence, and avoiding rhgb altogether, which will sidestep
all of the various issues related to rhgb hopefully.  ;o)

Thanks for your feedback.
Comment 8 kunkhmer 2005-03-22 04:51:39 EST
I had this problem.. during boot it hang after the line
"Enabling Swap Space..... [OK]"
I went too far and getting more complicate.. to search for the solution.
Actually it's not hanging, it just take too long that's all. if you wait for
about 3 to 5min it will continue loading the applications.

I accidently discovered that, after i added ".net" to my host name it seem to
boot normal.. not hanging anymore. I was curious, I tool ".net" out then it
start to have the hanging problem again.
Why Why Why? surely it's a bug!

Note You need to log in before you can comment on or make changes to this bug.