Bug 144622 - kernel crash on spinlock under X started by init/gdm
kernel crash on spinlock under X started by init/gdm
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-09 17:10 EST by R P Herrold
Modified: 2015-01-04 17:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-31 15:08:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2005-01-09 17:10:11 EST
Description of problem:
I have reviewed bugs: 141851 and 139978, but this appears different

    2.6.9-1.675

Jan  9 16:11:39 dhcp253 gpm[2002]: *** info [mice.c(1766)]:
Jan  9 16:11:39 dhcp253 gpm[2002]: imps2: Auto-detected intellimouse PS/2
Jan  9 16:42:09 dhcp253  [drm:i810_wait_ring] *ERROR* space: 65520
wanted 65528
Jan  9 16:42:09 dhcp253  [drm:i810_wait_ring] *ERROR* lockup
Jan  9 16:42:12 dhcp253  [drm:i810_wait_ring] *ERROR* space: 65512
wanted 65528
Jan  9 16:42:12 dhcp253  [drm:i810_wait_ring] *ERROR* lockup
Jan  9 16:42:12 dhcp253 gdm[3517]: gdm_server_start: Display :0 busy.
 Trying an
other display number.
Jan  9 16:42:12 dhcp253 kernel: [drm:i810_wait_ring] *ERROR* space:
65520 wanted
 65528
Jan  9 16:42:12 dhcp253 kernel: [drm:i810_wait_ring] *ERROR* lockup
Jan  9 16:42:13 dhcp253 kernel: [drm:i810_wait_ring] *ERROR* space:
65512 wanted
 65528
Jan  9 16:42:13 dhcp253 kernel: [drm:i810_wait_ring] *ERROR* lockup
Jan  9 16:42:14 dhcp253  mtrr: base(0x44000000) is not aligned on a
size(0x12c00
0) boundary
Jan  9 16:42:14 dhcp253 kernel: mtrr: base(0x44000000) is not aligned
on a size(
0x12c000) boundary
Jan  9 16:42:14 dhcp253 kernel: [drm] Using v1.4 init.
Jan  9 16:42:23 dhcp253  mm/mmap.c:97: spin_is_locked on uninitialized
spinlock
c72776d4.
Jan  9 16:42:23 dhcp253  Unable to handle kernel paging request at
virtual addre
ss c72776d8
Jan  9 16:42:23 dhcp253   printing eip:
Jan  9 16:42:23 dhcp253  c01571e0
Jan  9 16:42:23 dhcp253  *pde = 07001163
Jan  9 16:42:23 dhcp253  Oops: 0003 [#1]
Jan  9 16:42:23 dhcp253  Modules linked in: i810 md5 ipv6 parport_pc
lp parport
netconsole netdump autofs4 i2c_dev i2c_core sunrpc dm_mod uhci_hcd
hw_random snd
_intel8x0 snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer
snd_page_al
loc snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore e100 mii
floppy ext
3 jbd
Jan  9 16:42:23 dhcp253  CPU:    0
Jan  9 16:42:23 dhcp253  EIP:    0060:[<c01571e0>]    Not
tainted VLI
Jan  9 16:42:23 dhcp253  EFLAGS: 00010246   (2.6.9-1.675_EL)
Jan  9 16:42:23 dhcp253  EIP is at remove_vm_struct+0x83/0x12e
Jan  9 16:42:23 dhcp253  eax: 00000000   ebx: c7277698   ecx: c03136d6
  edx: c9
b72e80
Jan  9 16:42:23 dhcp253  esi: c9110270   edi: c2fe0aa0   ebp: c548cbe0
  esp: c9
b72e8c
Jan  9 16:42:23 dhcp253  ds: 007b   es: 007b   ss: 0068
Jan  9 16:42:23 dhcp253  Process kdeinit (pid: 3771,
threadinfo=c9b72000 task=cb
1fd230)
Jan  9 16:42:23 dhcp253  Stack: c9110858 c9110270 cf76d440 c0159441
c03de0b4 000
002bd c548cbe0 c548cbe0
Jan  9 16:42:23 dhcp253         c011e618 cb1fd230 c017399d 00000000
c9b72000 cfe
01900 cef2b800 c0173c54
Jan  9 16:42:23 dhcp253         c01736e0 c9b72ed4 00000080 cb15f8e0
cb15f8e0 004
00000 ffffffb0 00000001
Jan  9 16:42:23 dhcp253  Call Trace:
Jan  9 16:42:23 dhcp253   [<c0159441>] exit_mmap+0x1dc/0x1e5
Jan  9 16:42:23 dhcp253   [<c011e618>] mmput+0xb9/0xdc
Jan  9 16:42:23 dhcp253   [<c017399d>] exec_mmap+0x2b3/0x2cd
Jan  9 16:42:24 dhcp253   [<c0173c54>] flush_old_exec+0x43/0x367
Jan  9 16:42:24 dhcp253   [<c01736e0>] kernel_read+0x31/0x3b
Jan  9 16:42:24 dhcp253   [<c019a21b>] load_elf_binary+0x4e8/0xb92
Jan  9 16:42:24 dhcp253   [<c017321d>] copy_strings+0x22b/0x235
Jan  9 16:42:24 dhcp253   [<c0174e10>]
search_binary_handler+0x6f/0x1ae
Jan  9 16:42:24 dhcp253   [<c01750b7>] do_execve+0x168/0x1f6
Jan  9 16:42:24 dhcp253   [<c0104964>] sys_execve+0x2a/0x6f
Jan  9 16:42:24 dhcp253   [<c030aff3>] syscall_call+0x7/0xb
Jan  9 16:42:24 dhcp253  Code: c0 74 28 8b 43 44 48 89 43 44 8d 43 3c
ff 73 50 f
f 73 4c 50 ff 73 48 6a 61 68 73 c1 31 c0 68 62 37 31 c0 e8 86 a3 fc ff
83 c4 1c
<c7> 43 40 01 00 00 00 89 d9 89 fa c7 43 4c 73 c1 31 c0 89 f0 c7
Jan  9 16:44:40 ftp dhcpd: DHCPREQUEST for 10.16.33.253 from
00:02:a5:1b:30:df v
ia eth0
Jan  9 16:44:40 ftp dhcpd: DHCPACK on 10.16.33.253 to
00:02:a5:1b:30:df via eth0
Jan  9 16:45:09 ftp dhcpd: DHCPREQUEST for 10.16.33.253 from
00:02:a5:1b:30:df v
ia eth0


The information at the end is after I had rebooted -- I was running
the netdump package, which I figured out configs on -- what a neat
tool!  This information is, of course, from the logserver's records.

256M of ram

The unit is a Compaq SFF EN

[herrold@dhcp253 ~]$ sudo /sbin/lspci -v -v
00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and
Memory Controller Hub (rev 02)
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast
>TAbort- <TAbort- <MAbort+ >SERR- <PERR-
        Latency: 0
        Capabilities: [88] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 02) (prog-if 00 [VGA])
        Subsystem: Compaq Computer Corporation: Unknown device 001a
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 10
        Region 0: Memory at 44000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at 40300000 (32-bit, non-prefetchable)
[size=512K]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-

00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 01) (prog-if 00
[Normal decode])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=64
        I/O behind bridge: 00001000-00001fff
        Memory behind bridge: 40000000-402fffff
        Secondary status: 66Mhz- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort+ <SERR- <PERR-
        BridgeCtl: Parity- SERR+ NoISA+ VGA- MAbort- >Reset- FastB2B-

00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 01)
        Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0

00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 01) (prog-if
80 [Master])
        Subsystem: Intel Corp.: Unknown device 2411
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Region 4: I/O ports at 2460 [size=16]

00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 01)
(prog-if 00 [UHCI])
        Subsystem: Intel Corp.: Unknown device 2411
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin C routed to IRQ 5
        Region 4: I/O ports at 2440 [size=32]

00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97
Audio (rev 01)
        Subsystem: Compaq Computer Corporation: Unknown device 000f
        Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin B routed to IRQ 11
        Region 0: I/O ports at 2000 [size=256]
        Region 1: I/O ports at 2400 [size=64]

02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet
Controller (rev 01)
        Subsystem: Compaq Computer Corporation EtherExpress PRO/100 VM
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR+ FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 66 (2000ns min, 14000ns max), Cache Line Size 08
        Interrupt: pin A routed to IRQ 5
        Region 0: Memory at 40000000 (32-bit, non-prefetchable) [size=4K]
        Region 1: I/O ports at 1000 [size=64]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3cold+)
                Status: D0 PME-Enable+ DSel=0 DScale=2 PME-

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.675

How reproducible:
Always

Steps to Reproduce:
start X by init, rather than with startx -- startx is find and runs --
init into R/L 5 is not.

Actual Results:  it locks under init

Expected Results:  it should not lock
Comment 2 Dave Jones 2005-04-21 20:36:06 EDT
was this seen in the final GA kernel too ?
Comment 3 Suzanne Hillman 2005-05-31 15:08:56 EDT
Due to lack of reply in over a month, closing as NOTABUG. If this problem is
still around, please reopen with the requested information.

Note You need to log in before you can comment on or make changes to this bug.