This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 144649 - /proc/stat does not provide the disk_io details for RAID Disk or external disk array
/proc/stat does not provide the disk_io details for RAID Disk or external di...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 05:11 EST by Yogesh
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-25 13:38:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yogesh 2005-01-10 05:11:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
 In RH 3.0 release we found that though the iostat cmd
does list the device with the rpm sysstat-4.0.7-4.EL3.3.i386.rpm but 
disk_io data is not available in the /proc/stat file for the same device  

# cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 1)

# uname -a
Linux 2.4.21-9.EL #1 Thu Jan 8 17:24:12 EST 2004 i686 i686 i386 GNU/Linux

# more /proc/stat
cpu  949 0 922 70463 2266 34 5
cpu0 949 0 922 70463 2266 34 5
page 74317 15850
swap 1 0
intr 89550 74639 6 0 0 3 0 5 0 1 0 0 6040 58 0 0 8798
disk_io:
ctxt 120629
btime 1096020969
processes 3654
procs_running 1
procs_blocked 0

The output of regular /proc/stat of working linux box 

root@kalinga root]# cat /proc/stat
cpu  432515 682 115963 309681498 87926 5174 120597
cpu0 128265 55 35422 77383474 27514 4255 32229
cpu1 92950 272 26783 77445157 16701 447 28737
cpu2 120714 69 27533 77405447 27210 472 29602
cpu3 90586 286 26225 77447420 16501 0 30029
page 323651 3466728
swap 1 0
intr 84739916 77611583 6 0 6 6 0 5 2 1 0 0 0 32 0 477111 0 0 0 30 0
6651134
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
disk_io: (3,0):(481064,45488,645526,435576,6933428)
ctxt 106918155
btime 1095245839
processes 70265
procs_running 1
procs_blocked 0



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.On a Linux 2.4.21-9.EL #1 Advanced Server try to check the Disk
Performance details of a Externally mounted disk like RAID etc
2. The Disk details does not get listed in the /proc/stat 
3.
    

Expected Results:  The /proc/stat should have details for the disk like 

disk_io: (3,0):(481064,45488,645526,435576,6933428)

Additional info:

This was only observed for Raid Array
Comment 1 Yogesh 2005-01-18 07:34:58 EST
Hi Gary, 

Thanks for the reply. 

 We tried with new sysstat package sysstat-5.0.5-2.i386.rpm but this
still does not resolve the issue of /proc/stat where the disk_io
values for the disk array is not displayed . We tried this on our
client place and also on our lab and this was not succesfull. 

 Let me explain how this can be easily be reproduced. 

 1. On any X86 box running the below version of RH on IDE hardisk.

[root@root]# cat /etc/redhat-release
Red Hat Enterprise Linux WS release 3 (Taroon Update 1)
[root@root]# uname -a
Linux abhilash 2.4.21-9.EL #1 Thu Jan 8 17:24:12 EST 2004 i686 i686
i386 GNU/Linux

 2. Please boot the IDE harddisk as secondary master instead of
primary master . Under this environment please check the disk_io value
in /proc/stat

[root@root]# cat /proc/stat
cpu  741 0 982 1637620 1171 1814 388
cpu0 741 0 982 1637620 1171 1814 388
page 35434 17072
swap 1 0
intr 3364141 1642716 28 0 0 3 0 6 0 1 0 0 1715412 144 0 0 5831
disk_io:
ctxt 1971493
btime 1106034798
processes 3503
procs_running 1
procs_blocked 0

The disk_io does not return any value however the same work fine if
the IDE disk is booted as the primary master . I have pasted the below
details to help you .

root@tmp]# rpm -q sysstat
sysstat-5.0.5-5.rhel3

[root@ tmp]# df -k
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hdc2              9384708   2730508   6177472  31% /
/dev/hdc1               101089      9200     86670  10% /boot
none                    126612         0    126612   0% /dev/shm

[root@tmp]# iostat
Linux 2.4.21-9.EL    01/18/2005

avg-cpu:  %user   %nice    %sys %iowait   %idle
           0.05    0.00    0.19    0.08   99.68

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
hdc               0.38         4.57         2.37      76254      39474
hdc1              0.00         0.01         0.00        180         18
hdc2              0.37         4.53         2.37      75482      39456
hdc3              0.00         0.01         0.00        168          0


This issue is very critical since our application uses the disk_io
value to monitor the disk perfomance on RH Enterprise server and due
to this issue we are unable to monitor the disk of our critical
customers who are running RH AS 3.0 . 


Thanks
Yogesh








Comment 2 Neil Horman 2005-01-25 13:38:51 EST
This isn't a bug, its a limitation of the /proc/stat file and the data
structures which hold the information presented in it.  Due to ABI compatibility
issues, it is impossible in the RHEL3 series to add any stats to
/proc/partitions for devices with block major > 16.  Instead, /proc/partitions
has all the current information in /proc/stat (only in a slightly different
format), and includes the missing devices.

Note You need to log in before you can comment on or make changes to this bug.