Bug 144651 - Keyboard and mouse problems with SMP kernels
Keyboard and mouse problems with SMP kernels
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 06:08 EST by Fat Rat Bastard
Modified: 2015-01-04 17:15 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-21 20:36:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fat Rat Bastard 2005-01-10 06:08:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I just installed nahant b2 on an SMP i386 system. If I boot to an SMP
kernel, once I get past grub, my keyboard and mouse fail to function
properly. Strangely enough, input on my keyboard causes my mouse
cursor to jump around on the screen in a seemingly random fashion.
However, using the UP seems to not cause this strange behavior.
Needless to say I was unable to complete the install (complete
firstboot) w/o selecting a UP kernel.

I have compiled stock 2.6.10 UP and SMP kernels on this RHEL 4
install, and DO NOT get this behavior.

dmesg shows the following when grep'ing for 'mouse' when booting the
RHEL SMP kernels:

[root minerva ~]# dmesg | grep -i mouse
mice: PS/2 mouse device common for all mice
psmouse.c: Failed to reset mouse on isa0060/serio0
input: PS/2 Generic Mouse on isa0060/serio0
psmouse.c: Failed to enable mouse on isa0060/serio0
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 1 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.
psmouse.c: Mouse at isa0060/serio0/input0 lost synchronization,
throwing 2 bytes away.



Hardware:

SuperMicro X5DAL-TG2 motherboard
Intel E7505 chipset

Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-1.648_EL and kernel-smp-2.6.9-1.675_EL

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL 4b2
2. Boot to SMP RHEL 4b2 kernels listed above.
3.
    

Expected Results:  Everything to work fantastically, what else?

Additional info:
Comment 1 Steven Leatherman 2005-02-15 12:18:49 EST
This problem still exists in the current release of Red Hat Enterprise
4.  I can duplicate the problem using RHEL 4 on a Dell Precision 530
workstation and the SMP kernel.
Comment 2 Paul Raines 2005-03-31 18:25:11 EST
We have the same problem on a dual XEON system using an Intel SE7505VB2 board
on the stock RHEL4 smp kernel.
Comment 3 Paul Raines 2005-04-01 10:34:04 EST
Turns out disabling Legacy USB in the BIOS makes the problem go away.

Note You need to log in before you can comment on or make changes to this bug.