Bug 144655 - RHEL4ES/B2 Red Hat Setup Agent errors in Activate module
Summary: RHEL4ES/B2 Red Hat Setup Agent errors in Activate module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firstboot
Version: 4.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-10 13:00 UTC by Robert G. 'Doc' Savage
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2005-02-07 07:45:11 UTC


Attachments (Terms of Use)
system-generated error log file (549 bytes, text/plain)
2005-01-10 13:02 UTC, Robert G. 'Doc' Savage
no flags Details

Description Robert G. 'Doc' Savage 2005-01-10 13:00:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
During post-install configuration I received this error:

firstboot.py
An error has occurred in the Activate module
Traceback (most recent call last)
  File "/usr/share/firstboot/firstbootWindow.py", line 48, in
loadModules vbox, pix, title = module.launch()
  File "/usr/share/firstboot/modules/rhn_activate_gui.py", line 90, in
launch self.setupScreen()
  File "/usr/share/firstboot/modules/rhn_activate_gui.py", line 83, in
setupScreen vbox = self-activatePagePrepare()
  File "/usr/share/rhn/up2date.client/rhnregGui.py", line 336, in
activatePagePrepare if hostname:
UnboundLocalError: local variable 'hostname' referenced before assignment.

Since there is a problem with the Activate module, Red Hat Setup Agent
will not load this module and will attempt to run the remaining modules.

Please file a bug against 'firstboot' in the Red Hat bug tracking
system at http://www.redhat.com/bugzilla. A copy of the debug output
has been saved to /root/firstboot.1105321553.53
Be sure to attach that file to the bug report.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1."Everything" install of B2 from five-CD set
2.During first boot following install, error appears
3.
    

Actual Results:  Error message in Description appears

Additional info:

Tyan S2468 motherboard with Dual Athlon MP 2800+ and 3G RAM
Adaptec 2000S ZCR controller using i2o_block driver.

Comment 1 Robert G. 'Doc' Savage 2005-01-10 13:02:10 UTC
Created attachment 109551 [details]
system-generated error log file

Comment 2 Jay Turner 2005-02-07 07:45:11 UTC
This is actually a dup of another bug, but the other one appears to be private
so can't dup them.  Anyway this error is resolved with the 4.4.4 up2date version
(specifically tested with 4.4.5-1)


Note You need to log in before you can comment on or make changes to this bug.