Bug 14466 - Remnants of /etc/init.d still in cipe package.
Summary: Remnants of /etc/init.d still in cipe package.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cipe (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-22 19:36 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-22 20:28:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-07-22 19:36:54 UTC
There are some remnants of /etc/init.d in cipe package still.

Namely:

 - /etc/rc.d/init.d/ciped tries to source /etc/init.d/functions.
 - SPEC file Prereq's /etc/init.d

These _do_ work due to symlinks, but break backwards compatibility; should
be fixed IMO.

Comment 1 Bill Nottingham 2000-07-22 20:28:56 UTC
It's part of the transition to /etc/init.d; the requirement
is there so that the package does work (you need to prereq
/etc/init.d if you're going to source /etc/init.d/functions.)

Comment 2 Nalin Dahyabhai 2000-07-23 20:51:11 UTC
Since we're going the symlink route for this release, I've reverted
that change for 1.3.0-9.


Note You need to log in before you can comment on or make changes to this bug.