Bug 144704 - up2date --register presents error dialog "Problem sending hardware information"
up2date --register presents error dialog "Problem sending hardware information"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
: 149007 150200 (view as bug list)
Depends On:
Blocks: 137160 155573 156323
  Show dependency treegraph
 
Reported: 2005-01-10 15:28 EST by James Laska
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: RHBA-2005-711
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 13:12:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (196.02 KB, image/png)
2005-01-10 15:28 EST, James Laska
no flags Details
included patch from previous version (9.05 KB, patch)
2005-01-11 09:13 EST, Florian La Roche
no flags Details | Diff
up2date changes in the new package (1.46 KB, patch)
2005-01-11 09:15 EST, Florian La Roche
no flags Details | Diff

  None (edit)
Description James Laska 2005-01-10 15:28:33 EST
# TREE rel-eng/RHEL4-RC-re0107.0
# ARCH confirmed on i386, ppc, s390
# RHN  xmlrpc.rhn.webqa.redhat.com

I am presented with the error dialog when sending the hardware profile using the
graphical up2date client.  The error appears to be triggered by the code found
in the ActivatePage::activatePageApply() (see rhnregGui.py:572).  The error
appears to be preventing RHN registration.  However, closer inspection shows
that the system is registered to the channel and I can query RHN using commands
like: up2date --show-channels, up2date -l ...

NOTE: rhn_register --nox works fine.  This appears to only occur during the
graphical registration process.

The system_id's that have observed the failure are noted below:

  Arch   System ID
  =====================
  i386 - ID-1005179891
  ppc  - ID-1005179888
  s390 - ID-1005179893
Comment 1 James Laska 2005-01-10 15:28:33 EST
Created attachment 109574 [details]
Screenshot
Comment 2 Adrian Likins 2005-01-10 15:39:11 EST
Can you send me the output of 

python /usr/share/rhn/up2date_client/hardware.py

for some of those boxes?
Comment 3 James Laska 2005-01-10 15:53:42 EST
The x86_64 system is currently being utilized for other testing ... but here are
the results of the command noted in comment#2 for ppc and s390:

  http://people.redhat.com/jlaska/144704-ppc.txt
  http://people.redhat.com/jlaska/144704-s390.txt
Comment 4 Adrian Likins 2005-01-10 16:34:29 EST
hmm, can I get a shell on one of those boxes? My
initial thought was that it was a server fault, but
I can't find anything in the server traceback logs
to indicate that.
Comment 5 Adrian Likins 2005-01-10 17:32:09 EST
I see what it is. It's a bug introduced in the
fix for #142332. A change to make firstboot do
the right things (not hang on no network), causes
rhn_register to not initialize it's hardware list
correctly. 

This bug should affect all arches. Should probably
be a blocker of some sort, if theres such a thing
at this point. 

up2date-4.4.6 should have a fix for this, but
firstboot stuff needs to be verified. 

Comment 7 Florian La Roche 2005-01-11 09:13:19 EST
Created attachment 109606 [details]
included patch from previous version
Comment 8 Florian La Roche 2005-01-11 09:15:36 EST
Created attachment 109608 [details]
up2date changes in the new package
Comment 10 Jay Turner 2005-01-11 09:53:01 EST
Some additional notes.  On an IA64, up2date-4.4.5-1 fails as decribed above when
run as "up2date --register", but succeeds when run through firstboot.
Comment 11 Adrian Likins 2005-01-11 11:41:19 EST
firstboot works fines, `rhn_register` shows the error. 
The hardware profile does not get sent up. 

It can get sent later with `up2date --hardware` or
a schedule hardware update action. 

System does get registered correctly, sans the
hardware information (though, as a side effect,
the user has to specify a profilename manually).

user can proceed past the error. 
Comment 13 Adrian Likins 2005-01-14 15:01:18 EST
4.4.7 has the fix (actually, 4.4.6, but whose counting)
Comment 14 Jay Turner 2005-02-18 07:38:29 EST
*** Bug 149007 has been marked as a duplicate of this bug. ***
Comment 16 Jay Turner 2005-03-04 05:27:27 EST
*** Bug 150200 has been marked as a duplicate of this bug. ***
Comment 17 Jay Turner 2005-03-08 06:04:03 EST
Moving to PROD_READY, as up2date-4.4.8-1 resolves the issue.
Comment 26 Todd Warner 2005-09-23 16:30:40 EDT
PROD_READY-->RELEASE_PENDING
Comment 27 Red Hat Bugzilla 2005-10-05 13:12:30 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-711.html

Note You need to log in before you can comment on or make changes to this bug.