Bug 144718 - install FC3 on Dell I7500 laptop
install FC3 on Dell I7500 laptop
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 17:20 EST by jmw
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 10:41:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first log file (60.47 KB, text/plain)
2005-06-17 18:50 EDT, jmw
no flags Details
first log file (45.22 KB, text/plain)
2005-06-17 18:51 EDT, jmw
no flags Details
third log file (2.88 KB, text/plain)
2005-06-17 18:52 EDT, jmw
no flags Details
fourth log file (1003 bytes, text/plain)
2005-06-17 18:52 EDT, jmw
no flags Details

  None (edit)
Description jmw 2005-01-10 17:20:29 EST
Description of problem:
copied FC3 ISOs from Stanford EDU site, created bootable CDs, GUI
installation completed normally.  on reboot, i saw the usual boot
messages; right after "enter I for interactive mode...", the LCD
screen went blank and remained blank.  forced power-off, reboot, Linux
checks system integrity, same blank screen at same point.

i tried several combinations of setup through re-install of FC3, no
difference.  aside from this, the entire installation process always
appears to end normally.

Version-Release number of selected component (if applicable):


How reproducible:
always returns blank display at the same point in the boot process.

Steps to Reproduce:
1. follow typical FC3 installation from bootable CD.
2. remove last CD and re-boot.
3.
  
Actual results:
blank display on system boot-up.

Expected results:
FC3 login screen, for root account.

Additional info:
on boot-up, i briefly see a message that reds in part "PCI: unable to
assign address on .... device 0000.00.07..." (not able to capture full
message).

Dell I7500, 600MHz Pentium III, BIOS A14 2000, ATI Rage Mobility-P
AGP2-X video adaptor, 512MB Ram, 18GB HD (nothing else on disk).  for
what it's worth, this I7500 otherwise works normally with Windows 2000
SP4.
Comment 1 Bill Nottingham 2005-01-10 17:23:54 EST
The logical thing that would cause this sort of behavior is the
starting of the X server for rhgb. Does it still happen if you remove
'rhgb' from the boot line?
Comment 2 jmw 2005-01-10 18:04:31 EST
wow... that was quick.  made a little progres:

i changed the boot line.  it now reads:
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol100 quiet

remove 'quiet' too?  i don't know what that, or 'rhgb', does. 
meanwhile....
this time it gets as far as a command line 'localhost login:' (similar
to my RH9 version on another machine) and the screen goes blank again.

only other error message i can capture is this, at initial boot:
"PCI: cannot allocate resource region 4 of device 0000:00:07.1"
don't know if that helps.
Comment 3 jmw 2005-01-10 19:00:52 EST
seems that last stopping point was a fluke... 
i tried the 'rescue cd', found 'grub.conf' and edited the boot line
with vi.  saved and rebooted.  now it gets as far as a couple of lines
after 'bringing up eth0', displays a screenful of some error messages,
then the screen goes blank again.  if i knew where to find a file with
that last screenful of error message, i may be able to offer more.
Comment 4 Mike A. Harris 2005-01-31 19:31:26 EST
Configure your system to boot into runlevel 3, so you can log
in normally as root to a text console.  After doing this, update
your system to the latest Fedora Core 3 updates, including the
kernel.  Reboot the system if the kernel has been updated.

Then run:

    system-config-display --reconfig

Then run "startx".  Please indicate wether the problem occurs
still or not.  If the problem persists, please upgrade to the
xorg-x11 in Fedora development (currently xorg-x11-6.8.1.903),
and try to reproduce the problem again.

If the issue still exists in the Fedora development Xorg (which
will be released as an official update for FC3 soon), provide a
status update in bugzilla, and please attach your X server log,
X config file, and /var/log/messages from the failed session as
individual uncompressed attachments, using the link below.

Thanks in advance.
Comment 6 Mike A. Harris 2005-04-15 10:41:29 EDT
This bug has not been updated to provide us with the information
we've requested above.  If you have not already updated to the
latest Fedora Core xorg-x11 and kernel updates, please do so now and
if you still encounter the problem described above, please report the
issue to X.Org bugzilla at http://bugs.freedestop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Setting status to "NOTABUG" due to lack of information.
Comment 7 jmw 2005-06-17 18:50:46 EDT
Created attachment 115640 [details]
first log file

first of four files that may be useful.
Comment 8 jmw 2005-06-17 18:51:25 EDT
Created attachment 115641 [details]
first log file

second of four files that may be useful.
Comment 9 jmw 2005-06-17 18:52:01 EDT
Created attachment 115642 [details]
third log file

third of four files that may be useful.
Comment 10 jmw 2005-06-17 18:52:36 EDT
Created attachment 115643 [details]
fourth log file

fourth of four files that may be useful.
Comment 11 jmw 2005-06-19 17:57:14 EDT
hey!!!  ...seems i found a fix!
after an extensive go-ogle, i found an article that described appending an
option to the vmlinuz line in grub.conf:  vga=791 (affects 'framebuffer',
apparently)
i made a backup, changed the original, set level 5, rebooted.
now, FC4 boots into a GUI log-in, and it seems most things work.
next, i will try restoring 'rhgb' and 'quiet' options on the same line.  also,
FC4 installer left me with a low resolution format -- 800x640 -- and i know that
my ATI Rage Mobility card can support 1280x1024 & 70Hz, so it seems i will need
to experiment with other settings in grub.conf.

Note You need to log in before you can comment on or make changes to this bug.