Bug 144732 - Temporary disabled services can not be re-enabled (wont start)
Temporary disabled services can not be re-enabled (wont start)
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: xinetd (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 19:10 EST by Kazu Fukushige
Modified: 2015-08-31 23:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-24 15:49:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test program for CPS (3.72 KB, text/plain)
2005-01-12 11:56 EST, Jay Fenlason
no flags Details

  None (edit)
Description Kazu Fukushige 2005-01-10 19:10:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
A customer is encountered the following phenominon.
I would beleve that it seem to very simillar case as Bug # 60049 which
is not fixed yet.

(1)Log file

Dec 10 06:26:22 server xinetd[4324]: Deactivating service ftp due to
excessive incoming connections.  Restarting in 30 seconds.
Dec 10 06:26:52 server xinetd[4324]: bind failed (Address already in
use (errno = 98)). service = ftp
Dec 10 06:26:52 server xinetd[4324]: Error activating service ftp
Dec 10 06:26:52 server xinetd[25682]: Failed to contact identity
server at xxx.xxx.xxx.xxx: timeout

(2) Config File  /etc/xinetd.conf 
 
#
 # Simple configuration file for xinetd
 #
 # Some defaults, and include /etc/xinetd.d/
 
 defaults
 {
         instances               = 60
         log_type                = SYSLOG authpriv
         log_on_success          = HOST PID
         log_on_failure          = HOST
         cps                     = 25 30
 }
 
 includedir /etc/xinetd.d

I would appriciatet that if you could give me any work around this issue.

Please let me know that if you need any further info about this.

Regards,




Version-Release number of selected component (if applicable):
xinetd-2.3.12-2.3E

How reproducible:
Always

Steps to Reproduce:
1. In order to access more that 25 access. The sevice will be stop
within 30 sec. However It does not work properly. 
2.
3.
    

Additional info:
Comment 2 Kazu Fukushige 2005-01-11 19:32:47 EST
Fristly , I will issue it in IT.
However I have suggested to the customer to try to modify to following
param for work around.

cps                     = 50 30

Regards
Comment 3 Jay Fenlason 2005-01-12 11:56:30 EST
Created attachment 109675 [details]
Test program for CPS

WORKSFORME with the attached simple test program.  It creates a simple service,
triggers CPS, waits the CPS re-enable interval, and confirms that the service
re-enabled itself.
Comment 4 Jay Fenlason 2005-01-12 11:58:44 EST
Also, can you attach a tar of the /etc/xinetd.d directory on the 
server?  /etc/xinetd.conf by itself is of limited utility. 
Comment 5 Jay Fenlason 2005-10-24 15:49:30 EDT
WORKSFORME and no activity in a long time.  Closing. 

Note You need to log in before you can comment on or make changes to this bug.