Bug 144748 - disk druid should add partitions to a drive in the order I create them
disk druid should add partitions to a drive in the order I create them
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
: FutureFeature
: 144750 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-10 22:52 EST by Myk Melez
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-11 15:13:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Myk Melez 2005-01-10 22:52:23 EST
When I create partitions with Disk Druid, it doesn't add them to the
drive in the order I create them.  For example, if I create a 100MB
/boot partition and then a 4000MB swap partition on a drive, it places
the swap partition before the /boot partition, even though I created
the /boot partition first and the /boot partition should be the first
partition on the drive.

Disk Druid should add partitions to a drive in the order I create them.
Comment 1 Myk Melez 2005-01-10 23:04:41 EST
Note bug 144750, which combined with this bug makes Disk Druid
completely unusable for manual partitioning when the order of
partitions is important.
Comment 2 Jeremy Katz 2005-01-11 15:13:53 EST
/boot will be first because it's special cased.  Others won't be
because we have to put down the _largest_ partitions first to allow
for growing to occur.

If you want finer-grained then you have to lose the ability of growing
either by running parted manually or by editing free spaces which will
give you cylinder based partitioning.
Comment 3 Jeremy Katz 2005-01-11 15:14:27 EST
*** Bug 144750 has been marked as a duplicate of this bug. ***
Comment 4 Myk Melez 2005-01-11 16:33:11 EST
I'm happy to lose the ability to grow physical partitions, since I use
LVM for most partition management.  I create only /boot, a swap
partition equal to twice the maximum memory the machine can ever hold,
and one large LVM partition that takes up the rest of the space on
disk.  Thus I never need to grow a physical partition.

Nevertheless, even if that's insufficient cause to allow users to
control partition order, it's still the case that contrary to
expectation /boot is *not* first and special-cased in my situation. 
If I first create a /boot partition and then create a swap partition,
Disk Druid adds the swap partition *before* the /boot partition.

So if /boot is supposed to be first (as I reckon it should be), then
that's a bug, even if you don't intend to fix the larger issue of
control over partition ordering.

Note You need to log in before you can comment on or make changes to this bug.