Bug 144751 - orbs.dorkslayers.com RBL in default config causes false positives
orbs.dorkslayers.com RBL in default config causes false positives
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: spamassassin (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2005-01-10 23:23 EST by Karl Latiss
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-08 14:51:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl Latiss 2005-01-10 23:23:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.4.3)
Gecko/20040924 MultiZilla/1.6.4.0b

Description of problem:
The default config includes orbs.dorkslayers.com which according to
 
http://www.dorkslayers.com/
 
is no longer available. Subsequently it returns true for every query.


Version-Release number of selected component (if applicable):
spamassassin-2.55-3.4

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL spamassassin and use default config
2.
3.
    

Actual Results:  All email receives scores from orbs.dorkslayers.com
falsely inflating SPAM scores

Expected Results:  No score assigned by orbs.dorkslayers.com test

Additional info:
Comment 2 Ronald Cole 2005-02-16 17:40:19 EST
Please, please, please, please upgrade this package to 3.0.2 for RHEL3!

2.55 is WOEFULLY out of date (as in almost two years)!!

Comment 3 Ronald Cole 2005-02-18 17:53:28 EST
Here's a possible workaround for Karl's problem (hey, it works for me):

1. Add "FEATURE(`dnsbl', `sbl.spamhaus.org')dnl" and similar to your
   sendmail.mc and rebuild your sendmail.cf
2. Add "skip_rbl_checks 1" to /etc/mail/spamassassin/local.cf and
   restart spamd.

However, in an attempt to resolve my "stale spamassassin" problem, I
grabbed the spamassassin-3.0.1 source rpm from the RHEL4 release,
downloaded spamassassin-3.0.2 from apache and tweaked the spec file to
use it.  The rpmbuild complained about MakeMaker needing to be version
6.11 or later, but built the package anyway.  Trying to install the
resulting binary rpm results in the error:

error: Failed dependencies:
        perl(:MODULE_COMPAT_5.8.0) is needed by spamassassin-3.0.2-0.fi

Not being a Perl-wizard, I an unsure how to proceed.  Any suggestions?
Comment 4 Sherwin Levinson 2005-10-19 13:21:20 EDT
Workaround:

edit /usr/share/spamassassin/20_head_tests.cf

to remove lines 277-279.

While an updated RPM might put this back, let's hope not since anyone preparing 
an update should know that dorkslayers.com is dead.
Comment 5 Warren Togami 2007-06-08 14:51:33 EDT
Closing WONTFIX, RHEL3 spamassassin will not be updated.

Note You need to log in before you can comment on or make changes to this bug.