Bug 144758 - nfs4 mount hangs
nfs4 mount hangs
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 06:31 EST by Holger Burde
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 21:47:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Holger Burde 2005-01-11 06:31:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
mounting a nfs4 share hangs on the client. ctrl-c interupts - the
mount never completes.

Message : Jan 11 11:39:55 proton kernel: decode_getfattr: xdr error 10008!

Workaround : idmapd has to be restarted after nfs was started/reloaded


The problem is reproducable 

Version-Release number of selected component (if applicable):
nfs-utils-1.0.6-44

How reproducible:
Always

Steps to Reproduce:
1. mount -t nfs4 host:/ /mnt/whatever (regardles what options)
2.
3.
    

Actual Results:  mount hangs

Expected Results:  should mount share

Additional info:

restarting idmapd allways works
Comment 1 Holger Burde 2005-01-11 11:24:01 EST
the mount may hang after some time (3 h compile / no err message).
restarting the server does not help.
reboot of the client failed (hang at shutdown). seems the bug is moo
serious.
both boxes have selinux enabled (targetet policy / unchanged). both
are FC3 with latest patches.
Comment 2 W. Michael Petullo 2005-01-17 01:08:45 EST
I am having a similar problem.  My NFS server is an i386 Fedora Core 3
box with all of the updates.  My NFS client is a PowerPC Raw Hide box.
 Mounts hang indefinitely on the client and I see messages like the
following on the client:

Jan 16 23:58:03 imp kernel: decode_getfattr: xdr error 10008!

Server:
nfs-utils-1.0.6-44
kernel-2.6.10-1.741_FC3

Note that bug #137221 is very similar to this one.

Client:
kernel-2.6.9-1.1021_FC4
Comment 3 W. Michael Petullo 2005-02-05 21:12:07 EST
I installed 2.6.10-1.1124_FC4 and I am still having the problem
documented in comment #2.
Comment 4 W. Michael Petullo 2005-03-23 13:30:23 EST
This seems to be fixed for me by upgrading the client with the following packages:

kernel-2.6.11-1.1191_FC4
nfs-utils-1.0.7-1

Technically, some kernels > 2.6.10-1.1124_FC4 and < 2.6.11-1.1191_FC4 worked,
but  2.6.11-1.1191_FC4 is the kernel I am using now.
Comment 5 Steve Dickson 2005-03-30 14:19:22 EST
Yes the nfs4 code in later kernel is much, much, much better
than in earlier kernels... 

So can I close this?
Comment 6 Holger Burde 2005-03-31 13:13:25 EST
yep - its resolved since some weeks (feb if i remind correctly). 

Note You need to log in before you can comment on or make changes to this bug.