This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 144767 - Sound problem on IBM Thinkpad 600E
Sound problem on IBM Thinkpad 600E
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 08:45 EST by stelus
Modified: 2015-01-04 17:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 07:49:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
FC2 "modprobe.conf" sound section for IBM Thinkpad 600E (379 bytes, text/plain)
2005-01-12 11:41 EST, Joachim Frieben
no flags Details

  None (edit)
Description stelus 2005-01-11 08:45:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have installed Fedora 3 on IBM Thinkpad 600E and I have problem with
my sound
card. It's not detected by tool Soundcard detection. However it's
visible via scanpci command:
pci bus 0x0000 cardnum 0x06 function 0x00: vendor 0x1013 device 0x6001
Cirrus Logic CS 4610/11 [CrystalClear SoundFusion Audio Accelerator]

If I use alsaconf (alsa-utils-1.0.6-10.rhfc3.at, alsa-lib-1.0.6-5) it
doesn't help neither. Following error message is displayed in window
where alsaconf was run:
Loading driver...
/usr/sbin/alsaconf: line 674: rcalsasound: command not found
Setting default volumes...
Saving the mixer setup used for this in /etc/asound.state.
/usr/sbin/alsactl: save_state:1061: No soundcards found...

And here is the content of the /etc/modprobe.conf:
alias eth0 xirc2ps_cs
alias usb-controller uhci-hcd
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias snd-card-0 snd-cs46xx
alias sound-slot-0 snd-cs46xx
# --- END: Generated by ALSACONF, do not edit. ---

In system log one can find:
Jan 11 12:36:54 wa17224100121 kernel: Sound Fusion CS46xx: probe of
0000:00:06.0 failed with error -6

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:
Always

Steps to Reproduce:
1. run alsaconf
2. try to increase the volume level in sound control tool  
3.
    

Actual Results:  It's impossible to increase the sound in sound
control tool. Soundcard Detection tool cannot find any sound card on
the system. It's impossible to hear any music from audio CD.

Expected Results:  Increase volume and hear music from audio CD.

Additional info:
Comment 1 Joachim Frieben 2005-01-11 10:51:05 EST
Sound used to work for the CS4237B based sound system connected via
the ISA bus using the following entries in "modprobe.conf" - at least
for FC2. The sound setup as described below stopped working during the
FC3 test release cycle. Sound got never detected at all by
"/usr/bin/system-config-soundcard" which seems to be restricted to PCI
based sound devices.

--------------------------------------------
alias char-major-116 snd
alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220
fm_port=0x388 irq=5 dma1=1 dma2=0
install snd-cs4236 /sbin/modprobe --ignore-install snd-cs4236 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-cs4236 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-cs4236
--------------------------------------------
Comment 2 Joachim Frieben 2005-01-11 10:59:32 EST
It might be worth mentioning that in general, ISA PnP sound devices
are still supported by FC3. On my PR440FX based PC workstation
featuring a CS4236 sound device, "kudzu" correctly sets up
"modprobe.conf", and sound works nicely. Needless to say, that using
this file as a template  for my IBM Thinkpad 600E does not produce any
usable result either.
Comment 3 stelus 2005-01-12 07:01:30 EST
Hi Joachim,

Thanks a lot for the answer!!

I tried anyway the settings you mentioned but as expected - it didn't
work. There are following entries in system og:
Jan 12 12:44:54 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 6: ignoring bad line starting with 'fm_port=0x388' 
Jan 12 12:44:54 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 8: ignoring bad line starting with '/usr/sbin/alsactl' 
Jan 12 12:44:54 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 10: ignoring bad line starting with '/sbin/modprobe' 
Jan 12 12:44:55 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 6: ignoring bad line starting with 'fm_port=0x388' 
Jan 12 12:44:55 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 8: ignoring bad line starting with '/usr/sbin/alsactl' 
Jan 12 12:44:55 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 10: ignoring bad line starting with '/sbin/modprobe' 
...
Jan 12 12:46:08 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 6: ignoring bad line starting with 'fm_port=0x388' 
Jan 12 12:46:08 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 8: ignoring bad line starting with '/usr/sbin/alsactl' 
Jan 12 12:46:08 wa17224100121 modprobe: WARNING: /etc/modprobe.conf
line 10: ignoring bad line starting with '/sbin/modprobe' 

What's your opinion - are there any chance to make it work?

Best regards,
Piotr
Comment 4 Joachim Frieben 2005-01-12 11:40:22 EST
Sorry, I didn't notice that the lines of "modprobe.conf" had got
wrapped by copying them to the bugzilla text window. There are only
*4* distinct lines. I have attached the file itself now. This should
prevent further confusion. Anyway, as I said, sound only worked for me
up to FC2. I guess, some IRQs got changed by the later FC3 kernels,
and the "snd-cs4236" module options might need to be updated. Check
the relevant entries in the "/proc" and "/sys" respectively. I have
downgraded to a previous release again. I thus cannot help as far as
FC3 is concerned.
Comment 5 Joachim Frieben 2005-01-12 11:41:59 EST
Created attachment 109674 [details]
FC2 "modprobe.conf" sound section for IBM Thinkpad 600E
Comment 6 Miloš Komarčević 2005-01-15 18:28:15 EST
Aside from this sound chip never being automagically detected on the
600E, there seems to now be a problem with the latest batch of kernel
updates (2.6.10-1.7xx_FC3), here's what I get:

# modprobe snd-cs4236
FATAL: Error inserting snd_cs4236
(/lib/modules/2.6.10-1.741_FC3/kernel/sound/isa/cs423x/snd-cs4236.ko):
Unknown symbol in module, or unknown parameter (see dmesg)

with quite a few 

snd_cs4236: Unknown parameter `'

lines in dmesg output. 

The same /etc/modprobe.conf was working great up to the last 2.6.9
kernels.

(I've also reported this at bug #144742 previously)
Comment 7 Pontus Enhager 2005-01-17 15:39:12 EST
my soundcard does not work on kernels newer than 2.6.9-1.681_FC3

02:0c.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)

(TurtleBeach Santa Cruz 5.1)

i do not recall the error messages mentioned above though
Comment 8 Satish Balay 2005-01-17 22:08:28 EST
I have the following in modprobe.conf on a 600E
--
alias snd-card-0 snd-cs4236 
options snd-cs4236 isapnp=0 cport=0x538 port=0x530 sb_port=0x220 fm_port=0x388
irq=5 dma1=1 dma2=0
-- 
kernel-2.6.10-1.741_FC3 gives the following..
# dmesg |grep snd
snd_cs4236: Unknown parameter `'
snd_cs4236: Unknown parameter `'
...

# alsamixer
alsamixer: function snd_ctl_open failed for default: No such device

sound works with the following kernels:
kernel-2.6.9-1.681_FC3
kernel-2.6.10-0.ac10

Comment 9 Satish Balay 2005-01-17 22:26:09 EST
Ok - I just tried kernel-2.6.10-1.747_FC3 - and sound works on 600E. This issue
is fixed now?
Comment 10 Miloš Komarčević 2005-01-19 06:19:01 EST
I'd love to test as well, but where do you get this new kernel?
Couldn't see it in updates/testing, nor rawhide.
Comment 11 Miloš Komarčević 2005-01-19 08:42:39 EST
Ok, found davej's 2.6testkernels repository (doh), and can confirm
that 2.6.10-1.747_FC3 works for me too.
Comment 12 Eddie Goodwin 2005-01-21 16:37:50 EST
I've seen this problem many times on many different thinkpads.

It can usually be solved by going into the bios and changing the
'quick boot' setting to 'disabled' and then commit to an 'initialize'.

save the settings and reboot. The snd-cs4236 module will then load.
Its worked for me on FC2 and FC3 stock fedora kernels as well as 2.6.10.

For some reason a 'quick boot' doesn't initialize something in the
Crystal Audio chip that the kernel needs to see.

Please reply with your finidings.
Comment 13 stelus 2005-02-01 07:47:54 EST
Hello Everybody,

Quickboot was the source of the problem! It's working now :-))
Many thanks to Eddie for your help!! And for others for their ideas as
well.
Comment 14 Miloš Komarčević 2005-02-03 05:58:52 EST
Doesn't work again with the new 2.6.10-1.760_FC3 update

snd_cs4236: Unknown parameter `'
CS4236+ soundcard not found or device busy

And I had Quick Boot disabled all along, so that's not the source of
the problem.
Comment 15 Miloš Komarčević 2005-02-03 07:14:53 EST
Ok, I take that back. 

Eddie, pressing 'Initialize' in BIOS config (for me) puts Quick Boot
back into Enabled, so I had to go back and make sure it's disabled
again, and now I'm back where I was. 2.6.10-1.747_FC3 and
2.6.10-1.760_FC3 work, whereas 2.6.10-1.737_FC3 and 2.6.10-1.741_FC3
didn't, even with Quick Boot off.

So I guess it's both doen to Quick Boot and the module loader patch
that got was included in those two kernels. 

I do still get only one line of 

snd_cs4236: Unknown parameter `'

in dmesg output with 2.6.10-1.760_FC3, but at least the module loads
and sound works ok.

Excerpt from dmesg:
...
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
Linux Kernel Card Services
  options:  [pci] [cardbus] [pm]
snd_cs4236: Unknown parameter `'
piix4_smbus 0000:00:07.3: Found 0000:00:07.3 device
piix4_smbus 0000:00:07.3: IBM Laptop detected; this module may corrupt
your serial eeprom! Refusing to load module!
piix4_smbus: probe of 0000:00:07.3 failed with error -1
...
Comment 16 Dave Jones 2005-02-03 13:45:02 EST
what do you have in the options line for your audio module in
/etc/modprobe.conf  ?
Comment 17 Miloš Komarčević 2005-02-03 16:24:50 EST
Pretty much the same as everyone else:

alias snd-card-0 snd-cs4236
options snd-cs4236 isapnp="0" cport="0x538" port="0x530"
sb_port="0x220" fm_port="0x388" irq="5" dma1="1" dma2="0"
Comment 18 Joachim Frieben 2005-02-04 03:46:31 EST
Maybe you should drop the quotation marks, no?
Comment 19 Miloš Komarčević 2005-02-04 18:06:34 EST
Quotation marks are not the problem, but I did have two extra
whitespaces at the end of the options line. I get a clean output now,
thanks all.

Note You need to log in before you can comment on or make changes to this bug.