Bug 144792 - kernel 2.6.10-1.737_FC3 does not initialize driver for ethernet card (741, 760 too)
kernel 2.6.10-1.737_FC3 does not initialize driver for ethernet card (741, 76...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 11:28 EST by Joe Ogulin
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-20 15:03:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from lspci command (989 bytes, text/plain)
2005-01-11 11:29 EST, Joe Ogulin
no flags Details
Output of dmesg after booting with no kernel parameters (11.27 KB, text/plain)
2005-01-11 11:29 EST, Joe Ogulin
no flags Details
dmesg output after boot with acpi=off pci=usepirqmask (8.52 KB, text/plain)
2005-01-11 11:30 EST, Joe Ogulin
no flags Details
dmesg output with pci=routeirq (11.49 KB, text/plain)
2005-01-11 13:56 EST, Joe Ogulin
no flags Details

  None (edit)
Description Joe Ogulin 2005-01-11 11:28:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
The ACPI panic seems to have been fixed enough that I'm no longer
getting the "nobody cared" message for IRQ 11.

In fact, my sound card will now work (see bug 139449).

Now, however, it still does not bring up the ethernet card.  It tries to 
assign it to IRQ 0.

To get everything to work with no boot error messages, I have to use
the following kernel parameters:
acpi=off pci=usepirqmask

It will work without pci=usepirqmask, but I get some messages when it
tries to assign a couple of IRQs.. and then tells me to use that
parameter.




Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:
Always

Steps to Reproduce:
1. install kernel-2.6.10-1.737_FC3.i686.rpm
2. boot with no special kernel parameters

    

Additional info:

Toshiba 2775XDVD laptop, PIII-650
Comment 1 Joe Ogulin 2005-01-11 11:29:26 EST
Created attachment 109617 [details]
Output from lspci command
Comment 2 Joe Ogulin 2005-01-11 11:29:54 EST
Created attachment 109618 [details]
Output of dmesg after booting with no kernel parameters
Comment 3 Joe Ogulin 2005-01-11 11:30:47 EST
Created attachment 109619 [details]
dmesg output after boot with acpi=off pci=usepirqmask
Comment 4 Dave Jones 2005-01-11 12:43:15 EST
does pci=routeirq make it work too ?
Comment 5 Joe Ogulin 2005-01-11 13:56:34 EST
Created attachment 109630 [details]
dmesg output with pci=routeirq
Comment 6 Joe Ogulin 2005-01-11 13:57:53 EST
Unfortunately, even with pci=routeirq, I get the same results as with no
kernel parameters (or very similar ones).
Comment 7 Thomas Chung 2005-01-11 16:38:11 EST
I'm not sure it's related. 
I'll file a seperate bug report if you want me to. :)
Anyway, I've also noticed it couldn't find Synaptics driver either on
Evo N610c Notebook after installed kernel 2.6.10-1.737_FC3.

Please see following thread for more information:
http://fedoraforum.org/forum/showthread.php?p=151806#post151806

Thomas
Comment 8 Thomas Chung 2005-01-11 16:54:01 EST
Just want to follow up on syanptics issue.
Regardless "synaptics reset failed" messages, the touchpad on the
notebook seems to work fine. :)

Thomas
Comment 9 Joe Ogulin 2005-01-11 20:52:47 EST
Here's the error message I get when I boot without acpi=off when the
system tries to bring up eth0:

SIOCSIFFLAGS: Device or resource busy
Failed to bring up eth0.

Don't know if that will provide any clues or not.
Comment 10 Joe Ogulin 2005-01-17 11:07:37 EST
Kernel 2.6.10-1.741_FC3 has the same issues.
Comment 11 Joe Ogulin 2005-01-19 16:42:12 EST
Apparently, the Toshiba 2775XDVD laptop has ACPI v1.0b.

Found the spec info for it here:
http://www.acpi.info/DOWNLOADS/ACPIspec10b.pdf

The last BIOS upgrade from Toshiba was dated 10/3/2002, is
titled: ACPI Flash BIOS version 1.60 for Satellite 2755/2775

Comment 12 Dave Jones 2005-07-15 13:48:46 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 13 Joe Ogulin 2005-07-16 01:05:25 EDT
Well, I'm on FC4 now with kernel 2.6.12-1.1398_FC4.  It all seems to work now.

Thanks, everyone! :)

Note You need to log in before you can comment on or make changes to this bug.