Bug 1447996 - [RFE] Proxy support for Git access
[RFE] Proxy support for Git access
Status: CLOSED DUPLICATE of bug 1461213
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
All Linux
unspecified Severity medium
: GA
: cfme-future
Assigned To: Greg Blomquist
Dave Johnson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-04 07:20 EDT by Christian Jung
Modified: 2017-06-27 10:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 10:43:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Christian Jung 2017-05-04 07:20:27 EDT
Description of problem:
CF is now having more an more integration with Git/Github. Many enterprise customers are using Proxy servers to filter access to internet pages. Not being able to configure a proxy for different providers or SCM systems could be a show stopper in such an environment.


Version-Release number of selected component (if applicable):
all

How reproducible:
always

Additional info:
Ideally the proxy configuration should be specific for each individual SCM repository. e.g. public Git repos like Github used for the Ansible integration, could have a different proxy than internal repositories.

The setting should also be separate from provider specific proxy configuration.
Comment 4 Christian Jung 2017-05-24 04:13:29 EDT
HiHo,
with the new embedded Ansible, you can define a repository from which CF will clone the Playbooks. This repository can be an internal or external git repo. Including, but not limited to, github.com

Most enterprise customers only allow access to internet pages via Proxy Server. Currently it is not possible to define the proxy details which should be used to clone an external git repo.

The same applies to Automate. Since a while, you can define a git repo from which CF will clone the Automate domains. AFAIK right now it's also not possible to configure a proxy server for this.

Hope this helps,
Christian
Comment 5 Krain Arnold 2017-06-14 06:03:49 EDT
A temporary workaround for this is as follows:
Navigate to /var/lib/awx/venv/tower/lib/python2.7/site-packages/awx/playbooks/project_update.yml


Add the proxy info to the hosts info starting on line 14 like this:

- hosts: all
  connection: local
  gather_facts: false
  environment:
    http_proxy: http://your.special.proxy:PORT
    https_proxy: https://your.special.proxy:PORT

save the file and try to pull down the repo again.

profit. 

if you have a user:pass use this syntax:
    http_proxy: http://username:pass@proxy.com:8080
Comment 7 Christian Jung 2017-06-27 02:44:14 EDT
HiHo,
sounds like it. I originally created this for the git support in Automate, where you can import code from git. Starting with 4.5 we can also import playbooks from git, which should have proxy support as well.

Ideally it would be perfect if you can configure the proxy per repository. Some repo could be on github, while another one could be on an internal git, making it important to differentiate.

Regards,
Christian
Comment 8 Bronagh Sorota 2017-06-27 10:43:03 EDT

*** This bug has been marked as a duplicate of bug 1461213 ***

Note You need to log in before you can comment on or make changes to this bug.