Bug 144822 - clock (date, time) skews forward on ACPI resume
clock (date, time) skews forward on ACPI resume
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 14:19 EST by David Baron
Modified: 2015-01-04 17:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 20:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Baron 2005-01-11 14:19:58 EST
Description of problem:  Upgrading to kernel-2.6.10-1.737_FC3 from
kernel-2.6.9-1.724_FC3 caused a regression:  the clock seems to
advance double (I think) on ACPI resume.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:  Every time.

Steps to Reproduce:
1. Use ACPI suspend on IBM T42 laptop.
2. Resume
  
Actual results:  On resume, clock ends up too far in the future (I
think by the amount that the laptop's been suspended, although I
haven't tried enough times to be sure).

Expected results:  No clock skew.
Comment 1 David Baron 2005-01-11 16:07:11 EST
A few more details:  I was referring to S3 suspend, and my kernel boot
params include pci=noacpi acpi_sleep=s3_bios .
Comment 2 Tom Richardson 2005-01-11 17:14:36 EST
Having the same problem on an IBM T23 laptop with latest firmware.  I
noticed that the problem started with Dave Jones' test kernel 727_FC3
which I was using since it fixed an kernel panic on resume from RAM
caused by my Prism 2.5 card (bug #144045). dbaron, I agree with your
observation that the clock is ahead by the amount of suspend time.
Comment 3 Matthew Saltzman 2005-01-28 13:56:11 EST
Me too.  Thinkpad T41, kernel-2.6.10-1.741_FC3.
Comment 4 PJ B 2005-02-14 16:58:13 EST
Same thing. Dell 700m 2.6.10-1.760_FC3.
Comment 5 Matthew Saltzman 2005-02-18 10:44:47 EST
BTW, there is a workaround for this.  I have the following in 
/etc/acpi/actions/sleep.sh (as suggested at thinkwiki.org):

#!/bin/sh
/usr/bin/logger "Software suspend to RAM."
/bin/sync
/sbin/hwclock --systohc
/bin/echo -n mem > /sys/power/state
/sbin/hwclock --adjust
/sbin/hwclock --hctosys
/usr/bin/logger "Resume from suspend-to-RAM."

The script is invoked from /etc/acpi/events/sleep.conf:

event=button/sleep
action=/etc/acpi/actions/sleep.sh

and from /etc/acpi/events/lid.conf:

event=button/lid
action=/etc/acpi/actions/sleep.sh
Comment 6 Colin Charles 2005-03-31 22:17:26 EST
Can someone give this ago again, because I've read posts on the list (or on irc,
more likely) that suggest newer kernels have this fixed.
Comment 7 Steve Fox 2005-03-31 23:01:51 EST
Confirmed still broken on 2.6.10-1.770_FC3 with a Thinkpad T41p. Note that I
also have to manually stop mysqld

#!/bin/sh
/bin/sync
/etc/init.d/mysqld stop
echo -n 3 > /proc/acpi/sleep

Comment 8 Warren Togami 2005-03-31 23:43:10 EST
http://people.redhat.com/davej/kernels/Fedora/
Please test the 2.6.11 based FC3 update kernel from here.  It seems to prevent
clock skew on my Thinkpad T41.  You must have FC3 updates udev installed for
this kernel to work properly.
Comment 9 Steve Fox 2005-04-01 10:04:53 EST
Confirmed fixed with 2.6.11-1.9_FC3. I still have to manually kill dhclient and
restart the network service, but that's obviously another issue. This helps
though. Thanks.
Comment 10 Dave Jones 2005-07-15 16:39:17 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 11 Matthew Saltzman 2005-07-16 12:32:39 EDT
The machine I saw this on has been upgraded to FC4.  I'd been happily using the
workaround, but I just tested and it appears to be fixed, at least with the
latest FC4 kernel.

Note You need to log in before you can comment on or make changes to this bug.