Bug 144833 - Can't Connect via Network Device Control
Can't Connect via Network Device Control
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 15:23 EST by jim
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 06:14:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ifcfg-eth1 device (311 bytes, text/plain)
2005-01-12 16:50 EST, jim
no flags Details

  None (edit)
Description jim 2005-01-11 15:23:21 EST
Description of problem:
Can't connect to AP with simple activate of device
using  Network Device Control
Version-Release number of selected component (if applicable):
kernel version 2.6.9-1.681

How reproducible:
always

Steps to Reproduce:
1.open Network Device Control
2. Click Activate
3.  
  
Actual results:
Error for wireless request "Set Bit Rate" (8B20) :
    SET failed on device eth1 ; Operation not supported.

Determining IP information for eth1.../sbin/dhclient-script:
configuration for eth1 not found. 
Continuing with defaults.  
Sits there and then tries to ping the AP and returns 100$ failure in ping

Expected results:
Connection to Ap 

Additional info:

for me to connect I have to do the following...
1. after a reboot, open a terminal window su -  and type in   iwconfig
eth1 essid XXXXXXXXX key XXXXXXXXXX  I don't hit enter yet
2. I have a network monitor on my panel  I click it and click the
configure button it then shows me the devices availible to me. i click
my wireless device  and click the activate button.
3. I switch back to the terminal window, hit enter, and then switch
back to the pop-up window that is trying to activate my device.
4. I'm connected to my AP

if I deactivate the device.  I won't be able to connect again til I
Reboot!!


Extra...

Fedora Core 3
intel internal wireless using the ipw2200 drivers
Comment 2 Harald Hoyer 2005-01-12 04:17:48 EST
try to set the Bit Rate to "Auto"
Comment 3 jim 2005-01-12 16:50:56 EST
Created attachment 109697 [details]
ifcfg-eth1 device

I believe it is sset to "Auto" always has benn as far as I know
Comment 4 Bill Nottingham 2005-01-12 16:58:12 EST
What sort of hardware is this?
Comment 5 jim 2005-01-12 18:30:18 EST
internal intel wireless   "Centrino"   
Medion Notebook  model # 42100
1.5 ghz mobile pentium 
Comment 6 jim 2005-01-13 14:01:55 EST
I just upgraded to kernel-2.6.10-1.737_FC3
along with that came a few updates to network-manager & Gnome Network
NetworkManagerInfo seems to be fixed  so is this a new bug with
NetworkManagerInfo ?  If I use the NetworkManagerInfo it works if i
plug and unplug my cable,  but won't associate with my AP.  Please advise
Comment 7 Bill Nottingham 2005-10-03 16:20:23 EDT
Assigning to NetworkManager.
Comment 8 Dan Williams 2005-10-03 16:57:46 EDT
Can you do the following?

1) open a terminal, sudo/su to root
2) /sbin/service NetworkManager stop
3) /usr/bin/NetworkManager --no-daemon
4) try to connect to your access point

Then attach the output from NetworkManager that's in the terminal to this bug
report.

Thanks!
Dan
Comment 9 jim 2005-10-03 17:03:11 EDT
as requested dan  

[jim@fedorajim_mobile ~]$ su -
Password:
[root@fedorajim_mobile ~]# /sbin/service NetworkManager stop
Stopping NetworkManager daemon:                            [  OK  ]
[root@fedorajim_mobile ~]# /usr/bin/NetworkManager --no-daemon
NetworkManager: <information>   starting...
NetworkManager: <information>   eth1: Driver support level for 'ipw2200' is full
y-supported
NetworkManager: <information>   nm_device_new(): waiting for device's worker thr
ead to start
NetworkManager: <information>   nm_device_new(): device's worker thread started,
 continuing.
NetworkManager: <information>   Now managing wireless device 'eth1'.
NetworkManager: <information>   eth0: Driver support level for 'via-rhine' is fu
lly-supported
NetworkManager: <information>   nm_device_new(): waiting for device's worker thr
ead to start
NetworkManager: <information>   nm_device_new(): device's worker thread started,
 continuing.
NetworkManager: <information>   Now managing wired device 'eth0'.
NetworkManager: <information>   named started with pid 17231
NetworkManager: <information>   Updating allowed wireless network lists.
NetworkManager: <information>       SWITCH: best device changed
NetworkManager: <information>   Activation (eth1) started...
NetworkManager: <information>   Activation (eth1/wireless): waiting for access p
oint. (attempt 0)
NetworkManager: <information>   Activation (eth1/wireless): waiting for access p
oint. (attempt 100)
NetworkManager: <information>   Activation (eth1/wireless): waiting for access p
oint. (attempt 200)
NetworkManager: <information>   Activation (eth1/wireless): found access point '
HomeWireless' to use.
NetworkManager: <information>   Activation (eth1/wireless): access point 'HomeWi
reless' is encrypted, and a key exists.  No new key needed.
NetworkManager: <information>   Activation (eth1/wireless): using essid 'HomeWir
eless', with Open System authentication.
NetworkManager: dhcp_interface_init: MAC address = 00:0e:35:1f:ce:cf
NetworkManager: Broadcasting DHCP_DISCOVER
NetworkManager: DHCP: Starting request loop, overall start_time = {1128373284s,
600116us}
NetworkManager: DHCP: Request sent, waiting for reply...
NetworkManager: DHCP: Got some data of length 580.
NetworkManager: Server replied with 7 DHCP options:
NetworkManager:         Subnet Mask (1):        255.255.255.0
NetworkManager:         Router (3):     192.168.1.49
NetworkManager:         Domain Server (6):      24.92.226.9
NetworkManager:         Domain Name (15):       "rochester.rr.com"
NetworkManager:         Address Time (51):      86400
NetworkManager:         DHCP Msg Type (53):     2
NetworkManager:         DHCP Server Id (54):    192.168.1.49
NetworkManager:         Your IP Address:        192.168.1.53
NetworkManager:         DHCP Server Address:    192.168.1.49 (HW=00:0F:66:21:10: 45)
NetworkManager: Broadcast Address option is missing in DHCP server response. Ass
uming 192.168.1.255.
NetworkManager: Lease Time = 86400 in DHCP server response.
NetworkManager: Renewal Time (T1) is missing in DHCP server response. Assuming 4
3200s.
NetworkManager: Rebind Time (T2) is missing in DHCP server response. Assuming 75
600s.
NetworkManager: DHCP_OFFER received from  (192.168.1.XXX)
NetworkManager: Broadcasting DHCP_REQUEST for 192.168.1.XXX
NetworkManager: DHCP: Starting request loop, overall start_time = {1128373285s,
752909us}
NetworkManager: DHCP: Request sent, waiting for reply...
NetworkManager: DHCP: Got some data of length 580.
NetworkManager: Server replied with 10 DHCP options:
NetworkManager:         Subnet Mask (1):        255.255.255.0
NetworkManager:         Router (3):     192.168.1.49
NetworkManager:         Domain Server (6):      24.92.226.9
NetworkManager:         Domain Name (15):       "rochester.rr.com"
NetworkManager:         Broadcast Address (28): 192.168.1.255
NetworkManager:         Address Time (51):      86400
NetworkManager:         DHCP Msg Type (53):     5
NetworkManager:         DHCP Server Id (54):    192.168.1.XXX
NetworkManager:         Renewal Time (58):      0
NetworkManager:         Rebinding Time (59):    0
NetworkManager:         Your IP Address:        192.168.1.XXX
NetworkManager:         DHCP Server Address:    192.168.1.XXX
(HW=XX:XX:XX:XX:XX: XX)
NetworkManager: Lease Time = 86400 in DHCP server response.
NetworkManager: Renewal Time (T1) is missing in DHCP server response. Assuming 4
3200s.
NetworkManager: Rebind Time (T2) is missing in DHCP server response. Assuming 75
600s.
NetworkManager: DHCP_ACK received from  (192.168.1.XXX)
NetworkManager: <information>   Your IP address = 192.168.1.XXX
NetworkManager: <information>   Adding nameserver: 24.92.226.9
NetworkManager: <WARNING>         (): Adding domain search: rochester.rr.com

NetworkManager: <information>   Activation (eth1/wireless): Success!  Connected
to access point 'HomeWireless' and got an IP address.
NetworkManager: <information>   Activation (eth1) IP configuration/DHCP successf ul!
NetworkManager: <information>   Activation (eth1) ended.
NetworkManager: <information>   Activation (eth1) successful, device activated.
Comment 10 Dan Williams 2005-10-03 17:31:26 EDT
So what's the exact problem here?  It seems to be connecting to your access
point OK and getting an IP address...
Comment 11 jim 2005-10-04 06:09:29 EDT
If you notice the time at which I submitted this bug, it was with FC3.  I can
connect as you can see, The issue is that if I leave my notebook on and
connected, it will drop the connection after  afew hours.   I which i need to  do 
service network restart 
service MetworkManager restart 
then NetworkManagerInfo to get connected again. 

The next time this happens I will attach  a tail -100 /var/log/messages
Comment 12 jim 2005-10-04 06:14:32 EDT
We can close this bug and continue with bug # 151649.  I will attch the
messagelog file to that bug

Note You need to log in before you can comment on or make changes to this bug.