This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 144845 - i18n: inconsistent date format in ls -l command in Simplified Chinese
i18n: inconsistent date format in ls -l command in Simplified Chinese
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 17:11 EST by Mitrophan Chin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 5.2.1-37
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 11:37:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
changed the msgstr for src/ls.c:648 and src/ls.c:656 (214.73 KB, application/octet-stream)
2005-01-13 11:30 EST, Mitrophan Chin
no flags Details

  None (edit)
Description Mitrophan Chin 2005-01-11 17:11:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
ls -l in Simplified Chinese locale, gives previous year's datestamp
hyphenated YYYY-MM-DD, and it gives current year's datestamp as Month
name DD HH:MM and also it doesn't justify both formats to same width
for a cleaner output, like in the English locale. The datestamp should
be same width for both current and previous years' dates to make it
nicer for the eyes, and use the Chinese characters for year month and
day after each of the numerals, YYYY MM DD. Spacing is not necessary
between YYYYMMDD since Chinese doesn't use space to delineate words,
other than to line up the columns.

Version-Release number of selected component (if applicable):
coreutils-5.2.1-31

How reproducible:
Always

Steps to Reproduce:
1. login in Simplified Chinese local
2. cd /etc
3. ls -l | tail
    

Actual Results:  $ ls -l | tail
-rw-r--r--   1 root    root       585  1月  3 11:46 yp.conf
-rw-r--r--   1 root    root      1757 10月 14 15:15 ypserv.conf
-rw-r--r--   1 root    root        38  9月 13 11:08 ytalkrc
-rw-r--r--   1 root    root       253 12月  8 22:00 yum.conf
drwxr-xr-x   2 root    root      4096 12月  8 22:00 yum.repos.d
-rw-r--r--   1 root    root       252 2004-04-09  zlogin
-rw-r--r--   1 root    root        86 2002-10-14  zlogout
-rw-r--r--   1 root    root       168 2004-07-05  zprofile
-rw-r--r--   1 root    root       304 2002-11-28  zshenv
-rw-r--r--   1 root    root       640 2004-07-05  zshrc


Expected Results:  $ ls -l | tail
-rw-r--r--   1 root    root       585  1月 3日 11:46 yp.conf
-rw-r--r--   1 root    root      1757 10月14日 15:15
ypserv.conf
-rw-r--r--   1 root    root        38  9月13日 11:08 ytalkrc
-rw-r--r--   1 root    root       253 12月 8日 22:00 yum.conf
drwxr-xr-x   2 root    root      4096 12月 8日 22:00
yum.repos.d
-rw-r--r--   1 root    root       252 2004年04月09日
zlogin
-rw-r--r--   1 root    root        86 2002年10月14日
zlogout
-rw-r--r--   1 root    root       168 2004年07月05日
zprofile
-rw-r--r--   1 root    root       304 2002年11月28日
zshenv
-rw-r--r--   1 root    root       640 2004年07月05日
zshrc


Additional info:
Comment 1 Tim Waugh 2005-01-12 05:31:28 EST
Please supply a patch to the coreutils-5.2.1/po/ja.po file (or the corrected
file itself).

Thanks.
Comment 3 Mitrophan Chin 2005-01-12 16:42:46 EST
i think ja.po is japanese.. probably should be zh_CN.po
I never done this before.. How do I extract the file to edit it? The expected
results above, I did it with manual copy and paste.
Comment 4 Mitrophan Chin 2005-01-12 16:47:57 EST
I found this site. Is this used by fedora?

http://www.iro.umontreal.ca/translation/trans/zh_CN/
Comment 5 Tim Waugh 2005-01-13 05:35:46 EST
Sorry, I was thinking this was the same as bug #124862.

Not sure what you copied and pasted from, but it doesn't look like Chinese at
this end.  Get the zh_CN.po file from the coreutils source RPM:

CVSROOT=:pserver:anonymous@cvs.fedora.redhat.com:/cvs/dist
export CVSROOT
cvs -qz3 co coreutils
cd coreutils/devel
make prep
Comment 6 Mitrophan Chin 2005-01-13 11:30:49 EST
Created attachment 109725 [details]
changed the msgstr for src/ls.c:648 and src/ls.c:656
Comment 7 Tim Waugh 2005-01-13 11:37:18 EST
Thanks.  Fixed in coreutils-5.2.1-37.

Note You need to log in before you can comment on or make changes to this bug.