Bug 144851 - Unable to mount additional drives during bootup, but manually does just fine.
Unable to mount additional drives during bootup, but manually does just fine.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-11 17:44 EST by Ivo Sarak
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-12 23:21:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ivo Sarak 2005-01-11 17:44:32 EST
Description of problem:
Somehow the system refuses to mount SATA drives during the bootup, but
if to do try it manually then it will not complain a thing.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.667

How reproducible:
Always.

Steps to Reproduce:
1. Install FC3;
2. Add couple SATA drives to the system after installing the FC3;
3. Modify the /etc/fstab to mount the new drives;
4. Reboot the box;
  
Actual results:
Messages about "Unable to find valid ext2 filesystem on /dev/sda1 and
/dev/sdb1. If You are sure it is a valid ext2 then try e2fsck -b 8193
/dev/sda1 and e2fsck -b 8193 /dev/sdb1".

Expected results:
No errors and mounted drives as I can manually mount these without an
issue.

Additional info:

If to try with the lines it does advice to do:
[root@ragana ~]# e2fsck -b 8193 /dev/sda1
e2fsck 1.35 (28-Feb-2004)
e2fsck: Bad magic number in super-block while trying to open /dev/sda1

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

[root@ragana ~]# e2fsck -b 8193 /dev/sdb1
e2fsck 1.35 (28-Feb-2004)
e2fsck: Bad magic number in super-block while trying to open /dev/sdb1

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>

[root@ragana ~]#

But if to try to mount the drives by hand:
[root@ragana ~]# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      38381040  12675336  23756008  35% /
/dev/hda1               101086      9124     86743  10% /boot
none                    257904         0    257904   0% /dev/shm
[root@ragana ~]# mount /dev/sda1 /esimene
[root@ragana ~]# mount /dev/sdb1 /teine
[root@ragana ~]# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
                      38381040  12675336  23756008  35% /
/dev/hda1               101086      9124     86743  10% /boot
none                    257904         0    257904   0% /dev/shm
/dev/sda1            153834852 144075292   1945144  99% /esimene
/dev/sdb1            240362656 227516528    636328 100% /teine
[root@ragana ~]#


[root@ragana ~]# cat /etc/fstab
# This file is edited by fstab-sync - see 'man fstab-sync' for details
/dev/VolGroup00/LogVol00 /                       ext3    defaults    
   1 1
LABEL=/boot             /boot                   ext3    defaults     
  1 2
none                    /dev/pts                devpts  gid=5,mode=620
 0 0
none                    /dev/shm                tmpfs   defaults     
  0 0
none                    /proc                   proc    defaults     
  0 0
none                    /sys                    sysfs   defaults     
  0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults    
   0 0
#/dev/sda1               /esimene                ext3    defaults    
   1 1
#/dev/sdb1               /teine                  ext3    defaults    
   1 1

What is this?
How do fix this?
Comment 1 Ivo Sarak 2005-01-11 17:46:08 EST
Even the "fsck /dev/sda1" and "fsck /dev/sdb1" are not reporting
anything as being wrong.
Comment 2 Ivo Sarak 2005-01-12 15:35:31 EST
The issue is not SATA related after all, all drives what were added
after FC3 install complain the same error:
"/dev/XXX
The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and really contains an ext2
filesystem (and not swap or ufs or something else), then the
superblock is corrupt, and you might try sunning efsck with an
alternate superblock:
e2fsck -b 8193 <device>

fsck.ext3: No such file or directory while trying to open /dev/XXX"
Comment 3 Ivo Sarak 2005-01-14 17:04:16 EST
After "yum install kernel" I got it working!

Yum installed:
kernel-2.6.10-1.741_FC3

Note You need to log in before you can comment on or make changes to this bug.