Bug 144876 - kernel panic __put_unused_buffer_head
kernel panic __put_unused_buffer_head
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Glauber
Brian Brock
:
: 147548 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 04:06 EST by Karsten Hopp
Modified: 2007-11-30 17:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:09:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2005-01-12 04:06:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041204 Firefox/1.0

Description of problem:
spade became unresponsive after some time, ping still works, ssh,
login on the console or sysrq doesn't. These are the last messages on
the console, that's all the info I have (please close if that isn't
sufficient):


nfs: server curly.devel.redhat.com not responding, still trying

nfs: server curly.devel.redhat.com OK

nfs: server curly.devel.redhat.com OK

Unable to handle kernel pointer dereference at virtual kernel address
0000000000

000000

Oops: 0004

CPU:    7    Not tainted

cramfs loop autofs4 nfs lockd sunrpc audit qeth qdio af_packet sd_mod
scsi_mod e

xt3 jbd raid0 dasd_fba_mod dasd_eckd_mod dasd_mod  

Process lt-tethereal (pid: 16734, task: 00000000bfa00000, ksp:
00000000bfa03d18,

 f: 1)

Krnl PSW : 0700200180000000 0000000000082bac

           __put_unused_buffer_head [kernel] 0x6c (2.4.21-20.EL)

Krnl GPRS: 0000000000000000 9800000000000000 00000000000000b8
00000000001ceb64

           0000000000000000 000000000046c1a8 00000003ba4b5500
000000003ce4b8f8

           00000000000008a4 0000000094b3dd38 0000000000000000
000000000046c1b8

           0000000000000000 00000000001bb6d8 00000000bfa03a80
00000000bfa039e0

Krnl ACRS: 40d6c080 0abff970 00000000 00000000

           00000001 00000000 00000000 00000000

           00000000 00000000 00000000 00000000

           00000000 00000000 00000000 00000000

Krnl Code: e3 10 40 08 00 24 e3 00 20 08 00 24 c0 a0 00 1f 4a fc b9 04 

[<0000000000086684>] try_to_free_buffers [kernel] 0x128 (0xbfa03af0)

[<00000000000832b0>] try_to_release_page [kernel] 0x7c (0xbfa03b90)

[<000000000005f9b2>] filemap_nopage [kernel] 0x312 (0xbfa03c30)

[<0000000000056566>] do_no_page [kernel] 0x9a (0xbfa03ce0)

[<00000000000569d0>] handle_mm_fault [kernel] 0x13c (0xbfa03d90)

[<0000000000014898>] do_page_exception [kernel] 0x214 (0xbfa03e48)

[<000000000001572e>] sysc_return [kernel] 0x0 (0xbfa03ef0)

[<->] (0x0)

Kernel panic: Fatal exception


Version-Release number of selected component (if applicable):
2.4.21-20.EL

How reproducible:
Didn't try

Steps to Reproduce:
    

Additional info:
Comment 2 Pete Zaitcev 2005-02-09 01:07:46 EST
*** Bug 147548 has been marked as a duplicate of this bug. ***
Comment 3 Pete Zaitcev 2005-02-09 01:19:51 EST
This is getting serious. Larry, Rik, I would appreciate a look by
a virtual memory specialist, but please do not take this bug from
me just yet (unless this happens on other platforms, too).
Comment 4 Larry Woodman 2005-02-09 10:17:23 EST
It appears that the buffer_head.lru listhead is corrupt so the list_del(&bh->lru);
in __put_unused_buffer_head() crashes.  Is this reproducable and if so has it
ever  happened on other architectures?

Larry Woodman
Comment 5 Karsten Hopp 2005-02-10 05:44:23 EST
This happened after a few days uptime with building packages in beehive, it's not
reproducable with a simple command. But it has happened at least twice now,
probably more often.
Comment 6 Karsten Hopp 2005-03-17 11:33:45 EST
It happened again ;-)
Bug is still present in 2.4.21-27.EL:
addressing exception: 0038
CPU:    7    Not tainted

cramfs loop autofs4 nfs lockd sunrpc audit qeth qdio af_packet sd_mod scsi_mod
ext3 jbd raid0 dasd_fba_mod dasd_eckd_mod dasd_mod

Process uic (pid: 15462, task: 00000000a0abc000, ksp: 00000000a0abf818, f: 1)
Krnl PSW : 0700200180000000 0000000000083994
           __put_unused_buffer_head [kernel] 0x6c (2.4.21-27.EL)
Krnl GPRS: 0000000000000000 1800000000000000 00000000000000b8 00000000001d2fd2
           0001013f02517028 00000000004761a8 00000002b7bf4d00 00000002ab71edc0
           0000000000000028 00000000829e0528 0000000000000000 00000000004761b8
           0000000000000000 00000000001bf870 00000000a0abfa80 00000000a0abf9e0
Krnl ACRS: 40ddd200 28fff970 00000000 00000000
           00000001 00000000 00000000 00000000
           00000000 00000000 00000000 00000000
           00000000 00000000 00000000 00000000
Krnl Code: e3 10 40 08 00 24 e3 00 20 08 00 24 c0 a0 00 1f 94 08 b9 04
[<0000000000087474>] try_to_free_buffers [kernel] 0x128 (0xa0abfaf0)
[<00000000000840a0>] try_to_release_page [kernel] 0x7c (0xa0abfb90)
[<000000000006019e>] filemap_nopage [kernel] 0x312 (0xa0abfc30)
[<0000000000056c96>] do_no_page [kernel] 0x9a (0xa0abfce0)
[<0000000000057100>] handle_mm_fault [kernel] 0x13c (0xa0abfd90)
[<0000000000014898>] do_page_exception [kernel] 0x214 (0xa0abfe48)
[<000000000001572e>] sysc_return [kernel] 0x0 (0xa0abfef0)
[<->] (0x0)
Kernel panic: Fatal exception
Comment 7 Ernie Petrides 2005-10-06 19:40:27 EDT
Reassigning from PeteZ to Jan.
Comment 8 RHEL Product and Program Management 2007-10-19 15:09:22 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.