Bug 144886 - Kernel panic while initializing pcmcia bluetooth card
Summary: Kernel panic while initializing pcmcia bluetooth card
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-12 14:36 UTC by Leonid Kanter
Modified: 2015-01-04 22:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-30 00:44:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (36.98 KB, image/jpeg)
2005-01-12 14:38 UTC, Leonid Kanter
no flags Details

Description Leonid Kanter 2005-01-12 14:36:50 UTC
Description of problem:

"hciattach /dev/ttyS16 bcsp" produces kernel panic

Version-Release number of selected component (if applicable):

2.6.10-1.737_FC3

How reproducible:

always

Steps to Reproduce:
1. insert billionton pcmcia bluetooth card
2. run command "hciattach /dev/ttyS16 bcsp"

  
Actual results:

Kernel panic (see screenshot)

Expected results:

This card works (with warnings) with kernel 2.6.9-1.681_FC3

Additional info:

in 2.6.9 device name for this card was /dev/ttyS4, 2.6.10 - /dev/ttyS16

Comment 1 Leonid Kanter 2005-01-12 14:38:41 UTC
Created attachment 109667 [details]
screenshot

Comment 2 Leonid Kanter 2005-01-12 14:50:37 UTC
[root@omnibook ~]# cardctl info
PRODID_1="PCMCIA"
PRODID_2="Bluetooth Card"
PRODID_3=""
PRODID_4=""
MANFID=0279,950b
FUNCID=2
hciattach warnings in 2.6.9-1.681_FC3:
ttyS4 at I/O 0x100 (irq = 9) is a 16C950/954
Bluetooth: HCI UART driver ver 2.1
Bluetooth: HCI H4 protocol initialized
Bluetooth: HCI BCSP protocol initialized
bcsp_recv: Out-of-order packet arrived, got 1 expected 0
drivers/serial/serial_core.c:500:
spin_lock(drivers/serial/serial_core.c:024217e0) already locked by
drivers/serial/8250.c/1056
drivers/serial/8250.c:1058:
spin_unlock(drivers/serial/serial_core.c:024217e0) not locked
drivers/serial/serial_core.c:500:
spin_lock(drivers/serial/serial_core.c:024217e0) already locked by
drivers/serial/8250.c/1056
drivers/serial/8250.c:1058:
spin_unlock(drivers/serial/serial_core.c:024217e0) not locked
drivers/serial/serial_core.c:500:
spin_lock(drivers/serial/serial_core.c:024217e0) already locked by
drivers/serial/8250.c/1056
[root@omnibook ~]# hcitool inq
Inquiring ...
        00:E0:98:AD:FB:AA       clock offset: 0x7cc2    class: 0x120104
        00:0E:6D:15:9A:3B       clock offset: 0x7dd9    class: 0x500204

rfcomm, obex push and other features work perfectly with
2.6.9-1.681_FC3 and previous kernel.



Comment 3 Leonid Kanter 2005-01-14 11:59:38 UTC
reproduced on 1.741_FC3

Comment 4 Dave Jones 2005-07-15 18:40:48 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 5 Leonid Kanter 2005-07-18 08:13:00 UTC
This card works OK with 2.6.11-1.14 and 2.6.12-1.1372_FC3


Note You need to log in before you can comment on or make changes to this bug.