Bug 144917 - snmpwalk has extra carriage return in output
snmpwalk has extra carriage return in output
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Radek Vokal
David Lawrence
:
: 144928 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 13:49 EST by Stephen John Smoogen
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-23 08:10:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen John Smoogen 2005-01-12 13:49:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
We are evaluating net-snmp in RHEL-3 and onward to replace our older
Debian boxes. A problem in our switchwalking and autoblocking code was
found to be with an extra carriage return that 

snmpwalk -v 1 -c public -OQn 192.168.114.28 .1.3.6.1.2.1.17.4.3.1.1

5.1 SNMP shows this:

.1.3.6.1.2.1.17.4.3.1.1.0.224.129.42.189.239 = "00 E0 81 2A BD EF "
.1.3.6.1.2.1.17.4.3.1.1.8.0.9.215.46.79 = "08 00 09 D7 2E 4F "
.1.3.6.1.2.1.17.4.3.1.1.8.0.32.168.238.69 = "08 00 20 A8 EE 45 "

5.2 SNMP shows this

.1.3.6.1.2.1.17.4.3.1.1.0.208.183.189.145.97 = "00 D0 B7 BD 91 61
"
.1.3.6.1.2.1.17.4.3.1.1.0.208.183.189.188.194 = "00 D0 B7 BD BC C2
"
.1.3.6.1.2.1.17.4.3.1.1.0.224.43.0.0.1 = "00 E0 2B 00 00 01
"
.1.3.6.1.2.1.17.4.3.1.1.0.224.129.42.189.96 = "00 E0 81 2A BD 60
"
.1.3.6.1.2.1.17.4.3.1.1.0.224.129.42.189.239 = "00 E0 81 2A BD EF
"
.1.3.6.1.2.1.17.4.3.1.1.8.0.9.215.46.79 = "08 00 09 D7 2E 4F
"
.1.3.6.1.2.1.17.4.3.1.1.8.0.32.168.238.69 = "08 00 20 A8 EE 45
" 

There seems to be an extra carriage return after the mac address.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. snmpwalk your switches
2. see bad data
3.
    

Additional info:

Trying to work out patch.. but slow going on my part.
Comment 1 Stephen John Smoogen 2005-01-12 14:49:08 EST
*** Bug 144928 has been marked as a duplicate of this bug. ***
Comment 2 Stephen John Smoogen 2005-01-12 15:23:22 EST
It looks like the extra \n is being added before the printout. Doing a
 -D ALL to the command line showed items like this:

trace: snmp_pdu_parse(): snmp_api.c, 4339:
dumph_recv:         Value
dumpx_recv:          04 06 08 00 20 A8 EE 45

dumpv_recv:            String:  .. ..E
trace: sprint_realloc_by_type(): mib.c, 1975:

These are not in the 5.1.2 Debug
Comment 3 Radek Vokal 2005-02-23 08:10:08 EST
Fixed, will appear in rawhide. 

Note You need to log in before you can comment on or make changes to this bug.