This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 144926 - ipw2100 and ipw2200 fail to resume after software suspend
ipw2100 and ipw2200 fail to resume after software suspend
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 14:39 EST by petrosyan
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-12 10:03:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2005-01-12 14:39:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
After going to S3 state by running the command:
echo -n "mem" > /sys/power/state
and then resuming, ipw2100 fails to initialize.

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3

How reproducible:
Always

Steps to Reproduce:
1. $echo -n "mem" > /sys/power/state
2. resume the machine


Actual Results:  ipw2100: eth1: ipw2100_verify failed: -5
ipw2100: eth1: Failed to power on the adapter.
ipw2100: eth1: Failed to start the firmware.

Expected Results:  ipw2100 should work, as it did with previous kernels.

Additional info:

here is a dmesg:

Stopping tasks: ================================================================================|
Back to C!
Warning: CPU frequency is 1000000, cpufreq assumed 600000 kHz.
Debug: sleeping function called from invalid context at mm/slab.c:2061
in_atomic():0, irqs_disabled():1
 [<c011857c>] __might_sleep+0x7b/0x85
 [<c0145c53>] __kmalloc+0x40/0x76
 [<c01ea5a1>] acpi_os_allocate+0xa/0xb
 [<c01fdf53>] acpi_ut_callocate+0x30/0x79
 [<c01fde92>] acpi_ut_initialize_buffer+0x4a/0x89
 [<c01fad08>] acpi_rs_create_byte_stream+0x23/0x3b
 [<c01fc1ba>] acpi_rs_set_srs_method_data+0x1b/0x9d
 [<c0116bb9>] recalc_task_prio+0x128/0x133
 [<c02034d0>] acpi_pci_link_set+0xfe/0x176
 [<c0203856>] irqrouter_resume+0x1c/0x24
 [<c023896b>] sysdev_resume+0x3e/0xa5
 [<c023b9da>] device_power_up+0x5/0xa
 [<c01376b2>] suspend_enter+0x25/0x2d
 [<c0137718>] enter_state+0x37/0x53
 [<c0137814>] state_store+0x83/0x91
 [<c0137791>] state_store+0x0/0x91
 [<c019cefc>] subsys_attr_store+0x19/0x21
 [<c019d0ca>] flush_write_buffer+0x20/0x25
 [<c019d111>] sysfs_write_file+0x42/0x63
 [<c015de22>] vfs_write+0xb6/0xe2
 [<c015deec>] sys_write+0x3c/0x62
 [<c0103337>] syscall_call+0x7/0xb
hub 3-0:1.0: resubmit --> -108
hub 4-0:1.0: resubmit --> -108
hub 2-0:1.0: resubmit --> -108
ACPI: PCI interrupt 0000:00:02.0[A] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:1d.0 to 64
PCI: Setting latency timer of device 0000:00:1d.1 to 64
PCI: Setting latency timer of device 0000:00:1d.2 to 64
PCI: cache line size of 32 is not supported by device 0000:00:1d.7
ehci_hcd 0000:00:1d.7: USB 2.0 restarted, EHCI 1.00, driver 26 Oct 2004
ACPI: PCI interrupt 0000:00:1f.1[A] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI interrupt 0000:00:1f.5[B] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:1f.5 to 64
ACPI: PCI interrupt 0000:00:1f.6[B] -> GSI 11 (level, low) -> IRQ 11
PCI: Setting latency timer of device 0000:00:1f.6 to 64
ACPI: PCI interrupt 0000:02:01.0[A] -> GSI 11 (level, low) -> IRQ 11
ipw2100: eth1: ipw2100_verify failed: -5
ipw2100: eth1: Failed to power on the adapter.
ipw2100: eth1: Failed to start the firmware.
Restarting tasks... done
Comment 1 petrosyan 2005-01-20 01:33:29 EST
this bug is still present in kernel-2.6.10-1.741_FC3
Comment 2 Sammy 2005-01-20 09:15:34 EST
I am having the same problem with ipw2200 using the devel tree kernel. 
What should we look for? Is it hotplug? 
Comment 3 petrosyan 2005-01-26 08:46:00 EST
this bug is still present in kernel-2.6.10-1.753_FC3
Comment 4 petrosyan 2005-01-31 20:25:34 EST
this bug has been fixed in ipw2100 version 1.0.3
from Changelog:
* Fixed #523 problem with suspend not working (thanks to Stefan Dosinger and
Henrik Brix Andersen)

Please update ipw2100 driver.
Comment 5 petrosyan 2005-02-10 03:21:51 EST
Resume after suspend still fails with kernel-2.6.10-1.762_FC3 since it still
uses ipw2100-1.0.0.
The latest version of ipw2100 drivers is 1.0.5 available at:
http://ipw2100.sourceforge.net/
Comment 6 petrosyan 2005-02-19 21:23:25 EST
this bug is still present in kernel-2.6.10-1.766_FC3
Comment 7 petrosyan 2005-03-12 10:03:16 EST
with the inclusion of ipw2100-1.0.3 this bug has been finally fixed in
kernel-2.6.11-1.3_FC3 which can be downloaded from
http://people.redhat.com/davej/kernels/Fedora/FC3/RPMS.kernel/

Note You need to log in before you can comment on or make changes to this bug.