Bug 144939 - ACPI: FC2/FC3: hda lost interrupt when suspending
ACPI: FC2/FC3: hda lost interrupt when suspending
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 16:38 EST by Hans van de Koot
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:44:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from lspci -v (4.64 KB, text/plain)
2005-01-12 16:43 EST, Hans van de Koot
no flags Details
output from lsmod (1.40 KB, text/plain)
2005-01-12 16:44 EST, Hans van de Koot
no flags Details
output from dmesg (13.45 KB, text/plain)
2005-01-12 16:45 EST, Hans van de Koot
no flags Details

  None (edit)
Description Hans van de Koot 2005-01-12 16:38:50 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I am using FC3 on a Sony Vaio PCG-K215M. Suspend feature does not
work. Suspend is initiated correctly, but then after 30 seconds or so
I get a message "hda lost interrupt". The machine then does enter
suspend mode.
When I wake it up, there is no disk activity and no video.

I've tried to see if SMART controls interfere with ACPI. IF SMART is
off, the "hda lost interrupt" message is preceeded by a DMA timeout.

With every new kernel, I can see that ACPI support is improving
(thanks for all the hard work on this); see also current ACPI-related
dmesg output below; but this problem stays.


Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737_FC3 (and all previous 2.6 kernels I have used)

How reproducible:
Always

Steps to Reproduce:
1. Boot into KDE
2. Choose "Suspend" from battery applet
3.
    

Actual Results:  All processes are stopped.
Long pause (30 seconds or so).
"hda interrupt lost".
Machine seems to enter suspend mode (red mode indicator flashing on
laptop).
Machine wakes up, but no disk activity and no screen.
I have to power down to regain control.

Expected Results:  Machine should resume normally.

Additional info:

ACPI-related lines in dmesg:
############################################################
BIOS-e820: 000000001df70000 - 000000001df7f000 (ACPI data)
BIOS-e820: 000000001df7f000 - 000000001df80000 (ACPI NVS)
ACPI: RSDP (v000 PTLTD ) @ 0x000f6fc0
ACPI: RSDT (v001 SONY K7 0x06040000 LTP 0x00000000) @ 0x1df7a803
ACPI: FADT (v001 SONY K7 0x06040000 PTL 0x000f4240) @ 0x1df7ef64
ACPI: BOOT (v001 PTLTD $SBFTBL$ 0x06040000 LTP 0x00000001) @ 0x1df7efd8
ACPI: DSDT (v001 SONY K7 0x06040000 MSFT 0x0100000e) @ 0x00000000
ACPI: PM-Timer IO Port: 0x8008
ACPI: setting ELCR to 0200 (from 0c00)
ACPI: Subsystem revision 20041105
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (00:00)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNK0] (IRQs 4) *0, disabled.
ACPI: PCI Interrupt Link [LNK1] (IRQs 3) *11
ACPI: PCI Interrupt Link [LNK2] (IRQs 10) *11
ACPI: PCI Interrupt Link [LNK3] (IRQs 11) *0, disabled.
ACPI: PCI Interrupt Link [LNK4] (IRQs 6) *10
ACPI: PCI Interrupt Link [LNK5] (IRQs *11)
ACPI: PCI Interrupt Link [LNK6] (IRQs 9) *0, disabled.
ACPI: PCI Interrupt Link [LNK7] (IRQs 9) *11
ACPI: PCI Interrupt Link [LNK8] (IRQs 3 4 5 7 10 *11)
ACPI: Embedded Controller [EC0] (gpe 24)
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.PPB_._PRT]
pnp: PnP ACPI init
pnp: PnP ACPI: found 11 devices
PCI: Using ACPI for IRQ routing
apm: overridden by ACPI.
ACPI: Processor [CPU0] (supports C1 C2)
ACPI: Processor [CPU0] (supports 8 throttling states)
ACPI: Thermal Zone [TZ01] (66 C)
ACPI: PCI Interrupt Link [LNK6] enabled at IRQ 9
ACPI: PCI interrupt 0000:00:03.0[A] -> GSI 9 (level, low) -> IRQ 9
ACPI: PCI interrupt 0000:00:0f.0[A]: no GSI - using IRQ 0
ACPI wakeup devices:
ACPI: (supports S0 S3 S4 S5)
ACPI: PCI Interrupt Link [LNK1] enabled at IRQ 3
ACPI: PCI interrupt 0000:00:12.0[A] -> GSI 3 (level, low) -> IRQ 3
ACPI: PCI Interrupt Link [LNK7] enabled at IRQ 9
ACPI: PCI interrupt 0000:00:04.0[A] -> GSI 9 (level, low) -> IRQ 9
ACPI: PCI Interrupt Link [LNK5] enabled at IRQ 11
ACPI: PCI interrupt 0000:00:0c.2[C] -> GSI 11 (level, low) -> IRQ 11
ACPI: PCI Interrupt Link [LNK2] enabled at IRQ 10
ACPI: PCI interrupt 0000:00:0c.0[A] -> GSI 10 (level, low) -> IRQ 10
ACPI: PCI Interrupt Link [LNK4] enabled at IRQ 6
ACPI: PCI interrupt 0000:00:0c.1[B] -> GSI 6 (level, low) -> IRQ 6
ACPI: PCI Interrupt Link [LNK0] enabled at IRQ 4
ACPI: PCI interrupt 0000:00:0a.0[A] -> GSI 4 (level, low) -> IRQ 4
ACPI: PCI interrupt 0000:00:0a.2[C] -> GSI 10 (level, low) -> IRQ 10
ACPI: AC Adapter [ACAD] (on-line)
ACPI: Battery Slot [BAT1] (battery present)
ACPI: Power Button (FF) [PWRF]
ACPI: Sleep Button (CM) [SBTN]
ACPI: Lid Switch [LID]
ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
ACPI: PCI interrupt 0000:01:05.0[A] -> GSI 4 (level, low) -> IRQ 4
Comment 1 Hans van de Koot 2005-01-12 16:43:50 EST
Created attachment 109693 [details]
output from lspci -v
Comment 2 Hans van de Koot 2005-01-12 16:44:53 EST
Created attachment 109694 [details]
output from lsmod
Comment 3 Hans van de Koot 2005-01-12 16:45:23 EST
Created attachment 109695 [details]
output from dmesg
Comment 4 Dave Jones 2005-07-15 14:02:16 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 5 Hans van de Koot 2005-07-15 16:07:58 EDT
I'm afraid that, after struggling with several problems for months, I've given
up on Fedora and have gone back to running Windows XP on my Sony. Hans

Note You need to log in before you can comment on or make changes to this bug.