Bug 144940 - poor recording of emu10k1
poor recording of emu10k1
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-12 16:48 EST by Need Real Name
Modified: 2015-01-04 17:15 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 19:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Noice in arecord a.wav : Recording WAVE 'a.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono (37.04 KB, audio/x-wav)
2005-01-12 16:50 EST, Need Real Name
no flags Details
recording at 22050, poor quality, static in background (124.04 KB, audio/x-wav)
2005-01-12 16:54 EST, Need Real Name
no flags Details
recording at 44100, poor quality, intermitten signal (216.04 KB, audio/x-wav)
2005-01-12 16:57 EST, Need Real Name
no flags Details
disruption of signal at 32000 (796.04 KB, audio/x-wav)
2005-01-12 17:17 EST, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2005-01-12 16:48:31 EST
In
kernel-2.6.10-1.737_FC3
(and earlier) versions recording from a line work poorly
for emu10k1.
sound either have background noice or recording quality is poor.
In the same time playing sound seems to be working file.
Sound samples attached.
There was no such problem in 2.4


/etc/sysconfig/hwconf

class: OTHER
bus: PCI
detached: 0
driver: emu10k1-gp
desc: "Creative Labs SB Live! MIDI/Game Port"
vendorId: 1102
deviceId: 7002
subVendorId: 1102
subDeviceId: 0020
pciType: 1
pcidom:    0
pcibus:  3
pcidev:  2
pcifn:  1

aumix:
vol:48:48:P
bass:50:50:P
treble:50:50:P
synth:100:100:P
pcm:74:74:P
speaker:0:0:P
line:77:77:R
mic:0:0:P
cd:0:0:P
pcm2:92:92:P
igain:4:4:P
line1:0:0:P
dig1:0:0:P
phin:0:0:P
phout:100:100:P
video:0:0:P
Comment 1 Need Real Name 2005-01-12 16:50:54 EST
Created attachment 109696 [details]
Noice in arecord a.wav : Recording WAVE 'a.wav' : Unsigned 8 bit, Rate 8000 Hz, Mono
Comment 2 Need Real Name 2005-01-12 16:54:55 EST
Created attachment 109698 [details]
recording at 22050, poor quality, static in background

/usr/bin/esdrec -m -r 22050 s_22050.wav_FF.mZ5855
/usr/bin/sox -t raw -r 22050 -w -s -c 1 s_22050.wav_FF.mZ5855 s_22050.wav


esdplay s_22050.wav
Comment 3 Need Real Name 2005-01-12 16:57:08 EST
Created attachment 109699 [details]
recording at 44100, poor quality, intermitten signal

/usr/bin/esdrec -m -r 44100 s_44100.wav_FF.Mw5864
/usr/bin/sox -t raw -r 44100 -w -s -c 1 s_44100.wav_FF.Mw5864 s_44100.wav

esdplay s_44100.wav
Comment 4 Need Real Name 2005-01-12 17:17:43 EST
Created attachment 109700 [details]
disruption of signal at 32000

/usr/bin/esdrec -m -r 32000 s_32000.wav_FF.ju6071
/usr/bin/sox -t raw -r 32000 -w -s -c 1 s_32000.wav_FF.ju6071 s_32000.wav

aplay  s_32000.wav
Comment 5 Dave Jones 2005-07-15 15:10:27 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 6 Need Real Name 2005-07-15 17:23:01 EDT
exactly the same problem with
kernel-2.6.12-1.1372_FC3
(I did not upgraded to fc4 yet).
This is a very annoying bug, I can not use the sound since 2.6 because of it.
Comment 7 Dave Jones 2005-07-15 19:01:23 EDT
I'd hoped that one of the many upstream alsa resyncs would have fixed this.

As this bug has been around for quite a while, you may have better luck
reporting it directly to the ALSA developers at https://bugtrack.alsa-project.org
Comment 8 Vladimir Kotal 2005-09-26 13:55:24 EDT
I have also troubles recording sound with ALSA drivers for emu10k1. I cannot
record any sound at all even with testing kernel:

Linux erazim.devnull-lab.cz 2.6.13-1.1524_FC4 #1 Wed Sep 21 00:00:00 EDT 2005
i686 athlon i386 GNU/Linux

[techie@erazim ~]$ more /etc/sysconfig/hwconf
-
class: OTHER
bus: PCI
detached: 0
driver: emu10k1-gp
desc: "Creative Labs SB Live! MIDI/Game Port"
vendorId: 1102
deviceId: 7002
subVendorId: 1102
subDeviceId: 0020
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  a
pcifn:  1
-


tested with arecord/aplay, audacity, skype, ...
Comment 9 Vladimir Kotal 2005-09-26 14:10:54 EDT
Ah, I have forgotten relevant part of hwconf:

class: AUDIO
bus: PCI
detached: 0
driver: snd-emu10k1
desc: "Creative Labs SB Live! EMU10k1"
vendorId: 1102
deviceId: 0002
subVendorId: 1102
subDeviceId: 8065
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  a
pcifn:  0
-
Comment 10 Vladimir Kotal 2005-09-26 14:13:20 EDT
and also:

[techie@erazim ~]$ cat /proc/asound/cards
0 [Live           ]: EMU10K1 - SB Live [Unknown]
                     SB Live [Unknown] (rev.10, serial:0x80651102) at 0xb000, irq 11
[techie@erazim ~]$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.9b (Thu Jul 28 12:20:13
2005 UTC).
[techie@erazim ~]$

Note You need to log in before you can comment on or make changes to this bug.