Bug 144960 - kernel panic when mounting root filesystem (read/write) in kernel/module.c:2043
Summary: kernel panic when mounting root filesystem (read/write) in kernel/module.c:2043
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-13 00:41 UTC by Todd A. Fisher
Modified: 2015-01-04 22:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 22:37:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Todd A. Fisher 2005-01-13 00:41:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0 (ax)

Description of problem:
I upgraded three machines kernels this morning.  One running fc2 to
the new kernel.  During it's reboot it locked up with a kernel panic.
This resulted in damage in my harddrive.  Lost /usr on my mail server.
 Before that I had already updated the kernel on my notebook(i686). 
During it's first reboot into the new kernel it locked up while
checking the root filesystem (ext3).  I rebooted with no problems at
that point and my notebook started up without issue.  Then this
afternoon after getting the mail server rebuilt, I decided to change
/etc/inittab to disable graphical boot on my notebook.  So, to test it
i rebooted my notebook.  Now i have the same kernel panic on my
notebook screen as I had on my mail server this morning.

Remounting root filesystem in read-write mode: [ OK ]
Kernel panic - not syncing: kernel/module.c:2043:
spin_lock(kernel/module.c:c0347240) already locked by kernel/module.c/2043



Version-Release number of selected component (if applicable):
kernel-2.6.10-1.737

How reproducible:
Sometimes

Steps to Reproduce:
1. reboot
    

Additional info:

Comment 1 Dave Jones 2005-07-15 18:11:32 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 2 Todd A. Fisher 2005-07-15 19:08:30 UTC
yes, upgrading to the newer kernel did indeed fix the problems I was having


Note You need to log in before you can comment on or make changes to this bug.