Bug 144977 - ImageMagick-devel depends upon XFree86-devel but is not a dependency
ImageMagick-devel depends upon XFree86-devel but is not a dependency
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: ImageMagick (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 05:30 EST by David Grierson
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-26 01:01:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Grierson 2005-01-13 05:30:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Trying to use PEAR to install imagick PHP library - this is failing
during the configure phase of the build.

The installer uses Magick-config --libs to determine the compile line
required for programs using ImageMagick-devel, this gives the
following output:

-lMagick -ltiff -lfreetype -ljpeg -lpng -ldpstk -ldps -lXext -lSM
-lICE -lX11 -lbz2 -lxml2 -lz -lpthread -lm

It appears that ImageMagick-devel requires the XFree86-devel RPM in
order to have all of the appropriate libraries to compile but
ImageMagick-devel can be installed without XFree86-devel being present.



Version-Release number of selected component (if applicable):
ImageMagick-devel-5.5.6-7

How reproducible:
Always

Steps to Reproduce:
1. Install clean system
2. Install ImageMagick-devel using up2date
3. Attempt to build an ImageMagick program using the compile line
specified by Magick-config --libs
    

Actual Results:  Program compile will fail due to lack of -lX11
-ldpstk -ldps (& other) libraries.

Expected Results:  Program should compile successfully.

Additional info:
Comment 1 Matthias Clasen 2005-04-26 01:01:04 EDT
Fixed in rawhide. FC3 update will be pushed to testing tomorrow.

Note You need to log in before you can comment on or make changes to this bug.