Bug 145003 - Problems talking to CD drive
Problems talking to CD drive
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 12:02 EST by Paul Black
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 12:14:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Black 2005-01-13 12:02:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.5)
Gecko/20041110 Firefox/1.0

Description of problem:
In trying to burn a CD drive I find that the drive is not recognised
by various applications (k3n, cdrecord etc). If I do "cdrecord
-scanbus" I get
scsibus1:
ST' 'RW/DVD GCC-21N' 'A0' Removable CD-ROM
        1,1,0   101) *
        1,2,0   102) *
as the output rather than something like:
        1,0,0   100) HL-DT-STCD-RW/DVD-ROM GCC-4241N
        1,1,0   101) *
        1,2,0   102) *

I think this is a kernel issue because similar output appears in the
message at boot time. I.e. it outputs:
Jan 11 09:42:40 zurich kernel: hdc: HL
DT-STCD
RW/DVD-ROM GCC-21N, ATAPI CD/DVD-ROM drive
rather than 
Dec 10 11:57:35 zurich kernel: hdc: HL-DT-STCD-RW/DVD-ROM GCC-4241N,
ATAPI CD/DVD-ROM drive

(In the failing output, there are ^M and ^T characters inserted).

About 1 in 5 boots results in correct output and a working drive.
Sometimes, the issue has resolved itself on a booted machine but I've
not determined what steps create this scenario.

This issue was present in versions earlier than 2.6.10-1.737_FC3 but I
don't have a specific list.


Version-Release number of selected component (if applicable):
2.6.10-1.737_FC3

How reproducible:
Sometimes

Steps to Reproduce:
1. Boot PC
2. Look at /var/log/dmesg or do "cdrecord -scanbus"

    

Actual Results:  Drive string is corrupt.

Expected Results:  String should not be corrupt.

Additional info:
Comment 1 Paul Black 2005-01-13 12:14:01 EST
I've just noticed that the same corrupt drive string is present iwhen
viewed from the BIOS. I guess it's a hardware problem. D'oh!

Note You need to log in before you can comment on or make changes to this bug.