Bug 145035 - lvm_t can't access device_t:blk_file, removable_device_t:blk_file
Summary: lvm_t can't access device_t:blk_file, removable_device_t:blk_file
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-strict   
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-13 21:25 UTC by Ivan Gyurdiev
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 18:26:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ivan Gyurdiev 2005-01-13 21:25:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041228 Firefox/1.0 Fedora/1.0-8

Description of problem:
audit(1105648138.586:0): avc:  denied  { read } for  pid=1371
exe=/sbin/lvm.static name=md0 dev=tmpfs ino=4128
scontext=system_u:system_r:lvm_t tcontext=system_u:object_r:device_t
tclass=blk_file

audit(1105648138.586:0): avc:  denied  { ioctl } for  pid=1371
exe=/sbin/lvm.static path=/dev/md0 dev=tmpfs ino=4128
scontext=system_u:system_r:lvm_t tcontext=system_u:object_r:device_t
tclass=blk_file

audit(1105648138.586:0): avc:  denied  { read } for  pid=1371
exe=/sbin/lvm.static name=hdc dev=tmpfs ino=1286
scontext=system_u:system_r:lvm_t
tcontext=system_u:object_r:removable_device_t tclass=blk_file



Version-Release number of selected component (if applicable):
selinux-policy-strict-1.21.1-1

How reproducible:
Always

Steps to Reproduce:
1. Boot with strict policy

Additional info:

Comment 1 Daniel Walsh 2005-01-18 22:01:38 UTC
Looks like /dev/md0 has the wrong context on it.

Are you running under permissive mode.  Do you see these under enforcing?


Comment 2 Ivan Gyurdiev 2005-01-18 22:14:35 UTC
Permissive. You are correct - right now /dev/md0
has the context:  system_u:object_r:fixed_disk_device_t.

At the same time I see context  tcontext=system_u:object_r:device_t 
in dmesg, so it must have changed at some point.

I will enable enforcing and close if I can't reproduce.



Comment 3 Ivan Gyurdiev 2005-01-20 18:26:15 UTC
Closing bug, will reopen if I see this again.
I am now running in enforcing mode.



Note You need to log in before you can comment on or make changes to this bug.