Bug 145077 - ndiswrapper compiles with errors under kernel-linux-2.6.10-1.8_FC2
ndiswrapper compiles with errors under kernel-linux-2.6.10-1.8_FC2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-13 22:17 EST by JCC
Modified: 2015-01-04 17:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-13 23:21:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JCC 2005-01-13 22:17:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
Ndiswrapper compiles successfully in previous versions of the kernel.
 Below is the output from the failing compilation with kernel
2.6.10-1.8_FC2.  Because ndiswrapper is my network support on my
platform (compaq pesario 2100), I consider this problem as
functionality loss and "serious".

make -C driver install
make[1]: Entering directory
`/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver'
make -C /lib/modules/2.6.10-1.8_FC2custom/build
SUBDIRS=/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver
DRV_VERSION=0.7 modules
make[2]: Entering directory `/usr/src/linux-2.6.10-1.8_FC2'
  CC [M]  /home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.o
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c: In
function `ndis_suspend':
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c:743: error:
too many arguments to function `pci_save_state'
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c: In
function `ndis_resume':
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c:773: error:
too many arguments to function `pci_restore_state'
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c: In
function `ndis_init_one':
/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.c:973: error:
too many arguments to function `pci_restore_state'
make[3]: ***
[/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver/wrapper.o] Error 1
make[2]: ***
[_module_/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-2.6.10-1.8_FC2'
make[1]: *** [default] Error 2
make[1]: Leaving directory
`/home/johnc/Broadcom/ndis/ndiswrapper-0.7/driver'
make: *** [install] Error 2



Version-Release number of selected component (if applicable):
linux-2.6.10-1.8_FC2 and ndiswrapper-0.7

How reproducible:
Always

Steps to Reproduce:
1.  configure, compile, and install linux kernel-2.6.10-1.8_FC2
2.  cd to ndiswrapper makefile directory
3.  make install
    

Actual Results:  see description above.

Expected Results:  expected ndiswrpper to compile and install as in
previous versions of the kernel

Additional info:
Comment 1 Dave Jones 2005-01-13 23:21:19 EST
ndiswrapper needs fixing.

Note You need to log in before you can comment on or make changes to this bug.