Bug 145094 - named.conf is not set to config(noreplace)
Summary: named.conf is not set to config(noreplace)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: bind   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-14 11:20 UTC by Johannes Schmid
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 16:45:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johannes Schmid 2005-01-14 11:20:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3)
Gecko/20040910

Description of problem:
As the named.conf file the current bind configuration, it should not
get replaced when updating the package (thus causing some software to
fail because the config file is reset to a caching-only name server!)


Version-Release number of selected component (if applicable):
bind-chroot-9.2.4-2

How reproducible:
Always

Steps to Reproduce:
1. install bind-chroot
2. change named.conf
3. update to bind-chroot-9.2.4-2
    

Actual Results:  current (correct) config file will get renamed to
named.conf.rpmsave, standard named.config is now the default config
file -- your software breaks :-(

Expected Results:  store new named.conf as named.conf.rpmnew, do not
touch old named.conf

Additional info:

Comment 1 Jason Vas Dias 2005-01-14 16:45:56 UTC
This is not an issue with the bind-* package, but with the 
caching-nameserver package.

No bind-* package supplies any named configuration files,
unless none exist on the system, when only rndc.conf, rndc.key,
and the bare minimum named.conf sufficient to allow named to
run are installed.

When you install the 'caching-nameserver' package, which consists
entirely of the named configuration files, you are asking for 
a caching-nameserver named configuration to be installed.  

If you want to customize your named configuration files, and run
something other / more than a caching-only nameserver, uninstall
the caching-nameserver package.

Unless caching-nameserver replaces any existing named configuration
files on installation / upgrade, there would be no way of guaranteeing
after installation that a caching-nameserver was in place afterwards,
and no way of upgrading these configuration files. 

Hence this bug is being closed as 'NOT A BUG'. 
 


Note You need to log in before you can comment on or make changes to this bug.