This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 145099 - haldaemon still crashes on startup with b44 driver
haldaemon still crashes on startup with b44 driver
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-14 07:21 EST by Need Real Name
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-20 13:50:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-01-14 07:21:20 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The b44 driver still does not work with the current hal-4.5 from
updates. Only the linkup rpms from
http://people.redhat.com/davidz/linkup/ work without hanging the system.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Bootup system
2.Wait for haldaemon to start
3.Hangs
    

Actual Results:  System Hang

Expected Results:  Continue to bootup

Additional info:
Comment 1 David Zeuthen 2005-01-17 15:34:03 EST
I'm pretty sure that I've got a fix for this one; please try these
packages 

 http://people.redhat.com/davidz/hal-cvs20050117/

This contains a workaround for the broken b44 driver that doesn't like
to have the mii registers looked at. You will need a 2.6.10 kernel
from either Rawhide or FC3 updates. Thanks.
Comment 2 David Zeuthen 2005-01-20 13:50:15 EST
So, I've got someone on the hal mailing list to test this

 http://lists.freedesktop.org/archives/hal/2005-January/001686.html

I believe this is exactly the same issue so I'm closing this bug,
since this is fixed in hal-0.4.6 which will be in Rawhide and FC3
updates soon.

Note You need to log in before you can comment on or make changes to this bug.